none
[IIS 6] SSL Verbindung mit 128-bit Verschlüsselung RRS feed

  • Frage

  • Hallo,

    ich arbeite noch nicht sehr lange mit dem IIS und habe damit nun eine SSL-Verbindung hergestellt z.B.: https://92.159.124.3/test.html. Zusätzlich habe ich noch den Zertifikatsserver (unter Systemsteuerung/Software) installiert, da ich meine eigenen Zertigikate nutze.

    Das Zertifikat habe ich mit SelfSSL eingerichtet und ich Verlange nun mit "Sicheren Kanal vorraussetzen", das https verwendet wird. Unter dem Häcken für diese option gibts noch "128 Bit Verschlüsselung erforderlich". Wenn ich jedoch diese Option aktiviere, kann meine Seite nicht mehr besucht werden. Was muss ich hier ändern, damit dies funktioniert?

    Eigentlich wollte ich ohne die Hilfe von SelfSSL ein Zertifikat erstellen, aber das hat garnicht funktioniert, da in den Eigenschaften der Webseite unter "Verzeichnissicherheit" und Serverzertifikat kein "Zertifikatsserver" gefunden wurde und ich nur Textdateien erstellen konnte.

    Ich benutze Windows Server 2003 und IIS6.

     

    danke für die Antworten und Vorschläge

    acdc

    Montag, 15. November 2010 10:13

Alle Antworten

  • Hi,
    Wenn ich jedoch diese Option aktiviere, kann meine Seite nicht mehr besucht werden.

    und das heißt jetzt was genau? Ohne detaillierte Angabe, was genau wie nicht funktioniert, kann man da leider nicht helfen.

     


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community
    Montag, 15. November 2010 10:50
    Moderator
  • Es funktioniert nicht, wenn ich im Browser z.B.: https://92.159.124.3/test.html eingebe - Es erscheint die Meldung, dass die Seite nicht gefunden wird. DEaktiviere ich jedoch die 128Bit Verschlüsselung, so wird die Seite richtig angezeigt. Ich habe gelesen, dass das am Browser liegt und nicht am Server! Ist das so?

    acdc

    Montag, 15. November 2010 10:54
  • Hi,

    Es funktioniert nicht, wenn ich im Browser z.B.: https://92.159.124.3/test.html eingebe - Es erscheint die Meldung, dass die Seite nicht gefunden wird. DEaktiviere ich jedoch die 128Bit Verschlüsselung, so wird die Seite richtig angezeigt. Ich habe gelesen, dass das am Browser liegt und nicht am Server! Ist das so?

    hast Du eine im IIS eine Bindung für https angelegt? Einzig die Verschlüsselung zu aktivieren, reicht da nicht aus.

    IIS MMC
     -> <Website>
        -> Eigenschaften
           -> Reiter "Website"
              -> Button "Erweitert"
                 -> ...

     


    Gruß, Stefan
    Microsoft MVP - Visual Developer ASP/ASP.NET
    http://www.asp-solutions.de/ - Consulting, Development
    http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community
    Montag, 15. November 2010 11:23
    Moderator
  • Hallo,

    ich weis zwar nicht genau was man dort einstellt, aber ich sehe im Fenster "Erweiterte Identifikation für Websites", unter mehrere "SSL-Identitäten für diese Website" eine Zeile mit "Standard" und port: "443".

     

    acdc

    Montag, 15. November 2010 12:56