none
IE 10 lädt automatische Konfiguration nicht RRS feed

  • Frage

  • Guten Abend zusammen,

    Ich habe mal wieder ein klitzekleines Problemchen.

    Ich möchte gerne den IE 10 per automatische Konfiguration global konfigurieren. Dazu habe ich mir mit dem IEAK 10 ein passendes Konfigurationsscript in Form einer INS Datei erstellt und zusammen mit der CAB Datei auf einem Webserver per http am Port 80 bereit gestellt. Der Link ist im IE unter Verbindungen im passenden Feld eingetragen.

    Die INS Datei lässt sich problemlos vom client downloaden. Jedoch ignoriert der Client die Konfigurationen.

    Das Branding Logfile des IE bestätigt dies.

    Die Konfigdatei wurde allerdings auf einem anderen Client mit dem IEAK erstellt.

    Beim schreiben dieses Beitrages fällt mir auf, das die Konfig auf einem 2008R2 mit IE 10 erstellt ist. Die Konfig aber auf einem Win 7 mit IE 10 angewandt werden soll. Spielt daa eine Rolle?

    Ich hab hier noch andere Beiträge gefunden, wie das mit GPP funktioniert. Das sollte aber erst der zweite Schritt sein.

    Hat jemand eine Idee?

    Danke schon mal im Voraus.

    Mittwoch, 18. September 2013 18:49

Antworten

  • So liebe Forengemeinde. 

    Ich konnte das Problem jetzt selber lösen. :-)

    Ursache ist hier ein fehlerhafter Eintrag in der XML. 
    Der Eintrag wird zwar korrekt in der GPO gesetzt, bleibt aber mit dem Parameter disabled="1" in der XML entsprechend deaktiviert. Der Parameter wird auch mit F5/F6 zwar in der GUI grün markiert und somit eigentlich auch aktiviert, aber in der XML wird die Einstellung nicht geschrieben.

    Das Ganze kann ich hier in allen Umgebungen reproduzieren. Auch in einer eigens dafür aufgesetzten Domäne auf Basis Server 2012 konnte ich das Phänomen nachstellen.

    • Als Antwort markiert Phantomias Freitag, 11. Oktober 2013 08:14
    Freitag, 11. Oktober 2013 07:01

Alle Antworten

  • Ich habe jetzt mal weiter recherchiert. Der Client lädt die Config.ins. Die GPO mit den GPP wird problemlos gelesen.

    Also kann es mMn nur an der Config.ins oder deren Bereitstellung über den IIS 7.5 eines 2008R2 Servers. Die Dateiendung .ins ist dort ebenfalls als entsprechende Applications registriert.

    Dann habe ich im MSDN gelesen, das die config.uns im ANSI Format vorliegen muss. Habe auch das getan.

    Bin langsam am Ende mit meinen Ideen.

    Kann mir jemand einen Tip geben?

    Danke.

    Donnerstag, 19. September 2013 20:34
  • Beim IE10 gibt es keine IE-Wartung mehr, möglicherweise sind die INS-Dateien ja in der Wartung untergebracht, dann wäre mir klar weshalb die Einstellungen nicht greifen.

    Wenn Du die gleichen Einstellungen per GPP setzt, dann funktioniert es?


    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/

    Samstag, 21. September 2013 11:53
  • Wenn ich die Einstellungen per GPP setze, greifen diese auch.
    Ich kann auch im NetMon sehen, das die INS Datei vom Webserver geladen wird. Nur angewandt wird sie nicht.
    Mittwoch, 25. September 2013 20:24
  • Wenn ich die Einstellungen per GPP setze, greifen diese auch.


    OK, was spricht gegen die Verwendung von GPPs?
    Ich kann auch im NetMon sehen, das die INS Datei vom Webserver geladen wird. Nur angewandt wird sie nicht.

    Welche Einstellungen bzw. Registry Key importierst Du mit dieser Datei? Werden die Einstellungen angewandt, wenn Du für diese Aktion UAC abschaltest? Anschließend neu starten, erst jetzt die INS importieren.

    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/

    Mittwoch, 25. September 2013 20:47
  • Ich konfiguriere mit der INS Datei den IE 10 so wie ich ihn haben will. Dazu gehören die Favoriten, SearchBar, Proxy Einstellung, Einstellungen für Internet und Intranet. Einige Einstellungen lassen sich so leider auch nicht über die GPP abbilden.

    Leider habe ich bisher kein brauchbares ToDo für die Bereitstellung zentraler Konfiguration gefunden.

    Wie kann ich denn die INS Konfig manuell importieren?

    Donnerstag, 26. September 2013 07:46
  • Ich konfiguriere mit der INS Datei den IE 10 so wie ich ihn haben will. Dazu gehören die Favoriten, SearchBar, Proxy Einstellung, Einstellungen für Internet und Intranet. Einige Einstellungen lassen sich so leider auch nicht über die GPP abbilden.

    Welche Einstellungen kannst Du nicht über GPP abbilden?

    Leider habe ich bisher kein brauchbares ToDo für die Bereitstellung zentraler Konfiguration gefunden.

    Wie kann ich denn die INS Konfig manuell importieren?


    Ich glaube die INS ist mit dem Wegfall der IE-Wartung überflüssig. Genaues weiß ich aber nicht.

    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/

    Donnerstag, 26. September 2013 16:59
  • Ich habe die Einstellungen jetzt per GPP gesetzt. Die Einstellungen funktionieren auch soweit.
    Was mich nur wundert, ich habe die Proxyeinstellungen gesetzt, die werden aber nicht in den GPO Settings und im IE angezeigt.
    Surfen am Client geht aber problemlos.

    Trotzdem würde ich gerne wissen, warum die zentrale Konfigurationsdatei nicht eingelesen wird. In der Hilfe vom IEAK 10 wird ja auch explizit geschrieben, das man die INS Datei "einfach" auf 'nen Webserver packen soll.
    Der MIME-Handler für die INS Dateien sind entsprechend im IIS registriert.

    Ich habe dafür bisher keine Lösung gefunden.

    Freitag, 27. September 2013 10:09
  • Ich habe die Einstellungen jetzt per GPP gesetzt. Die Einstellungen funktionieren auch soweit.
    Was mich nur wundert, ich habe die Proxyeinstellungen gesetzt, die werden aber nicht in den GPO Settings und im IE angezeigt.
    Surfen am Client geht aber problemlos.

    Hast Du den Proxy pro Benutzer oder pro Maschine gesetzt? Wenn Du ihn per Benutzer setzt, ist er auch eingetragen und muss natürlich auch als Benutzer zu sehen sein. Zumindest ist es bei uns so. In diesem Thread wird über einen Bug in den IE10 GPPs gesprochen, evtl. hilft es dir: http://social.technet.microsoft.com/Forums/de-DE/aaf737ff-2ba9-49b2-bd9b-1a9fa356407e/internet-explorer-10-proxysettings-werden-nicht-angewendet

    Trotzdem würde ich gerne wissen, warum die zentrale Konfigurationsdatei nicht eingelesen wird. In der Hilfe vom IEAK 10 wird ja auch explizit geschrieben, das man die INS Datei "einfach" auf 'nen Webserver packen soll.
    Der MIME-Handler für die INS Dateien sind entsprechend im IIS registriert.

    Ich habe dafür bisher keine Lösung gefunden.


    Ich weiß es nicht, vielleicht wirst Du hier aufgeklärt: http://www.windowspro.de/wolfgang-sommergut/zentrale-ie-konfiguration-internet-explorer-wartung-vs-gpo-vs-ieak Ansonsten einen Call beim MSFT Support eröffnen.

    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/

    Freitag, 27. September 2013 13:56
  • Nachdem ich mich jetzt entschieden habe, die Einstellungen per GPP zu verteilen, stelle ich fest, das Alle Einstellungen auch übernommen werden. Eine Ausnahme bilden hier die Proxyeinstellungen.
    Die GPO wird auf einem Server 2012 erstellt.
    In den GPP Einstellugnen ist der IE 10 ausgewählt.
    Die Proxyeinsellungen werden dort auch eingetragen und mit F5 auch entsprechend grün markiert.
    Die Einstellungen kommen jedoch am Windows 7 / Server 2008R2 sowie Windows 8 / Server 2012 nicht an.
    Das die erste Anzeige leer bleibt, habe ich bereits gelesen. Es soll sich hier um einen Bug handeln. Aber auch im Bereich "Erweitert" sind keine Eintragungen.

    Habe mir heute Nachmittag schon den Blog von Matthias diesbezüglich durchgelesen. Logging aktiviert etc.
    Im Eventlog steht "Internetexplorer Branding in 43 Milisekunden durchgeführt". Jedoch als Fehler markiert.

    So langsam blick ich da nicht mehr durch.

    Was mache ich falsch?

    Montag, 30. September 2013 14:24
  • Siehst du denn die Einstellungen vom Proxy in der GPMC? Wenn nein, dann lösch doch beim Proxy wieder alles raus. Jetzt wie in diesem Thread vorgehen: http://social.technet.microsoft.com/Forums/de-DE/aaf737ff-2ba9-49b2-bd9b-1a9fa356407e/internet-explorer-10-proxysettings-werden-nicht-angewendet

    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/

    Samstag, 5. Oktober 2013 18:51
  • Ich habe nun die Info von Microsoft, das es ein Problem bei der Anzeige der Proxyeinstellungen in der GPMC gibt.

    Bei Microsoft sind wohl auch schon mehrere Fälle bekannt. Die Aussage war: "... es ist eindeutig by Design."
    Bisher gibt es kein Fix dafür.

    Ich werde jetzt mal versuchen, das ganze nochmal autag nachzustellen.

    Mittwoch, 9. Oktober 2013 13:04
  • Das mit dem Proxy und der GPMC hatte ich doch schon in meinem Posting vom 05.10 18:51 geschrieben. In dem gep. Thread wurde das behandelt, das ist ein Bug, nicht by Design.


    Servus
    Winfried

    GPOs: http://www.gruppenrichtlinien.de/
    WSUS Package Publisher: http://wsuspackagepublisher.codeplex.com/


    Mittwoch, 9. Oktober 2013 13:09
  • So liebe Forengemeinde. 

    Ich konnte das Problem jetzt selber lösen. :-)

    Ursache ist hier ein fehlerhafter Eintrag in der XML. 
    Der Eintrag wird zwar korrekt in der GPO gesetzt, bleibt aber mit dem Parameter disabled="1" in der XML entsprechend deaktiviert. Der Parameter wird auch mit F5/F6 zwar in der GUI grün markiert und somit eigentlich auch aktiviert, aber in der XML wird die Einstellung nicht geschrieben.

    Das Ganze kann ich hier in allen Umgebungen reproduzieren. Auch in einer eigens dafür aufgesetzten Domäne auf Basis Server 2012 konnte ich das Phänomen nachstellen.

    • Als Antwort markiert Phantomias Freitag, 11. Oktober 2013 08:14
    Freitag, 11. Oktober 2013 07:01
  • Microsoft hat mir heute schriftlich bestätigt, das wir wohl nicht die einzigsten sind, die dieses Problem haben.

    Die Tickets wurden wohl alle mit dem Hinweis "ist by Design" so.
    Ebenso wurde mir der Workaround, die XML manuell anzupassen, bestätigt.

    Mal gucken, wann ein Patch kommt. 
    Montag werde ich mal schauen, ob das Problem unter 2012 R2 schon behoben ist.

    Freitag, 11. Oktober 2013 10:43