none
Exchange 2010: Event ID 1025; Funktionsname oder Beschreibung des Problems: EcGenerateNRN RRS feed

  • Frage

  • Hi Community,

    ich hatte gestern Abend einmal folgenden Fehler in unserem Exchange 2010 geloggt:

    Protokollname: Application
    Quelle:        MSExchangeIS Mailbox Store
    Datum:         22.12.2015 21:41:00
    Ereignis-ID:   1025
    Aufgabenkategorie:Allgemein
    Ebene:         Fehler
    Schlüsselwörter:Klassisch
    Benutzer:      Nicht zutreffend
    Computer:      MTA.DOMAIN.local
    Beschreibung:
    Fehler für die Datenbank 'VWL'.
     Funktionsname oder Beschreibung des Problems: EcGenerateNRN: 
    Fehler: 0x80004005 
    

    Ich habe etliche Beschreibungen zu diesem Fehler gefunden aber es unterscheidet sich grundsätzlich der Fehlercode. Hier haben wir 0x80004005, die meisten Postings beziehen sich aber auf 0x80007005. Weiß jemand was es damit grundsätzlich auf sich hat oder weiß jemand gar genaueres zu exakt diesem Fehler. BTW: Es gab keine Begleitevents zu diesem Fehler.

    Thx & Bye Tom

    Mittwoch, 23. Dezember 2015 13:55

Alle Antworten

  • Hallo,

    bitte machen Sie siecher, dass Sie "eseutil /p /d" der Datenbank entgegen ausgeführt haben. Falls Sie die gleiche Meldung immer noch kriegen, bitte überprüfen Sie die Berechtigungen wie in dem Thread von Mohhamed angedeutet in dem Thread hat.

    Gruß,

    Teodora


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 24. Dezember 2015 09:10
    Moderator
  • Servus,

    > Falls Sie die gleiche Meldung immer noch kriegen, bitte überprüfen Sie die Berechtigungen wie in dem Thread von Mohhamed angedeutet in dem Thread hat.

    Diesen Thread kannte ich bereits. Das Topic des Threads geht zwar auf den Fehlercode 0x80004005 ein aber der dort verlinkte Microsoft KB Artikel [1] behandelt nur den Fehlercode 0x80070005 und bezieht sich explizit auf Exchange Server 2000 oder 2003. Ich weiß nicht ob das auf einen Exchange Server 2010 und den Fehlercode 0x80004005 zutrifft.

    [1] https://support.microsoft.com/en-us/kb/899393

    Thx & Bye Tom

    Freitag, 25. Dezember 2015 12:57
  • Hi Tom,

    das finde ich ziemlich ungewöhnlich.

    Ich würde an eurer Stelle jetzt einen Cal beim MS PSS aufmachen, ist meiner Meinung nach am effektivsten.

    Wenn du möchtest, kann ich versuchen, das intern zu eskalieren, aber derzeit dürften die meisten in Urlaub sein.

    ;)


    Gruß Norbert

    Freitag, 25. Dezember 2015 15:29
    Moderator
  • Auch wenn es dir nicht wirklich viel hilft, aber bei der Anzahl Fehler und Warnungen die du in letzter Zeit gepostest hast, sicher das an der Kiste nicht generell irgendwas im argen liegt?

    Grüße Jörg


    Freitag, 25. Dezember 2015 19:14
  • Servus Jörg,

    > Auch wenn es dir nicht wirklich viel hilft, aber bei der Anzahl Fehler und Warnungen die du in letzter Zeit gepostest hast, sicher das an der Kiste nicht generell irgendwas im argen liegt?

    Natürlich bin ich mir da _nicht_ sicher. Ausser den Problemen die ich schon gepostet habe, was in der Tat ungewöhnlich viele sind, fällt die Maschine nicht weiter auf.

    Ich bin selber schon am überlegen ob nicht auch ein Plan B her muss aber ich weiß nicht wo und wie ich damit anfangen soll, solange wir nicht wissen wo die Probleme herkommen. Was nutzt es einen neuen Exchange aufzusetzen und ein Backup einzuspielen, wenn ich nicht weiß ob das eigentliche Problem nicht schon lange mit einer Datenbank mitgesichert wurde?

    Ich trau mich schon gar nicht mehr eine Datenbank offline zu nehmen um diese mal zu prüfen, geschweige denn das Ding neu zu starten, nicht das die nicht wieder hochkommt und ich jetzt über die Feiertage niemanden erreiche. Ich habe vor kurzem erst mal eine (kleine) Datenbank mit eseutil gecheckt, die war in Ordnung, war aber auch eine andere wie die in dieser hier diskutierten Fehlermeldung. Der Exchange läuft auch mit ein paar anderen Windows 2008 R2 Servern virtualisiert auf einem ESX 5.1 Host und alle anderen Server zeigen keine Auffälligkeiten. Am liebsten wers mir zuerst mal irgendwie das Backup zu testen, bevor ich da ohne Netz und doppelten Boden am produktiven Exchange rumfummle.

    Aber wie testet man ein Backup, ohne den einzigen Exchange zu involvieren? Beim Exchange 2003 hatten wir mal eine temporäre (Recovery-) Domäne installiert und dort das Backup eingespielt, weil wir an ein Postfach ran mussten. Dieser Aufwand wäre in diesem Fall zwar gerechtfertigt aber ich weiß a) nicht ob es mittlerweile eine einfachere Methode gibt und b) weiß ich nicht mehr genau welche Parameter sich ändern müssen und welche sich nicht ändern dürfen aber das kriegen wir bestimmt wieder zusammen.

    Ausserdem liebäugle ich schon seit längerem mit dem Gedanken irgendwo, irgendwie einen zweiten Exchange in dauerhaften Betrieb zu nehmen um a) dort regelmäßig die Backups testen zu können und b) ggf gleich einen Ersatz parat zu haben, sollten irgendwelche Probleme es notwendig machen den produktiven Server offline zu nehmen, wenn er das bis dahin nicht schon selbst gemacht hat. Im Bedarfsfall erst einen Server zu installieren nimmt wertvolle Zeit in Anspruch und so ein Restore von ein paar Hundert Gigabyte Daten dauert halt auch seine Zeit.

    Für Vorschläge dieser Art bin ich derzeit sehr empfänglich ;-)

    Frohe Weihnachten übrigens und schöne Feiertage noch & Bye Tom

    Freitag, 25. Dezember 2015 20:35
  • Servus Norbert,

    > das finde ich ziemlich ungewöhnlich.

    Da es mich nicht mit Google Hits erschlagen hat, dachte ich mir schon hier ein exotisches Problem zu haben. Das einzige was mich bislang noch von dezenter Panik abhält ist, dass es sich hier um ein Problem mit irgendwelchen Non Read Notifications handelt, die eh kein Mensch braucht aber das kann ja gut auch nur ein Symptom eines ganz anderen Problems sein.

    > Ich würde an eurer Stelle jetzt einen Cal beim MS PSS aufmachen, ist meiner Meinung nach am effektivsten.

    Okay das kann ich nächste Woche ja mal machen, ich habe keine Erfahrung damit, den habe ich bislang noch nie in Anspruch genommen. Auch würde ich zuvor erst sicherstellen, dass das Backups funktioniert, weil die mich sicherlich mal einen Neustart machen lassen und ziemlich sicher auch die Datenbanken mal offline nehmen lassen.

    > Wenn du möchtest, kann ich versuchen, das intern zu eskalieren, aber derzeit dürften die meisten in Urlaub sein.

    Ja das ist nicht die beste Zeit für sowas, das geb ich zu aber wenn du da intern etwas herausbekommen kannst, wäre das sicherlich hilfreich. Wenn du das weitergibst wären bestimmt die anderen Probleme der letzten Wochen noch interessant. Die werden hier diskutiert:

    Exchange 2010: Warning Event IDs 1033; 9823; 1114

    Die traten zwar alle unabhängig voneinader auf aber könnten vielleicht den ein ein oder anderen Verdacht bestätigen.

    Meine primäre Sorge derzeit jedoch wäre irgendwie das Backup zu testen, ob das noch funktioniert, ohne den produktiven Exchange damit zu involvieren. Wenn da eine Datenbank am straucheln ist, ist das gut möglich, dass das Problem schon mitgesichert wurde.

    Frohe Weihnachten und noch schöne Feiertage, Bye Tom

    Freitag, 25. Dezember 2015 20:52
  • Moin Tom,

    ich würde einfach einen weiteren, neuen Exchange in der Umgebung hochziehen und die Postfächer nach und nach verschieben.

    Wenn alles drüben ist, deinstallieren und gut.

    Hast du AV-Software auf dem Teil?

    Das geht natürlich nur, wenn du genügend Resourcen im ESX hast.

    Ich habe das mal eingekippt, wie gesagt, Geduld...

    ;)


    Gruß Norbert

    Samstag, 26. Dezember 2015 07:33
    Moderator
  • Servus Norbert,

    > ich würde einfach einen weiteren, neuen Exchange in der Umgebung hochziehen und die Postfächer nach und nach verschieben.

    Hm, das klingt nach einem überschaubaren, pragmatischen Ansatz.

    > Das geht natürlich nur, wenn du genügend Resourcen im ESX hast.

    Ich wollte den Exchange eh auf einen anderen Host umziehen, weil ich den aktuellen Host wegen Wartungsarbeiten offline nehmen muss. Ohne vCenter und ohne Shared Storage kann man die Maschinen nur Offline von einem Host zum anderen kopieren. Das würde mir also sogar entegegen kommen.

    > Hast du AV-Software auf dem Teil?

    Jepp, Trend Micro SMB

    > Ich habe das mal eingekippt, wie gesagt, Geduld...

    Thx, schauen wir mal was dabei rauskommt. Geduld ist zZ oberstes Gebot. Klar das die nicht alle auf mich gewartet haben... ;-)

    Thx & Bye Tom

    Samstag, 26. Dezember 2015 12:31
  • Moin,

    endgültige Antwort habe ich noch nicht, nur die Empfehlung den TM runter zu nehmen.

    Bei der Anzahl von Ausnahmen, die man setzten muss, kann man den auch gleich weglassen.

    ;)

    PS: nach wie vor halte ich einen neuen Server für eine gute Idee.


    Gruß Norbert


    Montag, 28. Dezember 2015 07:15
    Moderator
  • Servus Norbert,

    >endgültige Antwort habe ich noch nicht, nur die Empfehlung den TM runter zu nehmen. Bei der Anzahl von Ausnahmen, die man setzten muss, kann man den auch gleich weglassen.

    Also vielleicht liegt da ein Missverständnis vor. Der TM ist nicht in das Betriebssystem installiert, so wie das zB bei einer normalen Workstation der Fall ist. Es ist nur die SMEX (Scan Mail for Exchange) Komponente installiert, also der Virenscanner und Spamfilter der die Mails überprüft. Ohne sowas gehts eigentlich nicht...

    > PS: nach wie vor halte ich einen neuen Server für eine gute Idee.

    Damit werde ich noch bis nach die Feiertage warten müssen.

    Thx & Bye Tom

    Montag, 28. Dezember 2015 07:46