none
Ex2003: Transaction Logs entgleisen RRS feed

  • Frage

  • Moin,

    auf meinem Ex2003 Mailbox-Server habe ich momentan die Situation, dass ein unbekannter Prozess auf einer (der ersten von 4) Storage Groups die Transaction Logs stetig anwachsen lässt. Es werden etwa alle 3 Minuten zwei neue Logdateien angelegt; und ich finde wiederkehrende Muster in den Logs. Das im Message Tracking Center angezeigte Mailvolumen entspricht nur einem Bruchteil der Logs.

    Wie kann ich den Übeltäter dingfest machen? An welchen Stellen sollte ich den Loglevel erhöhen?

    Viele Grüße, Georg.

    Donnerstag, 12. Mai 2011 06:49

Antworten

  • Hi Georg,

    wie ist es weiter gegangen? Schau mal, ob du einen User verantworten kannst und prüf die Mailbox:
    http://blogs.technet.com/b/jeff_stokes/archive/2009/01/25/defeated-by-unexpected-transaction-log-file-growth.aspx

    Der Blog-Eintrag enthält einen Link zum Auswerten der Log-Files.

    Wird vielleicht Entourage eingesetzt?
    http://support.microsoft.com/kb/889525


    Viele Grüße
    Christian

    Montag, 16. Mai 2011 15:11
    Moderator
  • Hi,

    ich habe gestern Nachmittag mit PSS Diagnostik betrieben - das scheint die Maschine so beeindruckt zu haben, dass das Problem nach einem weiteren (inzwischen wieder notwendig gewordenen) Vollbackup der betroffenen Storage Group automagically verschwunden ist.

    Entourage-User haben wir möglicherweise, obwohl ich vermute, dass die Mac-User durchweg Thunderbird benutzen. Ich hatte das eigentlich (vielleicht unbegründet) auch deshalb nicht weiter verfolgt, weil unser Maillimit deutlich höher liegt als die Menge an Daten, die wiederkehrend in die Logs geschrieben wurden. Wenn das das Problem war: Die Logs welcher SG wachsen dann, die des Absenders oder die des Empfängers? Auf der betroffenen SG habe ich keine Mac-User.

    Die Überprüfung einiger Logfiles, die ich woanders gesichert hatte, ergibt leider nichts Eindeutiges.

    Viele Grüße, Georg.

     

    Dienstag, 17. Mai 2011 16:10

Alle Antworten

  • http://technet.microsoft.com/de-de/library/aa996191%28EXCHG.65%29.aspx bin ich durch - das trifft alles nicht zu: In den Queues finde ich nichts, was das Problem verursachen könnte, Öffentliche Ordner werden nur einmal pro Stunde repliziert, Hinweise auf eine amoklaufende Regel sehe ich auch nicht. Nach Dienstschluss werde ich mal SA und IS durchstarten...

    Donnerstag, 12. Mai 2011 10:54
  • Hi,

    welche AV Engine scant denn hier. Gibt es einen Filescanner auf dem Server ? Wenn ja, wie sieht die Ausschlussliste aus ?
    Viele Grüße Marcel Küppers (MCSA-M, MCSE, MCTS, MCITP)
    Donnerstag, 12. Mai 2011 15:06
  • Es ist kein Virenscanner auf dem Exchange. Neustart der Dienst brachte keine Besserung.

    Für mich sieht es so aus, als ob alle paar Minuten versucht würde, ein und dieselbe Mail unterzubringen, dies aber nicht gelingt.

    Georg.

    Donnerstag, 12. Mai 2011 19:38
  • Hi,

    hast du die Empfängerprüfung an? Woraus schliesst du das das Message Tracking Center nur einen Bruchteil der Emails anzeigt? Was sagen die Warteschlangen am SMTP?

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Freitag, 13. Mai 2011 06:08
    Moderator
  • Moin,

    in der SMTP-Queue sind 5 Mails, die alle eingeliefert wurden, als das Problem schon länger bestand. Das Tracking Center zeigt nur einen Bruchteil des _Volumens_ an, nicht der Mails. Die Mailboxen in der betroffenen SG wachsen kaum, während die Log kontinuierlich wachsen (ca. alle 3 Minuten um 10 MB). Im Log stehen keine Mails, die ich diesem Schema zuordnen könnte. Und wie gesagt, wenn ich in die Transaction Logs reinschaue, sieht es ganz danach aus, als ob sich derselbe Inhalt ständig wiederholt. Es sieht nach einem Anhang aus, der durchaus Bezug zu unserem Tätigkeitsfeld hat.

    Empfängerprüfung ist aus.

    Viele Grüße, Georg.

     

    Freitag, 13. Mai 2011 06:26
  • Hi,

    gut, dann schalt mal die Empfängerprüfung global und per smtp ein, SMTP-Service durchbooten. Hört das dann auf? Meine Vermutung ist das etwas (ein kaputter oder evtl. auch gewollt) euch sehr viele Emails mit Anhang an einen Empfänger zustellt. Da es diesen nicht gibt bei euch schickt der Exchange das wieder raus.

    Mit eingeschalteter Empfängerprüfung wird die Email schon beim rcpt to abgelehnt wenn der Emfpänger nicht vorhanden ist. Ohne nimmt der Exchange die Email an und generiert den NDR dann erst selbst (mit 5 MB anhang)

     


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Freitag, 13. Mai 2011 06:41
    Moderator
  • Danke für den Hinweis! Das muss ich mir aber wohl noch etwas durch den Kopf gehen lassen, weil ich die Konsequenzen noch nicht überblicke - erstes Überfliegen von msxfaq sagt, dass man dies nur machen solle, wenn es kein SMTP-Relay gibt (bei uns zeigt das MX-Record nicht auf den Exchange).

    Aber wenn der Exchange die NDRs selbst generiert: Müsste ich diese dann nicht im Tracking Log sehen?

    Georg.

    Freitag, 13. Mai 2011 07:09
  • HI,

    mindestens im SMTP-Log müsstest du jede Menge Einträge haben. Hast du das aktiviert?


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/
    Samstag, 14. Mai 2011 13:46
    Moderator
  • Ich habe inzwischen probehalber alle relevanten Services außer dem SA und dem IS (deren Neustart ja nichts brachte) mal für jeweils ca. 10 Minuten angehalten: SMTP, MTA, IMAP, POP - nichts davon stoppt das Anwachsen der Logs. Mir scheint, die store.exe hat sich an irgendetwas verschluckt und kann es nicht verdauen... werde also am Montag wohl nicht umhinkommen, PSS einzuschalten.

    Schönes Wochenende, Georg.

    Samstag, 14. Mai 2011 18:02
  • Hi Georg,

    wie ist es weiter gegangen? Schau mal, ob du einen User verantworten kannst und prüf die Mailbox:
    http://blogs.technet.com/b/jeff_stokes/archive/2009/01/25/defeated-by-unexpected-transaction-log-file-growth.aspx

    Der Blog-Eintrag enthält einen Link zum Auswerten der Log-Files.

    Wird vielleicht Entourage eingesetzt?
    http://support.microsoft.com/kb/889525


    Viele Grüße
    Christian

    Montag, 16. Mai 2011 15:11
    Moderator
  • Hi,

    ich habe gestern Nachmittag mit PSS Diagnostik betrieben - das scheint die Maschine so beeindruckt zu haben, dass das Problem nach einem weiteren (inzwischen wieder notwendig gewordenen) Vollbackup der betroffenen Storage Group automagically verschwunden ist.

    Entourage-User haben wir möglicherweise, obwohl ich vermute, dass die Mac-User durchweg Thunderbird benutzen. Ich hatte das eigentlich (vielleicht unbegründet) auch deshalb nicht weiter verfolgt, weil unser Maillimit deutlich höher liegt als die Menge an Daten, die wiederkehrend in die Logs geschrieben wurden. Wenn das das Problem war: Die Logs welcher SG wachsen dann, die des Absenders oder die des Empfängers? Auf der betroffenen SG habe ich keine Mac-User.

    Die Überprüfung einiger Logfiles, die ich woanders gesichert hatte, ergibt leider nichts Eindeutiges.

    Viele Grüße, Georg.

     

    Dienstag, 17. Mai 2011 16:10