locked
unattend.xml DiskConfiguration RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe eine unattend.XML Datei für die Windows 7 Installationen erstellt. Alles sowei so gut.

    In der Phase WindowsPE würde ich gerne eine Partitionierung definieren ala

    http://technet.microsoft.com/en-us/library/ff715484.aspx

    Letztlich rufe ich auf

    sysprep.exe /generalize /oobe /shutdown

    Wie gesagt, alles in der Antwortdatei funktioniert, nur übernimmt er nicht die Partitionierung. Hier der relevante Teil:

                <DiskConfiguration>
                    <WillShowUI>Always</WillShowUI>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>70000</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Format>NTFS</Format>
                                <Label>Windows</Label>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Letter>C</Letter>
                                <Extend>false</Extend>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                        <InstallToAvailablePartition>false</InstallToAvailablePartition>
                        <WillShowUI>Always</WillShowUI>
                    </OSImage>
                </ImageInstall>

    Kann mir jemand sagen, warum das nicht funktioniert?

    Danke.

    Freitag, 31. Oktober 2014 22:58