none
Exchange 2010 - Verbindungen über CAS-Server RRS feed

  • Frage

  • Hallo zusammen,
     
    mit dem Powershell-Befehl
    Get-Counter "\MSExchange RpcClientAccess\anzahl benutzer" -ComputerName
    cas-servername |fl
    sehe ich das noch ziemlich viele Benutzer mit ihren Clients über einen
    unserer beiden CAS-Server verbunden sind.
     
    Den Server möchte ich Patchen und die Benutzer "sanft" herunter
    schmeißen. Über einen Loadbalancer werden die Zugrifef zur Zeit direkt
    auf den zweiten CAS-Server gelenkt.
     
    Gibt es zum "Herunter schmeißen" einen Befehl? Oder lässt sich dies
    durch einen einfachen Reboot des Server (bzw. Neustart eines Dienstes)
    provozieren?
     
    Viele Dank für eine kurze Info,
    JOhannes
     
    Mittwoch, 10. April 2013 16:12

Antworten

  • Hi Johannes,

    ich bin zwar nicht Robert und hab auch gerade keinen KEMP zur Hand, aber ich meine mich zu erinnern, dass Du das ueber die Web-Oberflaeche im Reiter Real-Server (Enable/Disable) machen kannst.

    Viele Gruesse

    Timo

    Mittwoch, 10. April 2013 16:44
  • Am 10.04.2013 18:44, schrieb Timo Geuken:
    > Hi Johannes,
    >
    > ich bin zwar nicht Robert und hab auch gerade keinen KEMP zur Hand, aber ich
    > meine mich zu erinnern, dass Du das ueber die Web-Oberflaeche im Reiter
    > Real-Server (Enable/Disable) machen kannst.
     
    Hi Timo,
    der Realserver ist dort bereits seit gestern deaktiviert. Die Anzahl der
    Verbindungen ist seit gestern von 350 auf jetzt 100 aktive Sitzungen
    gesunken. Ich hatte Robert so verstanden, dass ich über den Loadbalancer
    die Sitzungen "komfortabel" auf einen Schlag beenden kann.
    Viele Grüße
    Johannes
     
     

    Beenden deine User evt. ihr Outlook nicht? Solange sonst der Client den CAS noch erreicht passiert da afaik nämlich nix. Bei F5 muss man den Node "hart" deaktivieren, dann gibts einen neuen Verbindungsaufbau.

    Gruß

    Jörg

    Mittwoch, 10. April 2013 17:16
  • Moin,

    schau mal hier:
    http://www.loadbalancerblog.com/blog/2011/11/cookbook-finetuning-loadmaster-10-simple-steps

    Punkt 3

    Wenn Du wie von Timo beschrieben, den Real Server deaktivierst, bleiben altive Verbindungen bestehen, aber es kommein keine neuen dazu.

    Das hat auch was mit der "persistency" Einstellung zu tun. Sobald die aktiv ist, ist das verhalten auch korrekt. Und es ist wichtig, sonst würden die Clients ständig ein Passwort-Fenster bekommen.

    Du kannst zwar eine "Drain Time" setzen, die greift aber nur, wenn der Client keine aktive Verbindung mehr hat. Outlook hat leider quasi immer eine aktive Verbindung.

    Deine Beobachtung ist also erst mal normal.

    IMHO gibt es keine Möglichkeit bei KEMP, die User runterzuwerfen.

    Die Benutzer werden beim Switch-Over eventuell ein Passwort-Fenster bekommen. Das ist leider normal und dem Layer 7 Loadbalancing von Exchange 2010 geschuldet.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 10. April 2013 17:24

Alle Antworten

  • Moin,

    Den Server möchte ich Patchen und die Benutzer "sanft" herunter
    schmeißen. Über einen Loadbalancer werden die Zugrifef zur Zeit direkt
    auf den zweiten CAS-Server gelenkt.

    der Loadblancer wäre für das "runterwerfen" zuständig. Die gängigen Produkte haben i.d.R. irgendeine Konfig, die die Server leerräumt.

    Gibt es zum "Herunter schmeißen" einen Befehl? Oder lässt sich dies
    durch einen einfachen Reboot des Server (bzw. Neustart eines Dienstes)
    provozieren?

    Letzteres geht immer, dafür ist HA ja schließlich da. ;)


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 10. April 2013 16:15
  • Am 10.04.2013 18:15, schrieb Robert Wille [MVP]:
    > der Loadblancer wäre für das "runterwerfen" zuständig. Die gängigen
    Produkte
    > haben i.d.R. irgendeine Konfig, die die Server leerräumt.
     
    Hallo Robert,
     
    könntest Du mir spontan (dies extra zu erforschen ist nicht notwendig)
    beim Kemp LM2200 auf die Sprünge helfen?
     
    Viele Grüße und Danke
    Johannes
     
     
    Mittwoch, 10. April 2013 16:29
  • Hi Johannes,

    ich bin zwar nicht Robert und hab auch gerade keinen KEMP zur Hand, aber ich meine mich zu erinnern, dass Du das ueber die Web-Oberflaeche im Reiter Real-Server (Enable/Disable) machen kannst.

    Viele Gruesse

    Timo

    Mittwoch, 10. April 2013 16:44
  • Am 10.04.2013 18:44, schrieb Timo Geuken:
    > Hi Johannes,
    >
    > ich bin zwar nicht Robert und hab auch gerade keinen KEMP zur Hand, aber ich
    > meine mich zu erinnern, dass Du das ueber die Web-Oberflaeche im Reiter
    > Real-Server (Enable/Disable) machen kannst.
     
    Hi Timo,
    der Realserver ist dort bereits seit gestern deaktiviert. Die Anzahl der
    Verbindungen ist seit gestern von 350 auf jetzt 100 aktive Sitzungen
    gesunken. Ich hatte Robert so verstanden, dass ich über den Loadbalancer
    die Sitzungen "komfortabel" auf einen Schlag beenden kann.
    Viele Grüße
    Johannes
     
     
    Mittwoch, 10. April 2013 16:50
  • Hast Du evtl. noch Public Folder auf dem Server oder sind da noch Postfachdatenbanken aktiv?

    VG, Timo

    Mittwoch, 10. April 2013 17:04
  • Am 10.04.2013 18:44, schrieb Timo Geuken:
    > Hi Johannes,
    >
    > ich bin zwar nicht Robert und hab auch gerade keinen KEMP zur Hand, aber ich
    > meine mich zu erinnern, dass Du das ueber die Web-Oberflaeche im Reiter
    > Real-Server (Enable/Disable) machen kannst.
     
    Hi Timo,
    der Realserver ist dort bereits seit gestern deaktiviert. Die Anzahl der
    Verbindungen ist seit gestern von 350 auf jetzt 100 aktive Sitzungen
    gesunken. Ich hatte Robert so verstanden, dass ich über den Loadbalancer
    die Sitzungen "komfortabel" auf einen Schlag beenden kann.
    Viele Grüße
    Johannes
     
     

    Beenden deine User evt. ihr Outlook nicht? Solange sonst der Client den CAS noch erreicht passiert da afaik nämlich nix. Bei F5 muss man den Node "hart" deaktivieren, dann gibts einen neuen Verbindungsaufbau.

    Gruß

    Jörg

    Mittwoch, 10. April 2013 17:16
  • Moin,

    schau mal hier:
    http://www.loadbalancerblog.com/blog/2011/11/cookbook-finetuning-loadmaster-10-simple-steps

    Punkt 3

    Wenn Du wie von Timo beschrieben, den Real Server deaktivierst, bleiben altive Verbindungen bestehen, aber es kommein keine neuen dazu.

    Das hat auch was mit der "persistency" Einstellung zu tun. Sobald die aktiv ist, ist das verhalten auch korrekt. Und es ist wichtig, sonst würden die Clients ständig ein Passwort-Fenster bekommen.

    Du kannst zwar eine "Drain Time" setzen, die greift aber nur, wenn der Client keine aktive Verbindung mehr hat. Outlook hat leider quasi immer eine aktive Verbindung.

    Deine Beobachtung ist also erst mal normal.

    IMHO gibt es keine Möglichkeit bei KEMP, die User runterzuwerfen.

    Die Benutzer werden beim Switch-Over eventuell ein Passwort-Fenster bekommen. Das ist leider normal und dem Layer 7 Loadbalancing von Exchange 2010 geschuldet.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Mittwoch, 10. April 2013 17:24
  • Am 10.04.2013 19:04, schrieb Timo Geuken:> Hast Du evtl. noch Public
    Folder auf dem Server oder sind da noch
    > Postfachdatenbanken aktiv?
     
    Hi Timo,
     
    die liegen auf zwei DB-Server im einem DAG. Mit dem im Ursprungsposting
    geposteten Befehl sehe ich noch aktive Verbindungen auf dem CAS. Ich
    frage eigentlich nur nach, da ich letztens die aktiven Verbindungen
    ignoriert habe und einfach mit dem Patchen losgelegt habe. Als dann beim
    Patchen ein Rollup-Package dran war, konnten die paar betroffenen
    Benutzer (und das auch noch außerhalb der normalen Betriebszeit) nicht
    innerhalb ihrer bestehenden Verbindung für über eine halbe Stunde
    zugreifen. Das führe ich mit meinem jetzigen Kenntnisstand auf die
    bestehenden Verbindungen auf dem CAS zurück ...
     
    Aufgrund unsere HA-Lösung werde ich dann einfach mal kontrolliert den
    einen CAS-Server durchstarten und damit die aktiven Verbindungen
    unterbrechen ;)
     
    Viele Grüße
    Johannes
     
     
    Mittwoch, 10. April 2013 17:24