none
Microsoft Exchange 2007 Smarthost-Konfiguration erwartet MX-Record RRS feed

  • Frage

  • Liebes Forum,

    nachdem ich eben eine frustrierende Erfahrung mit Exchange Server 2007 hatte, stellen sich mir einige Fragen. Vielleicht kann sie mir jemand beantworten. Gleichzeitig könnte diese Erkenntnis anderen zur Problemlösung dienen - bisher bin ich auf dieses Problem und seine Lösung nirgends im Internet gestoßen.

    Ein 2007er Exchange-Server eines Kunden versendet E-Mails über einen Smarthost. Dieser ist umgezogen und sollte umkonfiguriert werden. Exchange Server quittierte jeden Versuch, eine E-Mail zu senden, mit folgender Fehlermeldung in der Warteschlange:

    421 4.2.1 Unable to connect Failover to alternate host did not succeed

    - TLS ist aktiviert, Zertifikat passt
    - Authentifizierung ist aktiviert, Zugangsdaten stimmen
    - Keinerlei Spur von dem Verbindungsversuch im Log des Smarthosts (Postfix-Server)

    Nach endloser Suche nach der Ursache an verschiedenen Stellen stellte sich über das Verbindungsprotokoll Folgendes heraus:

    Exchange Server verbindet sich nicht zu dem im Sendeconnector konfigurierten Smarthost. Das ist wohl auch gar nicht so vorgesehen. Stattdessen löst es den MX-Record (!) des im Sendeconnector hinterlegten Smarthosts auf und verbindet sich dorthin! Dieser Record stand bei Strato auf dem Standardwert, weil die Domain des Smarthosts selbst keine E-Mails empfängt.

    Meine Fragen:

    - Wo ist das dokumentiert?
    - Warum ist das überhaupt so? Ich empfinde es als himmelschreiend unlogisch. Der Smarthost ist ein Server, der als SMTP-Relay dient. Was hat der MX-Record damit zu tun? Der Name des Smarthosts selbst existiert nicht als E-Mail-Domain, warum sollte er auch?
    - Ist das in anderen Versionen von Exchange Server auch so oder nur bei 2007?

    Danke und viele Grüße,

    Julian

    Donnerstag, 10. November 2016 10:55

Antworten

  • Moinm

    das ist kein Bug, sondern das Standard-Verhalten:

    https://technet.microsoft.com/en-us/library/aa998294(v=exchg.160).aspx

    SmartHosts - The SmartHosts parameter specifies the smart hosts the Send connector uses to route mail. This parameteris required if you set the DNSRoutingEnabled parameter to $false and it must be specified on the same command line. The SmartHosts parameter takes one or more FQDNs, such as server.contoso.com, or one or more IP addresses, or a combination of both FQDNs and IP addresses. If you enter an IP address, you must enter the IP address as a literal. For example, 10.10.1.1. The smart host identity can be the FQDN of a smart-host server, a mail exchanger (MX) record, or an address (A) record. If you configure an FQDN as the smart host identity, the source server for the Send connector must be able to use DNS name resolution to locate the smart-host server.

    Wenn es einen MX-Eintrag gibt, wird dieser zuerst genommen. Betrifft alle Exchange-Versionen 2007 bis 2016.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    • Als Antwort markiert WUMJP Freitag, 11. November 2016 13:12
    Freitag, 11. November 2016 12:51

Alle Antworten

  • Am 10.11.2016 schrieb Udo IC:
    Hi,

    Nach endloser Suche nach der Ursache an verschiedenen Stellen stellte sich über das Verbindungsprotokoll Folgendes heraus:

    Weil man erst nach endloser Suche ins richtige Protokoll schaut?

    Exchange Server verbindet sich nicht zu dem im Sendeconnector konfigurierten Smarthost. Das ist wohl auch gar nicht so vorgesehen. Stattdessen löst es den*MX-Record* (!) des im Sendeconnector hinterlegten Smarthosts auf und verbindet sich*dorthin*!

    Wenn du mail.deinsmarthost.de dort einträgst und das bei 1und1 eine Subdomain ist, könnte ich mir das durchaus als halbwegs logisch vorstellen. Ist aber jetzt nur eine Vermutung, die zumindest aber erklären kann, warum deine Folgefragen überhaupt auftauchen. ;)

    Dieser Record stand bei Strato auf dem Standardwert, weil die Domain des Smarthosts selbst keine E-Mails empfängt.

    Weil ein Smarthost normalerweise eben keine Domain sondern ein A-Record ist (imho).

    Bye
    Norbert

    Donnerstag, 10. November 2016 22:10
  • Hallo Norbert, danke für deine Antwort.

    Weil ein Smarthost normalerweise eben keine Domain sondern ein A-Record ist (imho).

    Genau. Aber Exchange löst ja eben nicht den A-Record des Smarthosts auf, sondern den MX-Record und verbindet sich dann dorthin. Und da das für mich wie ein Bug aussieht, hätte ich gerne gewusst, ob das nur bei Exchange 2007 so ist oder bei neueren Versionen auch. Und wo es dokumentiert ist, an dieser Stelle jedenfalls nicht.

    Viele Grüße,
    Julian

    Freitag, 11. November 2016 10:04
  • Moinm

    das ist kein Bug, sondern das Standard-Verhalten:

    https://technet.microsoft.com/en-us/library/aa998294(v=exchg.160).aspx

    SmartHosts - The SmartHosts parameter specifies the smart hosts the Send connector uses to route mail. This parameteris required if you set the DNSRoutingEnabled parameter to $false and it must be specified on the same command line. The SmartHosts parameter takes one or more FQDNs, such as server.contoso.com, or one or more IP addresses, or a combination of both FQDNs and IP addresses. If you enter an IP address, you must enter the IP address as a literal. For example, 10.10.1.1. The smart host identity can be the FQDN of a smart-host server, a mail exchanger (MX) record, or an address (A) record. If you configure an FQDN as the smart host identity, the source server for the Send connector must be able to use DNS name resolution to locate the smart-host server.

    Wenn es einen MX-Eintrag gibt, wird dieser zuerst genommen. Betrifft alle Exchange-Versionen 2007 bis 2016.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    • Als Antwort markiert WUMJP Freitag, 11. November 2016 13:12
    Freitag, 11. November 2016 12:51
  • Super, danke!
    Freitag, 11. November 2016 13:12
  • Am 11.11.2016 schrieb Robert Wille [MVP]:

    Wenn es einen MX-Eintrag gibt, wird dieser zuerst genommen. Betrifft alle Exchange-Versionen 2007 bis 2016.

    Danke für den Link.
    Und wieder ein Grund, warum diese ganzen 1und1 Hostings eben suboptimal sind. Hat ja einen Grund, warum es Subdomain und A-Records gibt. ;)

    Bye
    Norbert


    Dilbert's words of wisdom #32:
    If it wasn't for the last minute, nothing would get done.
    nntp-bridge Zugriff auf die MS Foren wieder möglich: https://communitybridge.codeplex.com/

    Freitag, 11. November 2016 23:25