none
Intranet / Internet Connection -> OS Deployment for Workgorup Clients, which are moving then to Internet only... RRS feed

  • Allgemeine Diskussion

  • Hello together,

    I am fighting here with the following:

    I want to deploy Clients internal (not domain jonied, just put them into a Workgroup) over HTTPS. I give them two Task Sequence (OSD / Basic Application TS)... I want that the CCM-Agent's "Connection type" is either "Always Intranet" or "Currently Intranet"... After the two Tasksequences are done, I want the CCM-Agent's connection type is changed to "Currently Internet" or "Always Internet"... It doesn't matter if that happens with a new installation of the ccmsetup.exe with new options, or with any vbs-scripts... the only thing that matters: it should happen automatically!

    The Client will move to another location as workgroup client (internet only) and will never change back into a domain... From this time on, it's enough if the client communicate with the sccm server over Internet only!

    I am not able to do this procedure described above... :(

    Information about our Environment:

    - SCCM 2012 SP1 (one primary site only)
    --> Syste system settings = HTTPS or HTTP
    --> Client computer settings = Use PKI client certificate when available
    --> Management Point and Distribution Point accepts HTTPS (intranet and Internet connections)

    - Enterprise CA
    --> I have an Enterprise CA which is giving the Client a valid Certificate during the OSD TS..

    Questions:
    - How can I change the Connection Type (Internet / Intranet) on a Workgroup-Client after the OSD TS? It doesn't work in any way...
    - How can I make sure, that a Task Sequence (available for Internet-Clients) never will be re-runned when the client is moved to this other organization?

    at the moment I use the following command to install the ccm-agent during the OSD TS (as additional Job):
    ccmsetup.exe /UsePKICert /NoCRLCheck CCMHOSTNAME=depl.public.com CCMCERTISSUERS="CN=CAspecified; DC=contoso; DC=local" SMSSITECODE=XXX

    Thank you.

    Patrik


    Freitag, 1. März 2013 12:05

Alle Antworten