locked
Probleme mit Namensauflösung nach Energiesparmodus RRS feed

  • Frage

  • Hallo,

    ich habe da ein sehr seltsames Problem und hoffe, daß hier jemand eine Idee hat:

    Gegeben:

    PC mit WIN 7 Ult. 64 Bit SP1
    hängt per Kabel an
    Fritzbox 3270 v3 mit aktueller Firmware (96.04.87)
    an DSL (V4 only)

    So lief das ohne IPV6 und ohne Probleme ...

    ... bis ich im Heise-Newsticker vom kommenden IPV6-Day und dem Test unter www.test-ipv6.com gelesen habe.

    Der Test lief für IPV4 ohne Probleme, bei IPV6 ging natürlich gar nichts. Dann habe ich in der Fritzbox IPV6 aktiviert und die hat einen
    Tunnel gebaut. IIRC gab es jetzt 7 von 10 Punkten sowohl für V4 als auch für V6. Dann habe ich IPV6 in der Box wieder deaktiviert.

    Erst seit diesem Zeitpunkt gibt es folgendes Problem:

    Wenn der PC neu gestartet wurde ist alles in Ordnung. ipconfig /all zeigt auch nur eine IPV4-Adresse als DNS-Server. netsh int ipv6 show dns zeigt keinen DNS-Server.

    Wenn der PC allerdings aus dem hybriden Energiesparmodus aufgewacht ist, dauern Namensauflösungen sehr lange. ipconfig /all zeigt jetzt
    zusätzlich eine IPV6-Adresse als DNS-Server,  netsh int ipv6 show dns zeigt diese auch an und anscheinend wird diese zuerst befragt ... Die angezeigte Adresse beginnt mit fd00 und scheint Teile der MAC der Fritzbox zu beinhalten, ist also wahrscheinlich die nicht mehr aktive IPV6-Adresse der Box.

    Nach dem Aufwachen, wenn also das Problem besteht:

    netsh int ipv6 del dns "LAN-Verbindung" <adresse> ergibt

    "Das System kann die angegebene Datei nicht finden."

    netsh int ipv6 del dns "LAN-Verbindung" all ergibt

    "Auf dem Computer sind keine DNS-Server konfiguriert."

    ipconfig /all und netsh int ipv6 show dns sehen das aber wie gesagt anders ...

    Die Fritzbox habe ich zwischenzeitlich auf die Werkeinstellungen zurückgesetzt - keine Änderung. Ein Netbook, unter WIN 7 32 Bit,
    welches beim Test ausgeschaltet war, arbeitet auch nach dem Aufwachen korrekt.

    Es scheint also nicht an der Fritzbox zu liegen, sondern Windows scheint beim Aufwachen falsche Einstellungen wiederherzustellen. Ich
    habe weder in der Systemsteuerung noch in der Registry etwas gefunden, was mir weitergeholfen hätte.

    Ist da etwas bekannt?

    TIA

    Dienstag, 24. Mai 2011 15:36

Antworten

Alle Antworten

  • Hallo,

    deaktiviere doch einmal ipv6 am Client komplett:

    http://support.microsoft.com/kb/929852


    Danach bitte prüfen oder das Problem immernoch auftritt.

     

    Mittwoch, 25. Mai 2011 06:42
  • Hallo,

    deaktiviere doch einmal ipv6 am Client komplett:

    http://support.microsoft.com/kb/929852


    Danach bitte prüfen oder das Problem immernoch auftritt.

     


    Hallo Matthias,

    nachdem ich IPV6 deaktiviert hatte (0xffffffff), trat das Problem nicht auf. (War ja eigentlich nicht anders zu erwarten.)

    Nachdem ich es wieder aktiviert hatte (0x0), trat es aber wieder unverändert auf. Ich kann mich jetzt also entscheiden, ob ich IPV6 oder den Energiesparmodus nutzen wil ...

    Dabei ist mir aber unter HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\TCPIP6\Parameters\Interfaces etwas aufgefallen:

    Der letzte Eintrag enthält unter Dhcpv6 die gleiche, die auch ipconfig /all anzeigt. Hier ist auch Dhcpv6State auf 1, bei den anderen Einträgen ist es überall auf 0. Und Dhcpv6InterfaceOptions enthält ziemlich weit hinten die MAC der Fritzbox.

    Ich habe ich allerdings nicht getraut, da einfach mal rumzuspielen.

    Kennt sich damit jemand aus?

    Mittwoch, 25. Mai 2011 14:19
  • Hallo, hatte hier das selbe Problem wie geschildert. Das löschen des Eintrags "Dhcpv6InterfaceOptions" in dem die IP der Fritzbox stand hat das Problem bei mir behoben. Nebenwirkungen sind noch keine bekannt. Wahrscheinlich werden die Einträge sowieso dynamisch aktualisiert... Grüße
    Mittwoch, 22. Juni 2011 07:52
  • Hallo, hatte hier das selbe Problem wie geschildert. Das löschen des Eintrags "Dhcpv6InterfaceOptions" in dem die IP der Fritzbox stand hat das Problem bei mir behoben. Nebenwirkungen sind noch keine bekannt. Wahrscheinlich werden die Einträge sowieso dynamisch aktualisiert... Grüße


    Ich habe "Dhcpv6InterfaceOptions" sicherheitshalber exportiert und dann gelöscht. Bis jetzt funktioniert alles.

    Nun überlege ich, ob ich "Dhcpv6State" von 1 auf 0 setzte soll ...

    @Microsoft: IMHO ist da in WIN7 ein Bug versteckt. "Dhcpv6InterfaceOptions" wird anscheinend beim Hochfahren und beim Aufwachen unterschiedlich ausgewertet. Dazu kommt noch das oben genannten seltsame Verhalten von NETSH.

    Donnerstag, 23. Juni 2011 13:24