none
Report-Manager startet nicht RRS feed

  • Frage

  • Hallo zusammen,
    ich habe gerade angefangen mich mit SSRS zu befassen.
    Nun schaffe ich es leider nicht den Berichte-Manager zu starten.
    Hier mein System:
    - Windows Server 2008 R2 Standard (64Bit)
    - SQL Server 2008 R2 Express with advanced Services
    Im Sql Server Configuration Manager wird angezeigt, dass
    SQL Server Reporting Services Dienst aufgeführt wird.
    (NTAUTHORITY\NetworkService)
    Wenn ich den Berichtsserver mit dem Internetexplorer 8
    starten möchte erhalte ich die Meldung:
    "Die Webseite wurde nicht gefunden"
    Ich habe folgende URLs ausprobiert:
    http://<ComputerName>/reports
    http://<ComputerName>:80/reports
    Die Meldung ist als lokaler Administrator wie auch als
    unpriviligierter Benutzer identisch.
    Hängt das Problem vielleicht mit der Registrierung des Berichts-
    servers zusammen? Im Management Studio wird mir unter
    "Registrierte Server" der Bereich "Reporting Services"
    gar nicht angezeigt. Ich habe dann den Server einfach mal
    unter "lokale Servergruppen" und "Zentrale Verwaltungsserver"
    registriert.
    Ich habe auch schon mal in die Reporting Service log -Datei
    geschaut. Dort finde ich andere Urls für den Berichte-Manager.
    (Die werden auch im Konfigurations-Manager für Reporting Services
    angezeigt). Sie haben dieses Format:
    http://<ComputerName>:80/ReportServer_DBServerName
    http://<ComputerName>:443/ReportServer_DBServerName
    Wenn ich es damit versuche erhalte ich die Meldung:
    "Die dem Benutzer '...' erteilten Berechtigungen reichen zum Ausführen
    des Vorgangs nicht aus. (rsAccessDenied)"
    Dieses Mal konnte musste ich mich zur Windows-Authentifizierung als
    Domänenbenutzer anmelden. Dem Benutzer habe ich zuvor im Management
    Studio für die ReportServer - Datenbank unter Datenbankrollen
    db_owner Berechtigungen zugewiesen.
    Sorry für den langen Text aber ich bin schon eine Weile auf der
    Suche und habe keine Ahnung an welcher Stelle das Problem liegt.
    Was kann ich noch tun?
    Gruß
    Oliver
    Freitag, 19. November 2010 12:01

Antworten

  • Ok, habe ich in dem Text jetzt erst gesehen, das hast Du schon nachgesehen.

    Änderungen an dern ReportServer-Datenbanken bringen nichts, das wird sich nur auf SQL Server Ebene aus, nicht auf SSRS.

    Melde Dich am Server an und starte den IE mal als Administrator, also mit "Run as Administrator" und ruf dann die URL für den Report Manager auf. Das sollte dann gehen.

    Die Benutzerverwaltung findest Du dann oben rechts unter "Sidesettings" => "Security", dort kannst Du Dich als Systemadministrator hinzufügen, dann wird der Aufruf auch mit Deinem normalen Account gehen.


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    • Als Antwort markiert X7Code Freitag, 19. November 2010 13:03
    Freitag, 19. November 2010 12:44

Alle Antworten

  • Hallo Oliver,

    Ruf bitte mal im Startmenu unter MS SQL Server 2008 R2 => Konfigurationstools => Konfigurationsmanager für Reporting Services auf. Kannst Du Dich dort anmelden und sieht alles vollständig konfiguriert aus?

    Dort findest Du auch die URLs für den WebService und den Report Manager.
    Da Du die Express Edition hast und Du vermutlich alles mit den Standard Einstellung installierst hast, ist es eine benannte Instanz "SQLEXPRESS" und das gilt dann auch für den Reporting Services. Deshalb wird die URL eher:

    http://<ComputerName>:80/Reports_SQLEXPRESS

    lauten, also mit dem Instanzennamen in der URL.


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    Freitag, 19. November 2010 12:29
  • Hallo Olaf,

    im Konfigurationsmanager sieht alles, soweit ich das beurteilen kann, o.k. aus. Für die Instanz habe ich einen anderen Namen gewählt. Aber auch

    http://<ComputerName>:80/Reports_MEINNAME

    bringt leider keinen Erfolg.

    Die Urls aus dem Konfigurationsmanager habe ich schon ausprobiert. Damit erhalte ich die AccessDenied Fehlermeldung.

    Oliver

    Freitag, 19. November 2010 12:39
  • Ok, habe ich in dem Text jetzt erst gesehen, das hast Du schon nachgesehen.

    Änderungen an dern ReportServer-Datenbanken bringen nichts, das wird sich nur auf SQL Server Ebene aus, nicht auf SSRS.

    Melde Dich am Server an und starte den IE mal als Administrator, also mit "Run as Administrator" und ruf dann die URL für den Report Manager auf. Das sollte dann gehen.

    Die Benutzerverwaltung findest Du dann oben rechts unter "Sidesettings" => "Security", dort kannst Du Dich als Systemadministrator hinzufügen, dann wird der Aufruf auch mit Deinem normalen Account gehen.


    Olaf Helper ----------- * cogito ergo sum * errare humanum est * quote erat demonstrandum * Wenn ich denke, ist das ein Fehler und das beweise ich täglich http://olafhelper.over-blog.de
    • Als Antwort markiert X7Code Freitag, 19. November 2010 13:03
    Freitag, 19. November 2010 12:44
  • Auch als Administrator kann ich den Report Manager nicht aufrufen. (rsAccessDenied ...) Ah, jetzt hab ich es ! Beim Aufruf des Report Managers kommt ein Anmeldedialog, dort muss man sich nochmal als lokaler Administrator anmelden, dann klappt es. Vielen Dank !
    Freitag, 19. November 2010 12:55