none
Kein Zugriff mehr auf CRM RRS feed

  • Frage

  • Derzeit bin ich dabei CRM einzurichten.

    Der Zugriff unter IE8 hat auch geklappt.
    Doch nun erhalte ich nach dem Aufruf über den IE8 folgende Meldung:

    Fehler
    Es ist ein Fehler aufgetreten.
    Wiederholen Sie diese Aktion usw.

    Wo erhalte ich nun Informationen wo ich weitere Hinweise bekomme, warum sich CRM nicht mehr aufrufen lässt?

     

    Sonntag, 14. März 2010 09:09

Antworten

  • Hallo,

    weitere Informationen findest du an den üblichen stellen, Ereignisanzeige, Log-Dateien und Trace Files.
    Wo du welche Logfdatei finden kannst, kannst du hier nachlesen. Das tracen kannst du am einfachten mit diesem Tool einschalten CrmDiagTool4
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Sonntag, 14. März 2010 09:50
  • Hallo,

    nur eine einzige, unvollständige Fehlermeldung ist ein bisschen wenig, um dir weiterhelfen zu können.
    Steht nicht mehr in den Logdateien?

    Kleiner TIpp, die Logdateien kann man mit diesem Trace Log Viewer sehr viel einfacher analysieren und nach möglichen Problemen durchsuchen.

    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Mittwoch, 17. März 2010 18:15
  • Hallo,

    ich würde einfach den oben angesprochenem Dienst die entsprechenden Rechte auf der MSCRM_CONFIG Datenbank geben, dann sollte alles funktionieren.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Freitag, 2. April 2010 17:35
  • Danke für die Hilfe und Infos. Leider hat alles nicht zum Erfolg geführt.

    Da sich die Anforderungen an das CRM-System geändert hat, habe ich alles nochmal neu installiert.



     

    Sonntag, 30. Mai 2010 15:54

Alle Antworten

  • Hallo,

    weitere Informationen findest du an den üblichen stellen, Ereignisanzeige, Log-Dateien und Trace Files.
    Wo du welche Logfdatei finden kannst, kannst du hier nachlesen. Das tracen kannst du am einfachten mit diesem Tool einschalten CrmDiagTool4
    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Sonntag, 14. März 2010 09:50
  • Hallo,

    nur eine einzige, unvollständige Fehlermeldung ist ein bisschen wenig, um dir weiterhelfen zu können.
    Steht nicht mehr in den Logdateien?

    Kleiner TIpp, die Logdateien kann man mit diesem Trace Log Viewer sehr viel einfacher analysieren und nach möglichen Problemen durchsuchen.

    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Mittwoch, 17. März 2010 18:15
  • Hi,

    alternativ zur Log-Analyse

    - tritt der Fehler bei allen Benutzern auf?
    - hast du in der web.config die DevErrors auf On?
    - du beziehst dich explizit auf IE8. Klappts denn mit einer anderen Version?
    Mittwoch, 17. März 2010 21:48
  • @ckeller

    - Da ich noch dabei bin das System anzupassen habe ich nur einen Benutzer. Damit ist das CRM auch immer gestartet.

    - Nein ist nicht auf On

    - Hat mit IE8 immer geklappt. Eine andere Version ist nicht installiert.

    @Michael Sulz

    Das Tool TraceLogViever hat mir da schon mehr Fehler angezeigt.
    Zum einen treten Errors im AsynchronenProcessen beim Starten von CRM auf und dann noch beim Web-Dienst.
    Ist ja Wochenende und da ist ja wieder Zeit für so was.

    Danke erstmal für die bisherigen Hinweise.

     

    Freitag, 19. März 2010 16:10
  • Könnte sein das dies hier der Grund für den Fehler ist

    at MainApplication.Application_OnStart()
    at RuntimeMethodHandle._InvokeMethodFast(Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)
    at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
    at RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
    at HttpApplication.ProcessSpecialRequest(HttpContext context, MethodInfo method, Int32 paramCount, Object eventSource, EventArgs eventArgs, HttpSessionState session)
    at HttpApplicationFactory.FireApplicationOnStart(HttpContext context)
    at HttpApplicationFactory.EnsureAppStartCalled(HttpContext context)
    at HttpApplicationFactory.GetApplicationInstance(HttpContext context)
    at HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
    at HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
    at ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)
    >Exception occurred in Application_OnStart: System.TypeInitializationException: Der Typeninitialisierer für "Microsoft.Crm.ApplicationSqmHelper" hat eine Ausnahme verursacht. ---> System.Data.SqlClient.SqlException: Die von der Anmeldung angeforderte 'MSCRM_CONFIG'-Datenbank kann nicht geöffnet werden. Fehler bei der Anmeldung.
    Fehler bei der Anmeldung für den Benutzer 'NT-AUTORITÄT\NETZWERKDIENST'
    .
    bei System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
    bei System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
    bei System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
    bei System.Data.SqlClient.SqlConnection.Open()
    bei Microsoft.Crm.CrmDbConnection.Open()
    bei Microsoft.Crm.SharedDatabase.DatabaseMetadata.LoadMetadataXmlFromDatabase(CrmDBConnectionType connectionType, String connectionString, Int32& maxBlobSize)
    bei Microsoft.Crm.ConfigurationDatabase.ConfigurationMetadata.get_Cache()
    bei Microsoft.Crm.SharedDatabase.DatabaseService.Initialize(String tableName)
    bei Microsoft.Crm.SharedDatabase.DatabaseService.Retrieve(String tableName, String[] columns, PropertyBag[] conditions)
    bei Microsoft.Crm.ServerLocatorService.GetDeploymentIdFromDatabase()
    bei Microsoft.Crm.ServerLocatorService.GetDeploymentId()
    bei Microsoft.Crm.ServerLocatorService.GetDeploymentSetting(String settingName)
    bei Microsoft.Crm.CrmTraceSettings.LoadScaleGroupSettings()
    bei Microsoft.Crm.CrmTraceSettings.Load(String traceDirectory)
    --- Ende der internen Ausnahmestapelüberwachung ---
    bei Microsoft.Crm.MainApplication.Application_OnStart()

    Bei der Datenbank 'MSCRM_CONFIG' ist der Benutzer 'NT-AUTORITÄT\NETZWERKDIENST' mit dem Standardschema 'NT-AUTORITÄT\NETZWERKDIENST' eingetragen.
    Bei Schemas im Besitz ist der Haken nur bei 'NT-AUTORITÄT\NETZWERKDIENST' gesetzt. Dann ist noch bei Mitgliedschaft in Datenbankrollen der Haken nur bei "db_owner.

    Warum klappt nun der Zugriff auf diese Datenbank nicht mehr?

    Samstag, 20. März 2010 19:48
  • Funktioniert der SQL Server an sich?

    Wurden irgendwelche Netzwerk- oder Active Directory-Einstellungen verändert? Ich habe ähnliche Fehler ab und zu gehabt, wenn auf meine Entwicklungsmaschinen die Einstellungen für Netzwerk, Domäne und Internetproxy nicht mehr ganz sauber waren und dadurch dann die Authentifizierung im SQL Server bzw. im AD fehlgeschlagen ist.

    Mittwoch, 24. März 2010 09:43
  • Der SQL-Server funktioniert so weit wie ich das Beurteilen kann.
    Mit dem SQL-Server Management Studio komme ich an die Datenbank.

    Ich hatte Versucht die Rolle AD-Zertifizierungsdienst auf dem Server zu installieren.
    Da mir das aber nicht so Fehlerfrei geglückt war habe ich die Rolle wieder entfernt.

    Wie hast du denn Unternommen wenn der Fehler auftrat?

    Mittwoch, 24. März 2010 18:25
  • Kann ich gerne beschreiben, aber keine Ahnung ob dir das hilft.

    Bei mir traten solche Dinge immer dann auf, wenn sich meine Entwicklungsdomäne und unsere Live-Domäne in die Quere kamen. Das konnte ich dann immer durch eine Bereinigung der Netzwerkeinstellungen (also Trennung der Netze, kein NAT, kein nichts) regeln. Ansonsten griff teilweise der Proxy der Livedomäne auf den Server der Entwicklungsdomäne zu, kannte den DNS-mäßig nicht und zudem kamen falsche Credentials an...ein reines Netzwerk-Gewusel.

    Im Worst-Case könntest du ja eine Reparaturinstallation des CRM versuchen. Ist das System schon live?

    Donnerstag, 25. März 2010 14:37
  • Danke für den Hinweis.

    Der Server ist noch nicht im prod. Einsatz. Ich bin immer noch bei der Anpassung. Nur die bisher gemachten Anpssungen bei den Entitäten möchte ich ungern wieder Neu machen. Bald kommen ja die Ostertage und da ist ja wieder genügend Zeit was an dem Server zu machen.

    Wollte schon die Serversicherung vor den Problemen auf eine extra Festplatte zurücksichern. Da Meckert aber das Wiederherstellungsprogramm. Obwohl es sich bei der Quellen- und bei der Ziel-Festplatte um den gleichen Festplattentyp handelt, kommt die Meldung das das Ziellaufwerk nicht kleiner als das Quellenlaufwerk sein darf. 

    Donnerstag, 25. März 2010 17:42
  • Kann es vielleicht sein, dass du einen tieferen Fehler hast? Wenn schon das Wiederherstellungsprogramm rummault...
    Donnerstag, 1. April 2010 11:57
  • Hallo,

    ich würde einfach den oben angesprochenem Dienst die entsprechenden Rechte auf der MSCRM_CONFIG Datenbank geben, dann sollte alles funktionieren.


    Viele Grüße

    Michael Sulz
    MVP für Microsoft Dynamics CRM
    • Als Antwort markiert Michael Sulz Samstag, 30. März 2013 14:08
    Freitag, 2. April 2010 17:35
  • Hallo,

    danke für den Hinweis.
    Bei welchem Dienst sollen die Rechte auf die Datenbank gegeben werden? 

    Donnerstag, 15. April 2010 05:40
  • Hallo,

    hast du immer noch das Problem oder hast du mittlerweile eine eigene Lösung gefunden?

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Montag, 17. Mai 2010 14:38
    Moderator
  • Hallo Jürgen,

    danke für die Nachfrage.
    Leider habe ich bisher keine Lösung gefunden.
    Ich werde wohl den SQL Server und CRM neu aufsetzen und nochmal von vorne anfangen.

    Viele Grüße
    Bernd

    Montag, 17. Mai 2010 18:58
  • Hast du das hier schon einmal versucht?

    http://crmhacks.blogspot.com/2008/04/mscrm4-diagnostic-cannot-open-database.html

    In jedem Fall solltest du es auch einmal mit den aktuellen Rollup Updates versuchen.

    Ansonsten ist es für den Standard erst einmal eine stabile Vorgehensweise, mit Standardberechtigungen, wie sie direkt ab Installation vorliegen zu arbeiten. Lokale Richtlinien oder spezielle Benutzerkonten verkomplizieren meist eine Installation. Später kann man die restriktiveren Einstellungen immer noch vornehmen.

    Viele Grüße,
    Jürgen


    Jürgen Beck

    Dipl. Kfm./Wirtschaftsinformatik
    MVP, MCSD.NET, MCITP DBA, MCDBA, MCSE
    Microsoft Certified Business Management Solutions Professional
    Microsoft Certified CRM Developer
    Microsoft Certified Trainer

    ComBeck IT Services & Business Solutions
    Microsoft Gold Certified Partner
    Microsoft Small Business Specialist

    Developing & Supporting Business Applications from small business to big enterprises covering scores of sectors

    http://www.combeck.de
    Montag, 17. Mai 2010 19:46
    Moderator
  • Danke für die Hilfe und Infos. Leider hat alles nicht zum Erfolg geführt.

    Da sich die Anforderungen an das CRM-System geändert hat, habe ich alles nochmal neu installiert.



     

    Sonntag, 30. Mai 2010 15:54