none
Windows Server 2012 mit Hyper-V Systemtask lastet Festplatte aus RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe auf einem System mit Server 2012 und aktivem Hyper-V sporadische Auslastungspeaks der Festplatten. Der Ressourcenmonitor zeigt dann an, dass der Systemtask mit der ID4 auf die Datenplatte, auf der auch die VHDX Dateien liegen, zugreift und mit knapp 100% aktiver Zeit gleichzeitig liest und schreibt, was die Platten halt hergeben (sowohl lesen als auch schreiben gleichzeitig bei meist 70 bis 80 MB/s) und beide Werte ändern sich miteinander, d.h. wenn langsamer gelesen wird, wird auch langsamer geschrieben. Als würde das System also irgendwas kopieren.

    Der Zugriff dauert unterschiedlich lange, meist so 15 bis 20 Minuten. In dieser Zeit ist das System quasi lahmgelegt und Plattenzugriffe in den VMs sind nicht möglich. Der Host selber läuft normal, reagiert problemlos und auch Zugriffe auf die Datenplatte sind - wenn auch langsam - möglich.

    Das System verwendet, da Testsystem, nur SATA Platten an einem Adaptec SAS RAID Controller (2x 250 GB RAID1 boot, 5x 1 TB RAID5, Daten), AMD CPU, 32 GB Ram. Virtualisiert sind ein DC, ein WSUS und ein Exchange 2013, allesamt jeweils unter Server 2012.

    Es gibt zu dem Zeitpunkt keine Backuptasks oder ähnliches, was ich selber eingerichtet hätte. Zudem würde man da ja auch CPU Auslastung sehen. Die CPU ist aber eher gelangweilt.

    Mir fehlen irgendwie die Ideen. Wer hat noch welche?

    Dienstag, 10. September 2013 21:51

Alle Antworten

  •  

    Hallo Windingo,

    Langsamen Festplatten kann man mittels Ressourcenmonitoren ansehen.

    ID4 ist das system Process aber was meinen Sie mit 100% aktiver Zeit ?

    Eine langsame Festplatte gibt lange Antwortzeit und Warteschlange. Was sehen Sie ?

    Gibt es ein Cache auf der Controller ? Ist es aktiviert ?

    Haben Sie etwas wie ein Antivirus auf dem Host installiert

    viele Grüße

    Nathan

    Donnerstag, 12. September 2013 14:15
  • Die Festplatten sind nicht langsam, ich schrieb ja, gleichzeitig etwa 70 bis 80 MB/s lesen und schreiben.

    "100% aktive Zeit" ist die Angabe in Microsoft Deutsch im Taskmanager bezüglich der HDD Auslastung. Die Warteschlange ist natürlich dementsprechend voll. Ich habe kein allgemeines Performance-Problem, sondern nur zeitweise eine plötzliche Auslastung der Festplatten.

    Es gibt einen Cache auf dem Controller, er ist auch aktiviert. Antivirus Software ist auf keinem der Server.

    Donnerstag, 12. September 2013 14:24
  • Ich verstehe dass Sie die Aktivität des Festplatten während der Auslastung beobachten wollen.  Während der Auslastung, der Prozess der auf der Festplatte am moisten zugrifft (Gesamt B/s) ist System.

    Sie haben auch eine CPU Auslastung.

    Ist Der system Prozess auch in dieser Zeit der meisten Prozess für das CPU ?

    Haben Sie Process Monitor ausprobiert ? Es könnte vielleicht helfen.

    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Freitag, 13. September 2013 11:58
  • Mit welchem Programm ich die Sache anschaue ist letztlich egal, zu dem Zeitpunkt gibt es keinen Prozess, der die CPU besonders auslastet. Egal ob das nun per Taskmanager, Ressourcenmonitor oder Process Monitor angezeigt wird.
    Freitag, 13. September 2013 12:07
  • Mit Process Monitor können Sie die Aktivität der Festplatten für jeden Prozess anschauen. Vielleicht können Sie es während des Zeitpunkt benutzen.
    http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    Hier ist ein Beispiel

    Montag, 16. September 2013 16:02
  • Nein, da sich ja leider nur eine Person gemeldet hat, die mir sagen wollte, wie ich das sehen kann, was ich schon sehe. Ich _weiß_ ja schon, dass es der System Prozess ist.

    Die Umgebung wurde jetzt auf Server 2012 R2 aktualisiert, wobei auch zwei der VMs (DC & WSUS) komplett neu eingerichtet wurden. Ich habe das Problem seitdem nicht mehr beobachten können und hoffe, dass es sich damit erledigt hat.

    Eine wirkliche Idee oder eine Lösung, warum das überhaupt passiert ist, hab ich aber nicht gefunden.

    Montag, 30. September 2013 07:27
  • Nein, da sich ja leider nur eine Person gemeldet hat, die mir sagen wollte, wie ich das sehen kann, was ich schon sehe. Ich _weiß_ ja schon, dass es der System Prozess ist.

    Die Umgebung wurde jetzt auf Server 2012 R2 aktualisiert, wobei auch zwei der VMs (DC & WSUS) komplett neu eingerichtet wurden. Ich habe das Problem seitdem nicht mehr beobachten können und hoffe, dass es sich damit erledigt hat.

    Eine wirkliche Idee oder eine Lösung, warum das überhaupt passiert ist, hab ich aber nicht gefunden.

    Ich habe das exakt genau gleiche Problem:

    Umgebung: HyperV-Host mit 2008 R2 SP1, 1 DC virtualisiert mit SBS2011 und ein TS mit 2008 R2 SP1

    Prozess ID 4 lastet das System brutal aus und meistens ist 100% Zeit mit max. Aktivität:

    Folgen: Sehr langsame TS-Umgebung für die Benutzer

    Habt ihr irgendwas herausgefunden oder eine Idee?

    Grüsse


    • Bearbeitet alpha_tt Dienstag, 25. Februar 2014 12:31
    Dienstag, 25. Februar 2014 12:29
  • Es ist nicht ungewöhnlich, dass virtuelle Systeme, auch entsprechend die Platten auslasten. Ein Grund, warum man virtuelle Systeme, niemals auf der Systemplatte laufen lassen sollte, da sonst der gesamte Server zeitweilig "einfrieren" kann ...

    Dienstag, 25. Februar 2014 23:11
  • Hi,

    sind denn in der Detailansicht irgendwelche Dateien auffällig? Wird auf den Server via SMB zugegriffen?
    Sind die Dateien die angefasst werden zufällig die VHD der VM's?
    Paged der virtualisierte Terminalserver sich vielleicht zu Tode und killt damit die Platte des Hosts?

    Gruß
    Lennart

    Freitag, 28. Februar 2014 12:48

  • Sind die Dateien die angefasst werden zufällig die VHD der VM's?

    Korrekt. In der Detailansicht schwankt die Datenträger-E/A hin und her aber was mich irritiert ist, dass 10% Zeit mit max. Aktivität ist. Was bedeutet das, gibts irgendwo eine Erklärung? Kann es irgendwas mit der "trägen Umgebung" zu tun haben?

    @KlausKroenert: Warum das? Über welche Plattenanbindung ist denn der Zugriff für Hyper-V schneller als über die lokalen Festplatten?

    Montag, 3. März 2014 10:55
  • Hi,

    habt ihr vielleicht innerhalb der VM ein Performaceproblem und die VM paged einfach zu viel?

    KlausKroenert meint, dass VM's nicht auf die selbe Disk sollten, wie das Betriebssystem. Wenn die Disk ausgelastet ist, dann hängt natürlich auch dein komplettes System. Das OS sollte immer auf einer eigenen Disk (nicht nur Parition!) liegen.

    Montag, 3. März 2014 15:19
  • Hi,

    habt ihr vielleicht innerhalb der VM ein Performaceproblem und die VM paged einfach zu viel?

    Das mag sein, es ist ein SBS2011, aber voll am Limit läuft diese Maschine nicht. Gibt es generelle Empfehlungen (Statisch/Dynamisch), kann man die hohe Arbeitsspeichernutzung beschränken?

    Dienstag, 4. März 2014 15:01
  • Das ist die Grundfrage "wie size ich meinen Server".
    Schaut halt mal dort in den SBS rein und schaut euch die Performance und die Pagefileaktivität an.

    Je nachdem was der Server macht, vielleicht habt ihr ja auch IO intensive Anwendungen drauf laufen.

    Hier wurden schon mehrfach Tipps gegeben.

    • Lagert die VHDs auf eine andere Disk (nicht Parition!) aus. Bringt sie vor allem von der Disk runter, die das Host System beinhaltet.
    • Schiebt in euren Host vielleicht ein paar SSD's rein, die die VHDs vorhalten.

    RAM Nutzung kann man auch beschränken, Stichwort WSRM, ob das zielführend ist, ist aber eine andere Frage.

    Mittwoch, 5. März 2014 08:43
  • Danke für die Inputs

    Haben nun aber einen anderen Ansatz im Auge, offensichlich ist das Cache-Modul im RAID-Controller kaputt, dort hat er auch utopische Werte von 100%Read/0%Write.

    Ich denke das ist mitunter auch ein Grund für die Performance-Probleme

    Donnerstag, 6. März 2014 09:28
  • Danke für die Inputs

    Haben nun aber einen anderen Ansatz im Auge, offensichlich ist das Cache-Modul im RAID-Controller kaputt, dort hat er auch utopische Werte von 100%Read/0%Write.

    Ich denke das ist mitunter auch ein Grund für die Performance-Probleme

    Und so war es auch, jetzt läuft alles wie geschmiert.
    Freitag, 21. März 2014 12:47
  • Danke für die Inputs

    Haben nun aber einen anderen Ansatz im Auge, offensichlich ist das Cache-Modul im RAID-Controller kaputt, dort hat er auch utopische Werte von 100%Read/0%Write.

    Ich denke das ist mitunter auch ein Grund für die Performance-Probleme

    Wo hast du das gesehen mit dem Cach module?

    Habe ein HP Server mit ACU(Array Configuration Utility) dort sehe ich aber nichts :-(

    Montag, 24. November 2014 15:59