none
Öffentliche Ordner Berechtigungen defekt nach Migration RRS feed

  • Frage

  • Hallo zusammen,

    ich habe über die Feiertage und die freien Tage unseren Exchange von der Version 2010 auf die Version 2013 aktualisiert.
    Die Migration der Inhalte hat auch ziemlich "fast" reibungslos geklappt.

    Leider habe ich nach der Migration folgendes Problem mit unseren öffentlichen Ordnern:

    Die Zugriffsrechte auf die Öffentlichen Ordner werden mir im Outlook zwar angezeigt, greifen aber nicht. Das heißt:
    Ich bin als "Owner" eingetragen bei einem öffentlichen Ordner und allen seinen Child-Items. Jedoch darf ich keine Ordner anlegen oder löschen oder umbenennen.

    Ich habe bereits per Powershell meine Benutzerrechte entfernt und neu hinzugefügt, das zeigt aber keine Änderung. Das Outlook übernimmt die Anzeige immer korrekt, das heißt wenn ich mir die Rechte wegnehme dann verschwindet der Ordner aus meinen Outlook. Füge ich sie hinzu taucht der Ordner auch wieder auf. Leider greifen die restlichen Rechte nicht.

    Any ideas?

    Danke schon mal!

    EDIT:

    Gleiches gilt für öffentliche Ordner bei denen die "Send As" Berechtigung für manche User gesetzt ist. Die User sind eingetragen als erlaubte User, dürfen aber dann trotzdem laut Exchange-Fehlermeldung keine Mail senden.

    Mittwoch, 7. Januar 2015 07:55

Antworten

  • Hallo zusammen,

    ja ich habe tatsächlich eine Lösung für das Problem gefunden.

    Microsoft hat einfach mal wieder Mist gebaut.

    Es liegt daran, dass bei der Migration alle Öffentlichen Ordner auf die primäre und sekundäre Hierarchie verteilt werden.
    Von Haus aus ist es so konfiguriert, dass die sekundäre Hierarchie einfach schreibgeschützt ist und auch dementsprechend alle Inhalte.

    Zieht man die Inhalte in die primäre Hierarchie und weist diese auch den Usern als PublicFolderMailbox zu, dann geht alles wunderbar.

    Bei unseren 5.800 öffentlichen Ordnern hat allerdings der auserordentlich UNperformante IISWorker um die 12 Stunden gebraucht um das alles zu verarbeiten. Da es auch keine wirklich guten Skripts von Microsoft gibt die Rekursiv die Ordner verschieben muss man nahezu jede Ebene einzeln anstoßen.

    Das ist auf jeden Fall keine gute Lösung.

    Der Microsoft Support hat mir gesagt, dass ich alle Ordner neu erstellen muss, was natürlich bei der Zahl der Ordner keine Option war.

    Gefixt wird dieses Problem mit dem CU8, da kann aber bisher keiner sagen wann das veröffentlicht wird.
    Sollte jemand dieses Problem haben, dann ist der Weg der folgende:

    1. Alle Berechtigungen der User auf die PF wegnehmen
    2. Allen Usern die Primäre Hierarchie als DefaultPublicFolderMailbox zuweisen
    3. Alle PublicFolder aus der sekundären Hierarchie in die primäre Hierarchie verschieben
    4. Warten ....
    5. Clientrechte ALLE neu setzen.

    GANZ WICHTIG: Es gehen jegliche "Send-As" Berechtigungen verloren. Außerdem auch alle aktivierten Mail-Adressen werden zu ActiveDirectory Leichen. Diese müssen ebenfalls neu gesetzt werden und vorher per ADSI rausgeschnitten werden.

    Ich habe jetzt 4 Tage gebraucht um das ganze zu fixen.

    Exchange 2013 ist aus meiner Sicht nicht zu empfehlen, da wir bisher mehr Probleme haben, als einen wirklichen Nutzen.

    Gruß,

    Christoph

    Montag, 19. Januar 2015 12:09

Alle Antworten

  • Hallo Christoph,

    ausführen Sie bitte dem folgenden Befehl: Get-Mailbox „{hier mailbox geben}” | fl *public*

    Und wenn es möglich ist die Resultaten hier zu posten.

    Grüße,

    Teodora


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 8. Januar 2015 07:25
    Moderator
  • Hallo,

    auf was für eine Mailbox soll ich diesen Befehl ausführen?
    Ich habe 12 Mailboxen in der sekundären Hierarchie und 1 in der Primären Hierarchie.

    Wenn ich einfach nur Get-Mailbox | fl *public* aufrufe bekomme ich das folgende:

    http://edv.hl-s.de/txt.txt

    Donnerstag, 8. Januar 2015 07:31
  • Das hier bekomme ich auch noch als Antwort:

    [PS] C:\Windows\system32>get-mailbox -public | fl *public*


    IsRootPublicFolderMailbox  : True
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox :

    Donnerstag, 8. Januar 2015 08:46
  • Hallo Christoph,

    ich meine geben Sie folgendes ein: z.B. Get-Mailbox administrator | fl *public*

    Wenn Sie Besitzer den Ordner sind und auch Administrator. Wenn nicht, geben Sie das Alias den Besitzer ein und posten Sie die Resultaten.

    Grüße,

    Teodora


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Donnerstag, 8. Januar 2015 08:57
    Moderator
  • get-mailbox christoph.borchert | fl *public*

    IsRootPublicFolderMailbox  : False
    DefaultPublicFolderMailbox : hl-studios.de/Users/Mailbox1

    Ich bin als Besitzer der Ordner eingetragen und habe alle Rechte laut Outlook und laut Exchange-Powershell.
    Leider kann das Outlook die Rechte nicht anwenden. Wenn ich die Rechte versuche per Outlook zu ändern, dann bekomme ich eine Meldung, dass die Rechte nicht übernommen werden können.

    Donnerstag, 8. Januar 2015 09:08
  • Moin Christoph,

    ich hatte mal ein ähnliches Problem nach einer Migration. Meine Lösung war damals ein neuen OO zu erstellen, die Daten zu übernehmen und die Berechtigung dann neu zu setzen. Das Ganze kannst du dir hier nachlesen: https://social.technet.microsoft.com/Forums/de-DE/8708fb73-df6c-45d0-9148-2fc73c961564/addpublicfolderclientpermission-funktioniert-nicht-mit-benutzer-anonym?forum=exchange_serverde#7313458d-3b3b-4d9f-9e91-9c061607076a

    Gruß Rainer


    • Bearbeitet RaBu78 Donnerstag, 8. Januar 2015 09:26
    Donnerstag, 8. Januar 2015 09:26
  • Hi Rainer,

    ich habe bereits schon probiert neue Ordner zu erstellen und dann die Rechte neu zu vergeben.
    Das hat bei mir nichts gebracht, allerdings habe ich auch nicht versucht die Inhalte dann da hin zu übernehmen.

    Ich werde es jetzt einmal probieren und dann noch eine Rückmeldung geben.
    Wenn das funktioniert, dann ist das eine Lösung mit der ich leben kann & wahrscheinlich auch muss.

    Gruß

    Christoph

    EDIT:

    Also ich kann keine Ordner verschieben oder kopieren obwohl ich Besitzer bin. Er verweigert mir direkt die Rechte darauf.

    Donnerstag, 8. Januar 2015 10:35
  • Moin Christoph,

    die eigentliche Migration ist ohne Probleme oder Fehler durchgelaufen?

    In den Mailbox-Datenbanken steht die neue PF-DB drin?

    Alle User sind auf dem 2013?

    Wurde der 2010er schon entfernt?

    ;)


    Gruß Norbert

    Freitag, 9. Januar 2015 13:15
    Moderator
  • Hi Norbert,

    die eigentliche Migration ist durch. Jegliche Kommunikation läuft über den neuen.

    In den PublicFolderMailboxen stehen die neuen Datenbanken eingetragen.
    Die alten Datenbanken sind nicht mehr eingebunden.
    Mein Outlook sagt auch dass es nur noch mit dem neuen Server verbunden ist.

    Der 2010er läuft nebenbei macht aber nichts mehr.

    Gruß

    Christoph

    Freitag, 9. Januar 2015 13:19
  • Hallo Christoph,

    Haben Sie zufällig rausgefunden was die Lösung Ihrer Frage ist?
    Wenn Sie eine Lösung gefunden haben bitte teilen Sie sie der Community mit, so dass auch andere davon profitieren können.
    Bitte beachten Sie, dass ich wegen keiner weiteren Aktivitäten das Thema als Diskussion verschieben werde.

     
    Gruß,
    Teodora


    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Montag, 19. Januar 2015 11:54
    Moderator
  • Hallo zusammen,

    ja ich habe tatsächlich eine Lösung für das Problem gefunden.

    Microsoft hat einfach mal wieder Mist gebaut.

    Es liegt daran, dass bei der Migration alle Öffentlichen Ordner auf die primäre und sekundäre Hierarchie verteilt werden.
    Von Haus aus ist es so konfiguriert, dass die sekundäre Hierarchie einfach schreibgeschützt ist und auch dementsprechend alle Inhalte.

    Zieht man die Inhalte in die primäre Hierarchie und weist diese auch den Usern als PublicFolderMailbox zu, dann geht alles wunderbar.

    Bei unseren 5.800 öffentlichen Ordnern hat allerdings der auserordentlich UNperformante IISWorker um die 12 Stunden gebraucht um das alles zu verarbeiten. Da es auch keine wirklich guten Skripts von Microsoft gibt die Rekursiv die Ordner verschieben muss man nahezu jede Ebene einzeln anstoßen.

    Das ist auf jeden Fall keine gute Lösung.

    Der Microsoft Support hat mir gesagt, dass ich alle Ordner neu erstellen muss, was natürlich bei der Zahl der Ordner keine Option war.

    Gefixt wird dieses Problem mit dem CU8, da kann aber bisher keiner sagen wann das veröffentlicht wird.
    Sollte jemand dieses Problem haben, dann ist der Weg der folgende:

    1. Alle Berechtigungen der User auf die PF wegnehmen
    2. Allen Usern die Primäre Hierarchie als DefaultPublicFolderMailbox zuweisen
    3. Alle PublicFolder aus der sekundären Hierarchie in die primäre Hierarchie verschieben
    4. Warten ....
    5. Clientrechte ALLE neu setzen.

    GANZ WICHTIG: Es gehen jegliche "Send-As" Berechtigungen verloren. Außerdem auch alle aktivierten Mail-Adressen werden zu ActiveDirectory Leichen. Diese müssen ebenfalls neu gesetzt werden und vorher per ADSI rausgeschnitten werden.

    Ich habe jetzt 4 Tage gebraucht um das ganze zu fixen.

    Exchange 2013 ist aus meiner Sicht nicht zu empfehlen, da wir bisher mehr Probleme haben, als einen wirklichen Nutzen.

    Gruß,

    Christoph

    Montag, 19. Januar 2015 12:09