none
WDSUnttend.xml funktioniert nur teilweise. RRS feed

  • Frage

  • Hallo zusammen,

    ich hab ein kleines Problem mit meiner WDSUnattend.xml.

    Diese scheint im Grunde zu funktionieren, nur leider wiped sie die Festplatte nicht und kann keine Partitionierung vornehmen.

    Leider finde ich den Fehler nicht. Ich versuche ein Windows 7 x64 Professional zu installieren. Der Server ist mometan noch eine VM, der PC ist jedoch schon ein "echter" PC.

    Ich bedanke mich im Voraus für Vorschläge :)


    Anbei meine WDSUnattend.xml.

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <servicing></servicing>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>de-DE</UILanguage>
                    <WillShowUI>Never</WillShowUI>
                </SetupUILanguage>
                <InputLocale>de-DE</InputLocale>
                <SystemLocale>de-DE</SystemLocale>
                <UILanguage>de-DE</UILanguage>
                <UILanguageFallback>de-DE</UILanguageFallback>
                <UserLocale>de-DE</UserLocale>
                <LayeredDriver>1</LayeredDriver>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserData>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        <Key>Key</Key>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <FullName>Peter Lustig</FullName>
                    <Organization>Löwenzahn</Organization>
                </UserData>
                <EnableFirewall>false</EnableFirewall>
                <EnableNetwork>true</EnableNetwork>
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                                <Format>NTFS</Format>
                                <Active>true</Active>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                                <Format>NTFS</Format>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>100</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Order>2</Order>
                                <Size>65536</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Order>3</Order>
                                <Extend>true</Extend>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                    </Disk>
                    <WillShowUI>Never</WillShowUI>
                </DiskConfiguration>
                <WindowsDeploymentServices>
                    <Login>
                        <Credentials>
                            <Domain>Domain</Domain>
                            <Password>Passwort</Password>
                            <Username>User</Username>
                        </Credentials>
                    </Login>
                    <ImageSelection>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>2</PartitionID>
                        </InstallTo>
                        <WillShowUI>Always</WillShowUI>
                    </ImageSelection>
                </WindowsDeploymentServices>
            </component>
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>de-DE</UILanguage>
                    <WillShowUI>Never</WillShowUI>
                </SetupUILanguage>
                <InputLocale>de-DE</InputLocale>
                <LayeredDriver>1</LayeredDriver>
                <SystemLocale>de-DE</SystemLocale>
                <UILanguage>de-DE</UILanguage>
                <UILanguageFallback>de-DE</UILanguageFallback>
                <UserLocale>de-DE</UserLocale>
            </component>
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DiskConfiguration>
                    <WillShowUI>OnError</WillShowUI>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Order>1</Order>
                                <Size>100</Size>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Size>65536</Size>
                                <Order>2</Order>
                                <Type>Primary</Type>
                            </CreatePartition>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>3</Order>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Format>NTFS</Format>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                            </ModifyPartition>
                            <ModifyPartition wcm:action="add">
                                <Order>2</Order>
                                <PartitionID>2</PartitionID>
                                <Format>NTFS</Format>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                </DiskConfiguration>
                <UserData>
                    <ProductKey>
                        <Key>ProductKeyXY</Key>
                        <WillShowUI>Never</WillShowUI>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <FullName>Peter Lustig</FullName>
                    <Organization>Löwenzahn</Organization>
                </UserData>
                <WindowsDeploymentServices>
                    <Login>
                        <Credentials>
                            <Domain>Meine Domain</Domain>
                            <Password>Mein Passwort</Password>
                            <Username>Mein Username</Username>
                        </Credentials>
                    </Login>
                    <ImageSelection>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>2</PartitionID>
                        </InstallTo>
                    </ImageSelection>
                </WindowsDeploymentServices>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:e:/images/windows%207%20pro%20x64%20deutsch/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    Mittwoch, 24. April 2013 08:13

Antworten

  • Hallo zusammen,

    habe das Problem lösen können.

    Die DiskConfiguration der Unattend.xml auf Experts Exchange (kann leider keinen Link posten) hat schlussendlich zum Erfolg geführt.

    Bei näherer Betrachtung fiel mir auf, dass ein Teil nicht vorhanden ist:

    <CreatePartition wcm:action="add">

    Das wieso und warum kann ich nicht beantworten, aber es hilft!

    Ich hoffe, damit wird auch anderen geholfen, die dieses Problem haben.

    Gruß,

    MadBlade

    • Als Antwort markiert MadBlade91 Donnerstag, 25. April 2013 09:36
    Donnerstag, 25. April 2013 09:36

Alle Antworten

  • Jetzt auch nach mehreren weiteren Versuchen:

    Egal was ich versuche, die Platte wird nicht gewiped. (Andere Partitionierung, Umbennung in WDSClientUnattend.xml, usw... )

    Ich ging davon aus, dass ich im Punkt <DiscConfiguration> als ersten Punkt das Wipe = true haben muss, also hab ich das manuell verändert. Leider brachte auch das nichts...

    Was mach ich falsch?!


    Edit: Was mir gerade einfällt & evtl. noch wichtig sein könnte:

    Wenn ich die Partitionierungseinstellungen bei einer Installation via CD benutze, funktioniert das einwandfrei :)

    • Bearbeitet MadBlade91 Mittwoch, 24. April 2013 11:08 Ergänzung
    Mittwoch, 24. April 2013 10:56
  • Hallo zusammen,

    habe das Problem lösen können.

    Die DiskConfiguration der Unattend.xml auf Experts Exchange (kann leider keinen Link posten) hat schlussendlich zum Erfolg geführt.

    Bei näherer Betrachtung fiel mir auf, dass ein Teil nicht vorhanden ist:

    <CreatePartition wcm:action="add">

    Das wieso und warum kann ich nicht beantworten, aber es hilft!

    Ich hoffe, damit wird auch anderen geholfen, die dieses Problem haben.

    Gruß,

    MadBlade

    • Als Antwort markiert MadBlade91 Donnerstag, 25. April 2013 09:36
    Donnerstag, 25. April 2013 09:36