none
Textverketten() exportiert falsch ins Clipboard

    Frage

  • Hallo,

    das angezeigte Ergebnis der Textverketten-Funktion stimmt nicht immer mit dem in das Clipboard kopierte überein.

    Wenn ich einen Text, den ich mit Textverketten erzeugt habe, ins Clipboard kopiere und dann in den Windows Editor paste, fügt Excel manchmal

    zusätzliche Hochkommata ein, was m.M. nach ein Bug ist.

    Dies geschieht nicht, wenn ich den Zellinhalt im Editmodus markiere, kopiere und paste und auch nicht, wenn ich den Zellinhalt in dieses Forumfenster

    paste ?!?

    1) Text wird nicht wie gezeigt an das Clipboard übergeben:

    Ausgangsdaten:

    { " Horse ": "red" ,
    " Stamina ": 120 ,
    " Speed ": 1650 ,
    " Nervousness ": 50
    }

    (in den 3 leeren Zellen in Spalte I steht die Funktion =Zeichen(10)  für einen Zeilenumbruch im Ergebnis

    Funktion:

    =TEXTVERKETTEN("";WAHR;I1:N18)

    In Excel angezeigtes, erwünschtes Ergebnis:

    {"Horse":"red",
    "Stamina":120,
    "Speed":1650,
    "Nervousness":50}

    Ergebnis in dieses Community Formum Edit-Fenster per cut&paste (ok, wie ich es erwarten würde!):

    {"Horse":"red",
    "Stamina":120,
    "Speed":1650,
    "Nervousness":50}

    Ergebnis vom Clipboard im Windows Editor und in Notepad ++ jedoch statt dessen:

    "{""Horse"":""red"",
    ""Stamina"":120,
    ""Speed"":1650,
    ""Nervousness"":50}"

    2) In diesem Fall wird das Ergebnis wie in Excel angezeigt übergeben:

    Ausgangsdaten und Ergebnis:

    text  text text texttexttext
    text text

    Formel:

    =TEXTVERKETTEN("";WAHR;K19:L20)

    Ergebnis im Editor und Notepad++:

    text texttexttext

    3) Resümee:

    Beim ersten Fall scheint irgendwie die Zellstruktur der Ausgangsdaten im Clipboard erhalten zu bleiben und von den empfangenden Programmen

    verarbeitet zu werden (was die zusätzlichen " erklärt). Im 2. Fall aber nicht?!?

    Auch wenn man im zweiten Fall einen der Texte durch einen Zahl ersetzt oder die Parameter "Tennzeichen" oder "leere Zellen ignorieren"  ändert, bleib das Ergebnis gleich... (z.B.: text 100texttext)

    Hat jemand eine Idee oder kann jemand das an Microsoft als Bug melden? Ich will hier ein größeres Json erzeugen und die zusätzlichen Gänsefüsschen stören da sehr. :-(

    Vielen Dank im Voraus

    Olaf

    p.s. ich könnte die Ergebnisse natürlichüber dieses Forumfenster kopieren - hier macht er es ja richtig ... das wäre aber wohl die letzte Lösung (lol)

    Dienstag, 5. September 2017 05:21

Alle Antworten

  • Exportiert falsch kann man so nicht sagen, schließlich klappt das Kopieren innerhalb von Excel einwandfrei.
    Ursache ist, dass beim Bereitstellen im Clipboard meist mehrere Formate bereitsgestellt werden.
    Bei anwendungsübergreifendem Kopieren muss man durchaus schon mal andere Wege gehen, da der Empfänger mit den Formaten nicht immer zurechtkommt.

    Bei Word z.B. kann ich beim Einfügen über das Menü noch zwischen verschiedenen Formaten (z.B. "Nur Text") unterscheiden.

    Wenn ich also beim Empfänger nur den reinen Text haben will, muss ich in Excel halt den Text und nicht die Zelle kopieren. Denn beim Einfügen in Excel wird neben dem Text i.d.R. alles aus der markierten Zelle kopiert (Formate + Inhalte).

    Was genau im Clipboard ankommt kann man sehr schön mit folgendem Tool ansehen:
    http://www.freeclipboardviewer.com/


    • Bearbeitet bfuerchau Dienstag, 5. September 2017 07:43
    Dienstag, 5. September 2017 07:42