none
Empfangsconnector 530 5.7.1 Client was not authenticated (in reply to MAIL FROM command)) RRS feed

  • Frage

  • Guten Tag,

    ich habe bei Exchange 2010 in dem Hubtransport zwei Empfangsconnectoren erstellt einmal ist es der default und einmal einen mit Namen extern.

    Bei default ist in dem Berechtigungsgruppe Anonyme Benutzer deaktviert. Bei Extern habe ich Anonyme Benutzer aktiviert da wir ein Linux SMPT Relay haben. Jedoch greift das "extern" nicht. Erst wenn ich bei default Anonyme Benutzer an hake funktioniert es? Im Reiter Netzwerk habe ich bei "extern" auch extra nur die IP Adresse des SMTP Relay eingetragen. Oder greift die nicht weil bei "default" alle verfügbaren IPv4 Adressen drin steht?


    • Bearbeitet MaddinB Donnerstag, 23. Februar 2012 06:33
    • Typ geändert Alex Pitulice Mittwoch, 29. Februar 2012 15:07 Warten auf Feedback
    • Typ geändert Alex Pitulice Mittwoch, 28. März 2012 11:04 Noch aktiv
    Donnerstag, 23. Februar 2012 06:30

Antworten

  • Hallo,

    also es funktioniert jetzt, eingestellt habe ich:

    Email von Remoteservern empfangen: die Relays eingetragen (Linux)

    Authentifierzung: Extern gesichert

    Berechtigungsgruppen: Anonyme Benutzer, Partner

    • Als Antwort markiert Alex Pitulice Mittwoch, 28. März 2012 11:04
    Mittwoch, 28. März 2012 09:45

Alle Antworten

  • Moin,

    Bei default ist in dem Berechtigungsgruppe Anonyme Benutzer deaktviert. Bei Extern habe ich Anonyme Benutzer aktiviert da wir ein Linux SMPT Relay haben. Jedoch greift das "extern" nicht.

    Extern bedeutet auch, dass der sendende Server ein Computer-Konto hat und Mitglied der "Exchange Server" Gruppe ist und Du diese auch angehakt haben musst. Ist das bei Dir der Fall.

    Zum Verständnis (Abschnitt "Receive Connector Authentication Settings"):
    http://technet.microsoft.com/en-us/library/aa996395.aspx


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Donnerstag, 23. Februar 2012 08:26
  • Hallo,

    also die Konstelation ist:

    Internet -> Linux SMTP -> Exchange 2010

    wieso braucht der ein Computerkonto?Wenn ich bei default anonyme Benutzer anhacke geht es doch auch?

    Donnerstag, 23. Februar 2012 09:37
  • Hi,

    ein wirklich "anonymes" Relay ist mit vorsicht zu genießen - aber machbar:

    Creating an anonymous relay

    Grüße,

    Chris


    Christopher Dargel

    Chris' Exchange Blog - blog.dargel.at

    MCITP Enterprise Messaging Administrator 2007 / 2010

    Donnerstag, 23. Februar 2012 09:40
  • Moin,

    hast Du den Link gelesen?

    wieso braucht der ein Computerkonto?

    weil die Prüfung der berechtigten Computer bei "extern" für die Exchange Server Gruppe läuft und um da reinzukommen braucht man ein Computerkonto.

    Wenn ich bei default anonyme Benutzer anhacke geht es doch auch?

    Wenn das das gleiche wäre, hätte sich MSFT die beiden Auswahlmöglichkeiten sparen können, oder. ;)


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Donnerstag, 23. Februar 2012 09:41
  • Hi,

    den Link den Robert gepostet hat hast du durchgelesen oder? Dort ist auch dein Fall erläutert? Hast du den Connector eigentlich auf die IP des Relays eingeschränkt?


    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.com/blogs/wstein/ Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer"; if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. If a answer or remark helps you to cope with your problem you can "mark it as helpful".

    Donnerstag, 23. Februar 2012 09:46
    Moderator
  • Also extern ist jetzt nicht der hacken gemeint,sondern so habe ich nur meinen connector genannt.

    Ich habe jetzt einen zusätzlichen connector erstellt und wie auf der Seite besprochen den so eingerichtet:

    usage type: internet

    default permission group: AnonymousUser, Partner

    default authentication: none

    geht trotzdem nicht erst wenn ich bei default wieder "anonyme user " anhacke geht es.

    ja habe den connector auf die ip eingeschränkt

    Freitag, 24. Februar 2012 15:14
  • Moin,

    Also extern ist jetzt nicht der hacken gemeint,sondern so habe ich nur meinen connector genannt.

    und woher sollen wir das wissen? Extern ist nun mal auch ein Fachbegriff bei Connectoren.

    Ich habe jetzt einen zusätzlichen connector erstellt und wie auf der Seite besprochen den so eingerichtet:

    usage type: internet

    default permission group: AnonymousUser, Partner

    default authentication: none

    Wenn Du gar keine Optionen bei Authentifzierung einschaltest, wird der nie funktionieren. Wie auch, wenn der Connector nicht weiß, wen er vor sich hat. Er muss entweder wissen, dass er Anonyme oder Authentifizierte durchlassen soll.


    Grüße aus Berlin schickt Robert
    MVP Exchange Server
    Freitag, 24. Februar 2012 16:11
  • Hallo Maddin2803,

    Ist Deine Situation eigentlich abgeklärt? :) Können wir den Thread schließen?
    Wenn ja - bitte markiere den hilfreichen Beitrag(oder die Beiträge) "als Antwort".  
    Viele Grüße,
    Alex

      

    Alex Pitulice, MICROSOFT 
    Bitte haben Sie Verständnis dafür, dass im Rahmen dieses Forums, welches auf dem Community-Prinzip „IT-Pros helfen IT-Pros“ beruht, kein technischer Support geleistet werden kann oder sonst welche garantierten Maßnahmen seitens Microsoft zugesichert werden können.

    Mittwoch, 29. Februar 2012 09:24
  • Leider noch nicht geklärt.

    Hallo Robert Wille, was muss ich denn in dem Reiter uthentifizerung angeben? Weil es passt ja keine so wirklich oder?

    Gemeint ist dieser Reiter:

    Bei Berechtigungsgruppen habe ich Anonyme Benutzer und Partner angehackt und bei Allgemein steht die IP Adresse des Linux Relays drin.

    Oder liegt das Problem daran das ich einen weiteren Empfangsconnector habe der im Reiter Netzwerk das hat:

    und daher der zweite connector garnicht erst greift?

    • Bearbeitet MaddinB Montag, 5. März 2012 08:31
    Montag, 5. März 2012 08:26
  • Hi Maddin2803,

    bist du hier schon weiter gekommen? Du musst immer bedenken, dass die Eigenschaften des Connectors immer direkten Einfluss auf die Rechte haben. Darüber wird definiert welche Sender (ms-Exch-SMTP-Accept-Any-Recipient) oder Empfänger (ms-Exch-SMTP-Accept-Any-Recipient) akzeptiert werden.

    Hier wird das etwas schöner beschrieben, auch wenn der Artikel von Robert alles definiert:
    http://blogs.technet.com/b/exchange/archive/2006/12/28/3397620.aspx

    Wenn du für den ReceiveConnector mal das SMTP-Logging aktivierst, wirst du da auch ganz schön sehen, wie die Kommunikation abgehandelt wird und welche Rechte die Verbindung hat.

    Poste auch mal get-receiveconnector|fl, damit wir das besser überblicken können.
     -- Viele Grüße
    Christian

    Freitag, 9. März 2012 05:55
    Moderator
  • Hallo,

    nein leider habe ich mit diesem Thema genau zwei große Baustellen und weiß nicht mehr so wirklich wo mir der Kopf steht weil ich den Überblick irgendwie über die Connectoren verloren habe.

    Welchen Connector nutzen denn die AD Outlook Clients? Den Default?

    Was ich will ist einfach nur das unser Linux Relay an den Exchange 2010 Emails versenden kann. Langsam verstehe ich es ja, ich muss einen zusätzlichen Connector einstellen, der unter "Email von Remoteservern mit folgenden IP-Adressen empfangen" das Linux Relay einstellen oder?Und bei "Diese lokalen IP-Adressen zum Empfangen von Email verwenden" muss der ebenfalls rein mit alle lokalen IP Adressen und Port 25. Doch gehen dann noch die Exchange Outlook Clients in der Domäne? Ja oder?

    Dienstag, 20. März 2012 14:06
  • Hallo Maddin2803,

    also Deine Outlook Clients sollten "normalerweise" MAPI verwenden und gehen daher nicht über die Konnektoren. Von dem Default Konnektor lässt Du am Besten auch die Finger und Deinen "Externen" Konnektor löscht Du mal wieder. Anschließend folgst Du genau den Anweisungen in diesem Artikel hier: http://technet.microsoft.com/de-de/library/bb232021.aspx

    Da hast Du alles was brauchst ;-)

    Melde Dich, wenn es geklappt hat oder Du noch Fragen hast.

    Viele Grüße
    Timo

    Sonntag, 25. März 2012 20:27
  • Hallo,

    also es funktioniert jetzt, eingestellt habe ich:

    Email von Remoteservern empfangen: die Relays eingetragen (Linux)

    Authentifierzung: Extern gesichert

    Berechtigungsgruppen: Anonyme Benutzer, Partner

    • Als Antwort markiert Alex Pitulice Mittwoch, 28. März 2012 11:04
    Mittwoch, 28. März 2012 09:45