none
SCCM Client wird während OSD nicht installiert RRS feed

  • Frage

  • Hallo,

    ich habe seit kurzem ein merkwürdiges Problem. SCCM 2012 R2 mit CU5.

    Während des OSD wird der SCCM Client nicht installiert. Das hat natürlich auch zur Folge das danach auch keine Programme installiert werden. Auf dem Client habe ich in den LOGS dann ein ccmsetup.log

    Dies zeigt auch ein Fehlercode aber leider kann ich dazu nicht richtiges finden. Hat vielleicht schon mal jemand so ein Thema gehabt?

    Hier die letzten Zeilen des LOG Files:

    <![LOG[Sending Fallback Status Point message to 'NGSCCM01.test.LOCAL', STATEID='311'.]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9760">
    <![LOG[spNS.Open(L"root\\ccm"), HRESULT=8004100e (e:\qfe\nts\sms\framework\smscore\smsutil.cpp,426)]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="ccmsetup" context="" type="0" thread="2544" file="smsutil.cpp:426">
    <![LOG[Failed to get client version for sending messages to FSP. Error 0x8004100e]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="ccmsetup" context="" type="2" thread="2544" file="ccmsetup.cpp:9842">
    <![LOG[CFSPStateMessage::SetTopicType]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:405">
    <![LOG[CFSPStateMessage::SetTopicID]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:435">
    <![LOG[CFSPStateMessage::SetStateID]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:345">
    <![LOG[Params to send FSP message '5.0.7958.1604 Deployment Error 0x8024800c. Pre-req: dotNetFx40_Client_x86_x64.exe']LOG]!><time="12:34:41.304-120" date="10-19-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:9891">
    <![LOG[CFSPStateMessage::SetMessageUserParam]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:525">
    <![LOG[CFSPStateMessage::SetMessageUserParam]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:525">
    <![LOG[CFSPStateMessage::SetMessageUserParam]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:525">
    <![LOG[CFSPStateMessage::SetMessageUserParam]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:525">
    <![LOG[CFSPStateMessage::SetMessageUserParam]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:525">
    <![LOG[CFSPStateMessage::SetSiteCode]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:661">
    <![LOG[CFSPStateMessage::SendMessageToFSP]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:712">
    <![LOG[CFSPStateMessage::GetClientIdentityInfo]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1575">
    <![LOG[CFSPStateMessage::GetMACAddress]LOG]!><time="12:34:41.304-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1503">
    <![LOG[CFSPStateMessage::SetStateDetails]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:567">
    <![LOG[CFSPStateMessage::CreateMsg]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1026">
    <![LOG[CFSPStateMessage::GenerateHeader]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:776">
    <![LOG[CFSPStateMessage::GetMACAddress]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1503">
    <![LOG[CFSPStateMessage::GenerateBody]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:934">
    <![LOG[CFSPStateMessage::SendMsg]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1085">
    <![LOG[CFSPStateMessage::InitWinHttp]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1134">
    <![LOG[CFSPWinHttp::LoadWinHttpLib]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:183">
    <![LOG[CFSPStateMessage::_SendMsg]LOG]!><time="12:34:41.428-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:1186">
    <![LOG[State message with TopicType 800 and TopicId {E9271D91-0631-44CE-955F-273AF68F3A35} has been sent to the FSP]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:752">
    <![LOG[CFSPStateMessage::~CFSPStateMessage]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:321">
    <![LOG[InstallFromManifest(setupManifest, bClientInstallerRequiredReboot ), HRESULT=8024800c (e:\qfe\nts\sms\setup\ccmsetup\ccmsetup.cpp,2290)]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:2290">
    <![LOG[Run(), HRESULT=8024800c (e:\qfe\nts\sms\setup\ccmsetup\ccmsetup.cpp,2549)]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:2549">
    <![LOG[RunStandalone(), HRESULT=8024800c (e:\qfe\nts\sms\setup\ccmsetup\ccmsetup.cpp,879)]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="0" thread="2544" file="ccmsetup.cpp:879">
    <![LOG[CFSPStateMessage::CFSPStateMessage]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:272">
    <![LOG[CFSPStateMessage::~CFSPStateMessage]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="FSPStateMessage" context="" type="1" thread="2544" file="fsputillib.cpp:321">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\ccmsetup.cab.download]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\ccmsetup.xml]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\vcredist_x86.exe.download]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\vc50727_x86.exe.download]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\MicrosoftPolicyPlatformSetup.msi.download]LOG]!><time="12:34:41.444-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\WindowsFirewallConfigurationProvider.msi.download]LOG]!><time="12:34:41.460-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\dotNetFx40_Client_x86_x64.exe.download]LOG]!><time="12:34:41.460-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\SCEPInstall.exe.download]LOG]!><time="12:34:41.460-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[Deleted file C:\WINDOWS\ccmsetup\client.msi.download]LOG]!><time="12:34:41.460-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:9497">
    <![LOG[CcmSetup failed with error code 0x8024800c]LOG]!><time="12:34:41.460-120" date="10-19-2015" component="ccmsetup" context="" type="1" thread="2544" file="ccmsetup.cpp:10883">

    Dienstag, 20. Oktober 2015 05:21

Antworten

  • Ich konnte das Problem lösen. Ich habe ein neues Image erstellt und dort dann direkt alle NetFramework Komponenten und Updates eingespielt. Danach funktionierte auch die Installation des SCCM Client ohne Problem.
    • Als Antwort markiert MarcelMik Sonntag, 8. November 2015 11:13
    Sonntag, 8. November 2015 11:13

Alle Antworten

  • 0x8024800c = The data store section could not be locked within the allotted time. Source: Windows Update Agent

    Was steht denn im client.msi.log? Suche mal nach Return Value 3. Das Problem sollte direkt über dem ersten Auftreten.


    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 20. Oktober 2015 06:06
    Beantworter
  • Habe den Log gesucht aber leider nicht gefunden. Der Pfad sollte ja eigentlich C:\Windows\System32\ccmsetup sein. Diesen Ordner gibt es dort nicht. Direkt unter Windows habe ich einen Ordner ccmsetup und darunter auch einen logs Ordner. Darin befinden sich aber lediglich der ccmsetup, dism, dotNetFx4_Client_Setup.log und MicrosoftPolicyPlatformSetup.log

    Kein clientmsi.log zu finden...

    Dienstag, 20. Oktober 2015 06:14
  • Dann steht der Fehler irgendwo im ccmsetup.log, ist in dem Auszug oben aber nicht zu sehen. 

    Torsten Meringer | http://www.mssccmfaq.de

    Dienstag, 20. Oktober 2015 07:21
    Beantworter
  • Hier mal noch ein paar Auszüge aus dem LOG

    Den Return Code habe ich leider nicht gefunden. Auf was weißt so ein Fehlerbild den im allgemeinen hin? Was kann man da tun? Gibt es vielleicht ein "Allheilmittel" :-)

    Dienstag, 20. Oktober 2015 08:10
  • Die Installation des .Net Frameworks schlägt fehl. Logfile dazu (siehe Screenshot): dotNetFx4_Client_Setup.log. "Allheilmittel" ist einfach, das Log zu untersuchen. Steht alles im Klartext drin. 

    Torsten Meringer | http://www.mssccmfaq.de

    • Als Antwort vorgeschlagen Simon Dettling Donnerstag, 22. Oktober 2015 19:27
    • Nicht als Antwort vorgeschlagen MarcelMik Freitag, 23. Oktober 2015 05:46
    Dienstag, 20. Oktober 2015 08:57
    Beantworter
  • Ich habe jetzt den LOG mehrfach durch und dabei taucht immer wieder der Fehler auf:

    (C:\Users\Robin\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\Windows6.1-KB958488-v6001-x64.msu) failed with 0x240006 - (null). Exe Log File: CBS.log Exe (A:\219fd0e0b52d87724de6\SetupUtility.exe) succeeded. Exe Log File: dd_SetupUtility.txt MSI (C:\Users\Robin\AppData\Local\Temp\Microsoft .NET Framework 4 Setup_4.0.30319\netfx_Core_x64.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20110811_153252010-MSI_netfx_Core_x64.msi.txt Final Result: Installation failed with error code: (0x80070643), "Onherstelbare fout bij installatie. " (Elapsed time: 0 00:00:52).

    Er kann also ein Update nicht ausführen was benötigt wird um die net Framework Installation abzuschließen. Ich habe diese Update nun per DISM direkt in das Image eingebunden -> Keine Änderung.

    Danach habe ich in Foren gelesen das der Fehler auch mit fehlenden Berechtigungen im IIS stehen kann. Genauer gesagt muss auf der SMS_PKG Site die Anonymous Authentifizierung aktiviert sein. Auch das habe ich nachgezogen. Aber auch das brachte keine Abhilfe.

    So langsam werden die Möglichkeiten zur Lösung eng :-)

    Freitag, 23. Oktober 2015 05:52
  • Eine lokale msi-Installation hat mit Sicherheit nicht sehr viel mit Permissions im IIS zu tun. Du hast doch auch noch div. Logfiles erwähnt (dd_SetupUtility.txt, Microsoft .NET Framework 4 Setup_20110811_153252010-MSI_netfx_Core_x64.msi.txt). Was steht darin? Was passiert, wenn Du die Installation händisch startest?

    Torsten Meringer | http://www.mssccmfaq.de

    Freitag, 23. Oktober 2015 06:54
    Beantworter
  • Ich habe jetzt nochmal händisch ein weiteres SCCM Client Package erstellt. Das habe ich verteilt und auch im Task zugewiesen. Jetzt wird der SCCM Client auch installiert. Diesen Schritt habe ich also schon geschafft. Leider geht es dann aber wieder nicht weiter. Es werden keine Anwendungen installiert
    Freitag, 23. Oktober 2015 07:12
  • Ich konnte das Problem lösen. Ich habe ein neues Image erstellt und dort dann direkt alle NetFramework Komponenten und Updates eingespielt. Danach funktionierte auch die Installation des SCCM Client ohne Problem.
    • Als Antwort markiert MarcelMik Sonntag, 8. November 2015 11:13
    Sonntag, 8. November 2015 11:13