none
Datenbank wiederherstellen / Voreinstellung "Alle Dateien in Ordner verschieben" RRS feed

  • Frage

  • Da wir kein Upgrade von 2008 R2 Business Edition auf 2016 Standard Edition machen konnten, wurden die Datenbanken am SQL-Server 2008 gesichert und sollen nun unter 2016 zurückgesichert werden.

    Nun hatte ich vergessen beim Setup das Verzeichnis für die Protokolldateien anzupassen, sodass beim Wiederherstellen immer ein unerwünschter Pfad vorgeschlagen wird.

    Es lässt sich leider auch nicht unter den Servereigenschaften / Datenbankeinstellungen anpassen. Jeder Änderung wird nach dem Speichern ohne Fehlermeldung verworfen. Nach einer Anpassung steht wieder der Pfad gem. Seutp dort.

    Gibt es eine Idee, warum dies so ist?

    Viele Grüße
    Thorsten Melzer

    Freitag, 22. September 2017 06:49

Antworten

  • Nach der Änderung dieser Pfade muss der SQL Server Dienst neu gestartet werden.

    Hintergrund ist, dass dieser Wert in der registry steht - und die liest der SQL Server Dienst nur beim Start aus

    Ansonsten sollte man sich einfach an die WITH MOVE TO-Klausel beim Restore gewöhnen, die zum Standard gehört


    Andreas Wolter (Blog | Twitter)
    MCSM: Microsoft Certified Solutions Master Data Platform/SQL Server 2012
    MCM SQL Server 2008
    MVP Data Platform MCSE Data Platform
    MCSM Charter Member, MCITP Charter Member etc.

    www.SarpedonQualityLab.com
    | www.andreas-wolter.com


    Freitag, 22. September 2017 08:16
  • Das Skript zu der Änderung kann man sich im Hintergrund erzeugen lassen und dann wird das mit der Registry auch schnell deutlich!

    USE [master]
    GO
    EXEC xp_instance_regwrite N'HKEY_LOCAL_MACHINE', N'Software\Microsoft\MSSQLServer\MSSQLServer', N'DefaultLog', REG_SZ, N'D:\MSSQL14.MSSQLSERVER\MSSQL\DATA'
    GO
    

    WITH MOVE ist definitiv für alle Lebenslagen die sicherste Variante!


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    • Als Antwort markiert BORS IT Dienstag, 26. September 2017 08:22
    Freitag, 22. September 2017 11:24
    Beantworter
  • Hallo Thorsten,

    das ist ein Fehler im SSMS 17.2. In der nächsten Version 17.3 ist dies gefixed, allerdings ist die noch nicht öffentlich verfügbar.


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    • Als Antwort markiert BORS IT Dienstag, 26. September 2017 08:22
    Freitag, 22. September 2017 13:06
    Beantworter

Alle Antworten

  • Hallo Thorsten,

    eine Datenbank Datei kann nicht im laufenden Betreib verschoben werden. 

    Hier ist eine Anleitung von Microsoft wie man dies sicher durchführt

    https://docs.microsoft.com/de-de/sql/relational-databases/databases/move-user-databases


    Benjamin Hoch
    MCSE: Data Platform & Data Management and Analytics
    MCSA: SQL Server 2012/2014 & 2016 DB Administration
    MCSA: Windows Server 2012

    Freitag, 22. September 2017 07:33
  • Da wäre dann doch der direkte Link besser, da es ja nicht um ein Verschieben sondern um eine Übertragung an einen neuen Server handelt:
    https://docs.microsoft.com/de-de/sql/relational-databases/backup-restore/back-up-and-restore-of-sql-server-databases

    Es scheint allerdings so zu sein, dass man bei der Sicherung der Datenbank dies alles bereits berücksichtigen muss.

    Freitag, 22. September 2017 07:36
  • Nach der Änderung dieser Pfade muss der SQL Server Dienst neu gestartet werden.

    Hintergrund ist, dass dieser Wert in der registry steht - und die liest der SQL Server Dienst nur beim Start aus

    Ansonsten sollte man sich einfach an die WITH MOVE TO-Klausel beim Restore gewöhnen, die zum Standard gehört


    Andreas Wolter (Blog | Twitter)
    MCSM: Microsoft Certified Solutions Master Data Platform/SQL Server 2012
    MCM SQL Server 2008
    MVP Data Platform MCSE Data Platform
    MCSM Charter Member, MCITP Charter Member etc.

    www.SarpedonQualityLab.com
    | www.andreas-wolter.com


    Freitag, 22. September 2017 08:16
  • Das Skript zu der Änderung kann man sich im Hintergrund erzeugen lassen und dann wird das mit der Registry auch schnell deutlich!

    USE [master]
    GO
    EXEC xp_instance_regwrite N'HKEY_LOCAL_MACHINE', N'Software\Microsoft\MSSQLServer\MSSQLServer', N'DefaultLog', REG_SZ, N'D:\MSSQL14.MSSQLSERVER\MSSQL\DATA'
    GO
    

    WITH MOVE ist definitiv für alle Lebenslagen die sicherste Variante!


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    • Als Antwort markiert BORS IT Dienstag, 26. September 2017 08:22
    Freitag, 22. September 2017 11:24
    Beantworter
  • Hallo zusammen,

    vielen Dank für die schnelle und gute Hilfe. Nach dem Neustart des SQL-Server-Dienstes ist nun die Datenbankeinstellungen gespeichert und auch verfügbar.

    Da ich hierzu immer den Dialog im SQL Managment Studio für das RESTORE verwende und die Option "Alle Dateien in Ordner verschieben" wähle wird im Skript "RESTORE DATABASE" immer die Option "WITH MOVE TO" verwendet.

    Nur war ich in dem Dialog verwundert, dass immer der ungewünschte Pfad für die Protokolldatei vorgeschlagen wurde.

    Eventuell hat jemand noch eine Idee zu der folgenden Problematik im SQL Management Studio V17.2:
    Unter Datenbankeinstellungen ist für die Protokolldatei"P:\Microsoft SQL Server\MSSQL13.MESO\MSSQL\DATA\" angegeben. Das wird auch im Dialog "Datenbank wiederherstellen" / Dateien / Alle Dateien in Ordner verschieben angezeigt, allerdings hier ohne den abschließenden Backslash. Das hat zur Folge, das "P:\Microsoft SQL Server\MSSQL13.MESO\MSSQL" vorgeschlagen wird:

    Sicher ein Problem im SQL Management Studio oder habe ich etwas verkehrt konfiguriert?

    Viele Grüße
    Thorsten

    Freitag, 22. September 2017 12:40
  • Hallo Thorsten,

    das ist ein Fehler im SSMS 17.2. In der nächsten Version 17.3 ist dies gefixed, allerdings ist die noch nicht öffentlich verfügbar.


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    • Als Antwort markiert BORS IT Dienstag, 26. September 2017 08:22
    Freitag, 22. September 2017 13:06
    Beantworter
  • Hallo Christoph,

    besten Dank für das Feedback. Nun sin auch all meine Frage geklärt worden.

    Viele Grüße Thorsten

    Montag, 25. September 2017 08:58
  • Hallo Thorsten,

    dann markiere doch bitte noch die für Dich hilfreichen Antworten, damit der Thread insgesamt als beantwortet dargestellt wird.


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Montag, 25. September 2017 12:37
    Beantworter
  • Hallo Thorsten,

    seit heute ist die Version 17.3 öffentlich verfügbar. Aktuell zeigt die deutsche Seite aber noch auf die alte Version, so dass Du den Download über die englische Seite starten musst. Aber auch hier bekommst Du (automatisch) die deutsche Version.

    SSMS english page


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Dienstag, 10. Oktober 2017 06:09
    Beantworter