none
Computer Association funktioniert nicht richtig RRS feed

  • Frage

  • Hallo!

    Habe da wieder einmal ein Problem, bei dem ich nicht weiter komme. Diesmal handelt es sich um die Computer Association.
    Folgendes Szenario habe ich probiert:

    Ich habe mir eine MDT Task Sequence erstellt, die zu Computertausch verwendet werden kann. Super Sache übrigens!
    Da passiert ein Request State Store und die Daten werden gesichert. Soweit funktioniert das wunderbar. Im Knoten
    Computer Association wird eine In-Place Association angelegt.

    Computer Association between N322936 and N322936
    Migration Date:
    State Delete On:
    Date State Saved: 16.07.2010 11:57:11
    State Location: \\SERVER01.DOMAIN.LOCAL\SMPSTOREe_DF510DCA$\8D1EA942EF45D2074C5A5E0C41F1C24C91C1F9165CFD9E36FFAE5A454FA2E254

    Migration Type: In-place

    In der MigrationStatus.xml steht diese Zeile:

    <migrationstatus Version="1.0" LastStoreCreationTime="2010-07-16T09:55:47Z" UseNAA="false" associationcounter="1" SourceClient="GUID:1c4448b7-221c-4f14-8aef-a6165f761b02" MigrationID="87E0CB4A-689A-45EE-BE55-096A49A20ABC" capturestatus="succeeded" LastCaptureTime="2010-07-16T09:57:11Z"><associationlist RestoreClientCount="1"><RestoreClient RestoreStatus="false">GUID:1c4448b7-221c-4f14-8aef-a6165f761b02</RestoreClient></associationlist></migrationstatus>

    Soweit so gut. Jetzt möchte ich aber, dass die Benutzerdaten auf einen anderen Rechner migriert werden und lege aus diesem Grund eine
    weiter Computer Association an:

    Computer Association between N322936 and N32300
    Migration Date:
    State Delete On:
    Date State Saved: 16.07.2010 11:57:11
    State Location: \\SERVER01.DOMAIN.LOCAL\SMPSTOREe_DF510DCA$\8D1EA942EF45D2074C5A5E0C41F1C24C91C1F9165CFD9E36FFAE5A454FA2E254

    Migration Type: Side-by-side

    Nur wenn ich den Rechner aufsetze, kann er den State Store nicht anfordern und bricht ab bzw. habe ich mir eine Task Sequence zum Datenwiederherstellen gemacht.  Auch der Inhalt der xml-Datei ändert sich nicht?! Sollte sie das? Z.B.  associationcounter="2" und einen weiteren RestoreClientCount?

    Ich habe auch schon probiert im Anschluss die In-Place Association zu löschen. Das hilft aber auch nicht. Die xml-Datei ändert sich nicht und der neue Client kann den State Store nicht anfordern.

    Was mache ich falsch? Vielen Dank im Voraus! Ach ja, hier ein Auszug aus der SMSTS.LOG:

    Successfully parsed SMP response. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Adding \\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$ to list  OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Trying to connect to \\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$ using machine account. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Connection request for "\\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$" OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    No credentials available for connecting to "\\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$". See whether the share has already been connected. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Connecting to "\\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$" OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Successfully connected to "\\SERVER01.DOMAIN.LOCALL\SMPSTOREe_DF510DCA$" OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
       Setting SSL = 0. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
       Setting CRLUse = 0. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Sending SMP request to SERVER01.DOMAIN.LOCAL:80. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    CLibSMSMessageWinHttpTransport::Send: URL: SERVER01.DOMAIN.LOCAL:80  CCM_POST /SMSSMP/.sms_smp?op=restore OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Error. Status code 500 returned OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Received 3839 byte response. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Found certificate context of the smp server OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Successfully decoded 208 byte response. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    SMP request to "SERVER01.DOMAIN.LOCAL" failed with error: E_SMPERROR_RESTORING_CLIENTID_NOT_FOUND
    <<<<<EDIT: TROTZ ANGELEGTER ASSOCIATION! >>>>> (207) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    0, HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\osdsmpclient\smpclient.cpp,2218) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Request to SMP 'SERVER01.DOMAIN.LOCAL' failed with error (Code 0x80004005). Trying next SMP. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    FALSE, HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\osdsmpclient\smpclient.cpp,1698) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Failed to find an SMP that can serve request after trying 6 attempts. OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    pClientRequestToSMP->Execute(migInfoFromMP.saSMPs), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\osdsmpclient\smpclient.cpp,2854) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    ExecuteRestoreRequestToSMP failed (0x80004005). OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    ExecuteRestoreRequestToSMP(migInfoFromMP), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\osdsmpclient\smpclient.cpp,2912) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    ExecuteRestoreRequest failed (0x80004005). OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    ExecuteRestoreRequest(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\osdsmpclient\main.cpp,80) OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    OSDSMPClient finished: 0x00004005 OSDSMPClient 16.07.2010 11:49:10 2076 (0x081C)
    Process completed with exit code 16389 TSManager 16.07.2010 11:49:10 1928 (0x0788)
    !--------------------------------------------------------------------------------------------! TSManager 16.07.2010 11:49:10 1928 (0x0788)
    Failed to run the action: Request User State Storage.
    Unknown error (Error: 00004005; Source: Unknown) TSManager 16.07.2010 11:49:10 1928 (0x0788)

    EDIT: Was ich vergessen habe: Wenn ich die Association vor der Status Sicherung anlege funktioniert das schon mit Side-by-side. Nur eine Nachträgliche Änderung funktioniert nicht!


    Dietmar

    Freitag, 16. Juli 2010 10:41

Antworten

  • die Association vor der Status Sicherung anlege funktioniert das schon mit Side-by-side. Nur eine Nachträgliche Änderung funktioniert nicht!

    Das könnte "by design" sein: http://technet.microsoft.com/en-us/library/bb633286.aspx: "You must create a computer association before you can capture the user state from a reference computer"

    • Als Antwort markiert Dietmar H. _ Freitag, 16. Juli 2010 11:37
    Freitag, 16. Juli 2010 11:06
    Beantworter
  • Ein Bisschen aushelfen kann man sich schon, habe ich gerade gesehen. Auch wenn es die In-Place Association schon gibt. Einfach die neue Side-by-side Association erstellen und in der MigrationStatus.xml

    <migrationstatus Version="1.0" LastStoreCreationTime="2010-07-16T09:55:47Z" UseNAA="false" associationcounter="1" SourceClient="GUID:1c4448b7-221c-4f14-8aef-a6165f761b02" MigrationID="87E0CB4A-689A-45EE-BE55-096A49A20ABC" capturestatus="succeeded" LastCaptureTime="2010-07-16T09:57:11Z"><associationlist RestoreClientCount="1"><RestoreClient RestoreStatus="false">GUID:AUF-DIE-NEUE-GUID-ABÄNDERN</RestoreClient></associationlist></migrationstatus>

    die Ziel-GUID abändern. Speichern und Daten wiederherstellen. Und da ist MS nix eingefallen, wie man das in die Console einbauen hätte können? Z.B. im Kontextmenü der In-Place-Association den Punkt Ziel ändern, das diese xml-Datei ändert und den Migration Type von In-Place auf Side-by-side umdreht?

    Mann, das muss ich gleich als Vorschlag für vNext auf connect posten!


    Dietmar
    • Als Antwort markiert Dietmar H. _ Freitag, 16. Juli 2010 12:01
    Freitag, 16. Juli 2010 12:00

Alle Antworten

  • die Association vor der Status Sicherung anlege funktioniert das schon mit Side-by-side. Nur eine Nachträgliche Änderung funktioniert nicht!

    Das könnte "by design" sein: http://technet.microsoft.com/en-us/library/bb633286.aspx: "You must create a computer association before you can capture the user state from a reference computer"

    • Als Antwort markiert Dietmar H. _ Freitag, 16. Juli 2010 11:37
    Freitag, 16. Juli 2010 11:06
    Beantworter
  • Ich hab's befürchtet. Das ist nicht gut! Dass heißt, unsere Administratoren in den Abteilungen müssen immer schon wissen, welcher der Ziel-Computer sein wird inkl. MAC-Adresse. Oder sie setzen den neuen Rechner auf, bevor sie die 'Computer replace'-Task Sequence ausführen und geben uns dann Bescheid. So kann's gehen.

    Wieder einmal vielen Dank für deine Hilfe und gratulation zur Verlängerung des MVP!!! Du hast es dir wirklich verdient!!!
    Dietmar
    Freitag, 16. Juli 2010 11:37
  • Vielen Dank!
    Freitag, 16. Juli 2010 11:41
    Beantworter
  • Ein Bisschen aushelfen kann man sich schon, habe ich gerade gesehen. Auch wenn es die In-Place Association schon gibt. Einfach die neue Side-by-side Association erstellen und in der MigrationStatus.xml

    <migrationstatus Version="1.0" LastStoreCreationTime="2010-07-16T09:55:47Z" UseNAA="false" associationcounter="1" SourceClient="GUID:1c4448b7-221c-4f14-8aef-a6165f761b02" MigrationID="87E0CB4A-689A-45EE-BE55-096A49A20ABC" capturestatus="succeeded" LastCaptureTime="2010-07-16T09:57:11Z"><associationlist RestoreClientCount="1"><RestoreClient RestoreStatus="false">GUID:AUF-DIE-NEUE-GUID-ABÄNDERN</RestoreClient></associationlist></migrationstatus>

    die Ziel-GUID abändern. Speichern und Daten wiederherstellen. Und da ist MS nix eingefallen, wie man das in die Console einbauen hätte können? Z.B. im Kontextmenü der In-Place-Association den Punkt Ziel ändern, das diese xml-Datei ändert und den Migration Type von In-Place auf Side-by-side umdreht?

    Mann, das muss ich gleich als Vorschlag für vNext auf connect posten!


    Dietmar
    • Als Antwort markiert Dietmar H. _ Freitag, 16. Juli 2010 12:01
    Freitag, 16. Juli 2010 12:00