none
Outlook Kalender mit eingeschränkter Funktionalität RRS feed

  • Frage

  • Hallo zusammen,

    freut mich das es das TechNet Forum jetzt auch in dieser Sprache gibt :)

    Das Grundproblem ist folgendes:

    Es kommen ab und an Mitarbeiter mit dem Problem zu mir, dass Sie in Outlook 2003 z.B. keine Termine erstellen, bearbeiten oder auf Einladungen reagieren können weil einfach nichts passiert wenn man die Aktion durchführt. Nach einem Neustart von Outlook funktioniert meißt wieder alles ohne Probleme.
    Das Problem tritt nur sporadisch und auch nicht immer bei der gleichen Person auf.

    Zur Umgebung:

    Die Arbeitsplätze (fast alle unterschiedliche Hardware) sind mit Windows XP SP3 und Office 2003 Prof. ausgestattet. Bei Outlook 2003 ist der Cache-Modus aktiviert. Es sind auch noch zwei Outlook 2007 Versionen im Einsatz, da wurde bisher jedoch kein Fehler gemeldet. In den Ereignissprotokollen ist auch nichts zu finden was auf ein solches Problem hindeutet.
    Bei dem Mailserver handelt es sich um einen Exchange Server 2007 SP1 mit dem aktuellsten Update Rollup 7 (ich meine das wäre das letzte gewesen :P).

    Ich hatte schon einmal gelesen, dass das starten von Outlook mit "/cleanreminders" Abhilfe schaffen soll, dem ist aber auch nur temporär so...

    Hat jemand einen Rat wie ich diesem nervigen Problem Herr werden kann?

    Wenn Ihr noch weitere Fragen habt, steh ich gerne Rede und Antwort!


    Gruß,
    mauii
    Donnerstag, 26. März 2009 15:13

Antworten

  • Zunächst sollte man, wenn ein solches Szenario vorliegt, im Task-Manager in der Prozessliste nachschauen, ob mehrere Instanzen des Prozesses OUTLOOK.EXE laufen. Wenn dort nur ein Prozess dieses Namens zu finden ist (die alphabetische Sortierung der Prozessnamensspalte zu verwenden verringert die Gefahr, einen Prozess gleichen Namens zu übersehen), ist zumindest das in Ordnung.

    Ein Outlook-Start mit dem Outlook-Zeilenschalter /noextensions könnte ansonsten helfen, eventuell querschlagende Add-ins zur Ruhe zu bringen und zu schauen, ob das Problem dann auch noch auftritt. Natürlich könnte man hierzu bei Bedarf auch iterativ vorgehen und die Erweiterungen schrittweise aktivieren oder deaktivieren.
     
    Ein weiterer Schritt bei der Problemanalyse könnte etwa das Einschalten des Kalender-Loggings von Outlook auf den Clientmaschinen sein. Wie das geht, steht hier: http://support.microsoft.com/default.aspx?scid=kb;EN-US;841615. Da die Logdatei verschlüsselt ist, müsstest Du Dich zur genaueren Analyse dann allerdings direkt an den Microsoft-Support wenden.
    Donnerstag, 26. März 2009 17:40
  • Hallo Mauii,

    schau dir mal bitte den folgenden KB-Artikel an:

    Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality
    http://support.microsoft.com/kb/837391

    Bitte installliere Wins und sorge dafür das der bei den Clients eingetragen wird. Sind denn alle 3 beim Client eingetragenen DNS-Server AD-DNS-Server oder ist da was externes dabei? Der externe müsste dann auch raus.

    hth
    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.org/blogs/wstein
    Freitag, 27. März 2009 10:18
  • Hallo,

    ergänzend zu den wertvollen Hinweisen, die im Verlauf des Threads gegeben wurden, eine weitere Anmerkung:
    Den externen DNS kann ich auch entfernen aber ist das denn so wichtig? Natürlich kann der keine internen Namen auflösen aber führt das zwangsläufig zu einem Problem?
    Die DNS Server werden immer in der Reihenfolge von "oben nach unten" abgearbeitet. Ist der erste DNS Server (oder der zweite, ...) erreichbar, werden die weiteren DNS Server nicht mehr befragt. Sobald eine Anwort vom ersten DNS Server kommt, auch wenn Sie lautet "keinen Eintrag gefunden", so ist das eine Antwort an den Client und der DNS Client wird nicht versuchen, die anderen DNS Server erneut zu befragen.

    Von daher wird der externe DNS Server nur genutzt, wenn beide internen DNS Server nicht verfügbar wäre. Dann hättest Du jedoch Probleme in Deiner AD-Umgebung, da hier ohne die internen DNS Einträge der AD nichts mehr läuft.

    Zu Deinem "Urspungsproblem": Tritt das Problem bei allen Benutzern auf oder nur bei bestimmten, sind immer die selben Clients betroffen oder tritt das Problem sporadisch auf verschiedenen Systemen auf?

    Hast Du die Möglichkeit, mit einer anderen Outlook Version zu testen, ob das Problem weiterhin existiert?

    Ein Netzwerktrace könnte unter Umständen ebenfalls Aufschlüsse geben, ob vom Client aus Anfragen ins Netz gehen, die nicht korrekt beantwortet werden (können). Es empfiehlt sich hierfür der NetMon 3.2, da dieser die Applikationen mit aufführt, die die Anfragen gesendet haben. Dann kannst Du neben dem "Hintergrundrauschen", welches oftmals auch sehr interessant ist, direkt den Outlook Traffic filtern: http://www.microsoft.com/downloads/details.aspx?familyid=f4db40af-1e08-4a21-a26b-ec2f4dc4190d&displaylang=en

    Viele Grüße
    Fabian

    http://blogs.technet.com/deds
    Samstag, 28. März 2009 08:16
  • Hallo Mauii,

    hast du denn schon mal auf dem Exchange-SErver geschaut ob es dort Irgendwelche Einträge im Eventlog gibt die auf ein Kalenderproblem hindeuten? Kannst du dort evtl. mal prüfen ob die Datenbank konsistent ist (sieht man nach der Sicherung wenn alle TA-Logs gelöscht werden). Ansonsten würde mir noch einfallen den Store mal per isinteg zu prüfen.
    Vielleicht kannst du auch mal ipconfig /all von Exchange und einem Client posten, oft liegt es an falschen Einstellungen. Hast du Wins im Einsatz?

    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.org/blogs/wstein
    Freitag, 27. März 2009 07:10

Alle Antworten

  • Zunächst sollte man, wenn ein solches Szenario vorliegt, im Task-Manager in der Prozessliste nachschauen, ob mehrere Instanzen des Prozesses OUTLOOK.EXE laufen. Wenn dort nur ein Prozess dieses Namens zu finden ist (die alphabetische Sortierung der Prozessnamensspalte zu verwenden verringert die Gefahr, einen Prozess gleichen Namens zu übersehen), ist zumindest das in Ordnung.

    Ein Outlook-Start mit dem Outlook-Zeilenschalter /noextensions könnte ansonsten helfen, eventuell querschlagende Add-ins zur Ruhe zu bringen und zu schauen, ob das Problem dann auch noch auftritt. Natürlich könnte man hierzu bei Bedarf auch iterativ vorgehen und die Erweiterungen schrittweise aktivieren oder deaktivieren.
     
    Ein weiterer Schritt bei der Problemanalyse könnte etwa das Einschalten des Kalender-Loggings von Outlook auf den Clientmaschinen sein. Wie das geht, steht hier: http://support.microsoft.com/default.aspx?scid=kb;EN-US;841615. Da die Logdatei verschlüsselt ist, müsstest Du Dich zur genaueren Analyse dann allerdings direkt an den Microsoft-Support wenden.
    Donnerstag, 26. März 2009 17:40
  • Hallo Mauii,

    hast du denn schon mal auf dem Exchange-SErver geschaut ob es dort Irgendwelche Einträge im Eventlog gibt die auf ein Kalenderproblem hindeuten? Kannst du dort evtl. mal prüfen ob die Datenbank konsistent ist (sieht man nach der Sicherung wenn alle TA-Logs gelöscht werden). Ansonsten würde mir noch einfallen den Store mal per isinteg zu prüfen.
    Vielleicht kannst du auch mal ipconfig /all von Exchange und einem Client posten, oft liegt es an falschen Einstellungen. Hast du Wins im Einsatz?

    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.org/blogs/wstein
    Freitag, 27. März 2009 07:10
  • Danke schon einmal für eure Antworten!

    @Forenteam:

    - es ist immer nur eine Instanz der Outlook.exe vorhanden
    - mit den Add-ins werde ich bei Gelegenheit mal testen, muss ich dann aber einzeln machen da dort ein Add-in bei ist was täglich genutzt wird und der Fehler ja leider nur alle x Tage bis x Wochen auftritt...

    @Walter Steinsdorfer:

    - in den Eventlogs des Exchange ist leider auch nichts zu finden was auf das Problem hindeutet
    - die Datenbank scheint kosistent zu sein, es haben sich keine Logs angesammelt, BPA und TA melden auch keine Fehler bzw. Probleme
    - mit isinteg muss ich noch schauen wann ich die Zeit finde um die Datenbank "offline" zu schalten
    - WINS ist nicht im Einsatz

    ipconfig /all vom exchange:


    Windows-IP-Konfiguration

       Hostname  . . . . . . . . . . . . : exchange
       Prim„res DNS-Suffix . . . . . . . : domain.local
       Knotentyp . . . . . . . . . . . . : Hybrid
       IP-Routing aktiviert  . . . . . . : Nein
       WINS-Proxy aktiviert  . . . . . . : Nein
       DNS-Suffixsuchliste . . . . . . . : domain.local

    Ethernet-Adapter LAN-Verbindung 3:

       Verbindungsspezifisches DNS-Suffix:
       Beschreibung. . . . . . . . . . . : Microsoft Virtual Machine Bus Network Adapter
       Physikalische Adresse . . . . . . : 00-15-5D-02-0E-0A
       DHCP aktiviert. . . . . . . . . . : Nein
       Autokonfiguration aktiviert . . . : Ja
       IPv4-Adresse  . . . . . . . . . . : 192.168.2.10(Bevorzugt)
       Subnetzmaske  . . . . . . . . . . : 255.255.255.0
       Standardgateway . . . . . . . . . : 192.168.2.252
       DNS-Server  . . . . . . . . . . . : 192.168.2.5
                                           192.168.2.22
       NetBIOS �ber TCP/IP . . . . . . . : Aktiviert

    Tunneladapter LAN-Verbindung* 8:

       Medienstatus. . . . . . . . . . . : Medium getrennt
       Verbindungsspezifisches DNS-Suffix:
       Beschreibung. . . . . . . . . . . : isatap.{0BE2EB85-1CCC-46D6-9CDC-0F0FD1CEF3BC}
       Physikalische Adresse . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP aktiviert. . . . . . . . . . : Nein
       Autokonfiguration aktiviert . . . : Ja


    ipconfig /all von einem Client:

    Windows-IP-Konfiguration

            Hostname. . . . . . . . . . . . . : pc37
            Primäres DNS-Suffix . . . . . . . : domain.local
            Knotentyp . . . . . . . . . . . . : Unbekannt
            IP-Routing aktiviert. . . . . . . : Nein
            WINS-Proxy aktiviert. . . . . . . : Nein
            DNS-Suffixsuchliste . . . . . . . : domain.local
                                                      domain.local

    Ethernetadapter VMware Network Adapter VMnet8:

            Verbindungsspezifisches DNS-Suffix:
            Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet8
            Physikalische Adresse . . . . . . : 00-50-56-C0-00-08
            DHCP aktiviert. . . . . . . . . . : Nein
            IP-Adresse. . . . . . . . . . . . : 192.168.43.1
            Subnetzmaske. . . . . . . . . . . : 255.255.255.0
            Standardgateway . . . . . . . . . :

    Ethernetadapter VMware Network Adapter VMnet1:

            Verbindungsspezifisches DNS-Suffix:
            Beschreibung. . . . . . . . . . . : VMware Virtual Ethernet Adapter for VMnet1
            Physikalische Adresse . . . . . . : 00-50-56-C0-00-01
            DHCP aktiviert. . . . . . . . . . : Nein
            IP-Adresse. . . . . . . . . . . . : 192.168.222.1
            Subnetzmaske. . . . . . . . . . . : 255.255.255.0
            Standardgateway . . . . . . . . . :

    Ethernetadapter LAN-Verbindung:

            Verbindungsspezifisches DNS-Suffix: domain.local
            Beschreibung. . . . . . . . . . . : Realtek RTL8168C(P)/8111C(P) PCI-E Gigabit Ethernet NIC
            Physikalische Adresse . . . . . . : 00-1E-8C-49-E2-5D
            DHCP aktiviert. . . . . . . . . . : Ja
            Autokonfiguration aktiviert . . . : Ja
            IP-Adresse. . . . . . . . . . . . : 192.168.2.178
            Subnetzmaske. . . . . . . . . . . : 255.255.255.0
            Standardgateway . . . . . . . . . : 192.168.2.252
            DHCP-Server . . . . . . . . . . . : 192.168.2.22
            DNS-Server. . . . . . . . . . . . : 192.168.2.5
                                                192.168.2.22
                                                145.253.2.11
            Lease erhalten. . . . . . . . . . : Dienstag, 24. März 2009 13:24:47
            Lease läuft ab. . . . . . . . . . : Mittwoch, 1. April 2009 13:24:47



    Danke nochmals für eure Hilfe !!

    Freitag, 27. März 2009 08:00
  • Hallo Mauii,

    schau dir mal bitte den folgenden KB-Artikel an:

    Exchange Server 2003 and Exchange 2000 Server require NetBIOS name resolution for full functionality
    http://support.microsoft.com/kb/837391

    Bitte installliere Wins und sorge dafür das der bei den Clients eingetragen wird. Sind denn alle 3 beim Client eingetragenen DNS-Server AD-DNS-Server oder ist da was externes dabei? Der externe müsste dann auch raus.

    hth
    Viele Grüße Walter Steinsdorfer MVP Exchange Server http://msmvps.org/blogs/wstein
    Freitag, 27. März 2009 10:18
  • Benötigt der Exchange 2007 auch noch NetBIOS?

    Werde ich aber Testweise mal alles installieren / konfigurieren.
    Den externen DNS kann ich auch entfernen aber ist das denn so wichtig? Natürlich kann der keine internen Namen auflösen aber führt das zwangsläufig zu einem Problem?
    Freitag, 27. März 2009 11:00
  • Moin,

    Exchange 2007 benötigt "angeblich" keine NetBIOS-Namensauflösung ... aber allgemein treten viele, auch seltsame, Probleme nicht mehr auf, wenn man WINS flächendeckend einsetzt.

    Einen nicht-lokalen DNS-Server solltest du in einer AD-Umgebung niemals bei einem Client eintragen. Zur externen Namensauflösung konfigurierst du auf deinem internen DNS-Server einen Forwarder.

    Es ist zwar nicht wahrscheinlich, dass deine Probleme direkt daran hängen, aber diese Punkte solltest du korrigieren.

    Gruß, Nils

    Nils Kaczenski
    MVP Directory Services
    Hannover, Germany
    Freitag, 27. März 2009 18:55
  • Hallo,

    ergänzend zu den wertvollen Hinweisen, die im Verlauf des Threads gegeben wurden, eine weitere Anmerkung:
    Den externen DNS kann ich auch entfernen aber ist das denn so wichtig? Natürlich kann der keine internen Namen auflösen aber führt das zwangsläufig zu einem Problem?
    Die DNS Server werden immer in der Reihenfolge von "oben nach unten" abgearbeitet. Ist der erste DNS Server (oder der zweite, ...) erreichbar, werden die weiteren DNS Server nicht mehr befragt. Sobald eine Anwort vom ersten DNS Server kommt, auch wenn Sie lautet "keinen Eintrag gefunden", so ist das eine Antwort an den Client und der DNS Client wird nicht versuchen, die anderen DNS Server erneut zu befragen.

    Von daher wird der externe DNS Server nur genutzt, wenn beide internen DNS Server nicht verfügbar wäre. Dann hättest Du jedoch Probleme in Deiner AD-Umgebung, da hier ohne die internen DNS Einträge der AD nichts mehr läuft.

    Zu Deinem "Urspungsproblem": Tritt das Problem bei allen Benutzern auf oder nur bei bestimmten, sind immer die selben Clients betroffen oder tritt das Problem sporadisch auf verschiedenen Systemen auf?

    Hast Du die Möglichkeit, mit einer anderen Outlook Version zu testen, ob das Problem weiterhin existiert?

    Ein Netzwerktrace könnte unter Umständen ebenfalls Aufschlüsse geben, ob vom Client aus Anfragen ins Netz gehen, die nicht korrekt beantwortet werden (können). Es empfiehlt sich hierfür der NetMon 3.2, da dieser die Applikationen mit aufführt, die die Anfragen gesendet haben. Dann kannst Du neben dem "Hintergrundrauschen", welches oftmals auch sehr interessant ist, direkt den Outlook Traffic filtern: http://www.microsoft.com/downloads/details.aspx?familyid=f4db40af-1e08-4a21-a26b-ec2f4dc4190d&displaylang=en

    Viele Grüße
    Fabian

    http://blogs.technet.com/deds
    Samstag, 28. März 2009 08:16
  • Einen WINS Server habe ich am Freitag noch installiert und die DHCP Optionen bzw. die TCP/IP Einstellungen des Exchange Servers dem entsprechend angepasst. Den externen DNS habe ich auch einmal vorsichtshalber rausgenommen.

    @Fabian:

    Das Problem trat bisher bei unterschiedlichen Benutzern und Clients auf jedoch nicht bei allen. Bei Outlook 2007 ist das Problem bisher noch nicht aufgetreten, davon sind bisher aber auch nur zwei Stück im Einsatz.

    Danke nochmals für eure Hilfe und eure Tips! :) Ich werd es mit dem WINS jetzt erstmal laufen lassen und schauen ob in den nächsten Tagen/Wochen sich eine Besserung einstellt. Ansonsten versuch ich dann mal etwas genauer zu schauen, wie zb mit dem NetMon und mich dann hier nochmal melden :)

    mit besten Grüßen
    mauii
    Montag, 30. März 2009 06:35