none
[Exch 2010] Mail abgelehnt ohe Eintrag ins Logfile RRS feed

  • Allgemeine Diskussion

  • Hi Community,

    kann es sein, dass Exchange 2010 eine Mail nicht annimmt und darüber keinerlei Einträge in irgendwelchen Logfiles zu finden ist? Eine Kundin beschwert sich zZ, dass wir Mails angeblich nicht bekommen, die sie aber abgeschickt hat und keine Fehlermeldung diesbzgl. bekommt.

    Ich habe die Send und Receive Logs aktiviert und bekomme zB auch eingehenede Mails von der Domain angezeigt aber die letzte vom 27.02.17:

    prontos-Mac-Pro:~ pronto$ grep wbu.de /Volumes/Protocol*/SmtpReceive/*
    /Volumes/ProtocolLog$/SmtpReceive/RECV20170207-1.LOG:2017-02-07T09:21:04.728Z,UNIVERSE-3\Default UNIVERSE-3,08D449AE2A8E1109,49,192.168.110.2:25,192.168.110.3:8560,<,MAIL FROM:<Wirtschaftsbeirat@senderdomain.de> SIZE=350397 AUTH=<> XSHADOW=0fdae3b2-eef6-444d-ab70-cdb0681bcaa9,
    /Volumes/ProtocolLog$/SmtpReceive/RECV20170209-1.LOG:2017-02-09T16:13:31.816Z,UNIVERSE-3\Default UNIVERSE-3,08D449AE2A8E2F54,49,192.168.110.2:25,192.168.110.3:25730,<,MAIL FROM:<Wirtschaftsbeirat@senderdomain.de> SIZE=324196 AUTH=<> XSHADOW=98669ad7-a227-4deb-a081-6da6647ac7ef,
    /Volumes/ProtocolLog$/SmtpReceive/RECV20170221-1.LOG:2017-02-21T06:49:15.660Z,UNIVERSE-3\Default UNIVERSE-3,08D449AE2A8EA1F1,49,192.168.110.2:25,192.168.110.3:20212,<,MAIL FROM:<CRieck@senderdomain.de> SIZE=1372550 AUTH=<> XSHADOW=80fed925-a7d3-4c4c-9975-cc616119c52a,
    

    Ich kann auch eine Message ID vollständig auflösen, kein Problem. Ich dachte bislang immer, wenn in diesem Logfile nichts aufschlägt, ist auch nie etwas auf unseren Mailservern angekommen. Täusche ich mich da?

    BTW: Wir haben eine DAG aus zwei Mailservern und bei keinem steht was im Logfile. Wir verwenden keinen Smarthost und als Virenscanner ist Trend Micro Scan Mail for Exchange im Einsatz.

    Was kann da schief laufen...?

    Thx & Bye Tom


    Mittwoch, 8. März 2017 10:57

Alle Antworten

  • Am 08.03.2017 um 11:57 schrieb Thomas Pronto Wildgruber:
    Hi,

    kann es sein, dass Exchange 2010 eine Mail nicht annimmt und darüber keinerlei Einträge in irgendwelchen Logfiles zu finden ist? Eine Kundin beschwert sich zZ, dass wir Mails angeblich nicht bekommen, die sie aber abgeschickt hat und keine Fehlermeldung diesbzgl. bekommt.

    Hmm schwer nachzuvollziehen, ich würde das pauschal auch erstmal nur "bedingt glauben" und unter alternative Fakten abheften. ;)
    Kannst du denn von dort testen?

    Ich kann auch eine Message ID vollständig auflösen, kein Problem. Ich dachte bislang immer, wenn in diesem Logfile nichts aufschlägt, ist auch nie etwas auf unseren Mailservern angekommen. Täusche ich mich da?

    Und die DAG nimmt die Mails direkt aus dem Netz an, oder kommt da noch ein Loadbalancer, Smarthost, Firewall davor? Ich hatte schon ähnliche Fälle, da scheiterte dann die TLS Aushandlung, und das sieht man nicht im Receivelog soweit ich mich erinnere.

    Bye
    Norbert

    Mittwoch, 8. März 2017 12:12
  • Servus Norbert,

    >Hmm schwer nachzuvollziehen [...] Kannst du denn von dort testen?

    Nein testen kann ich dort nicht aber ich habe mit denen telefoniert und die vermuten schon auch, dass uU mehrere Empfänger von ihnen keine E-Mails bekommen. Wir hatten nur bislang das deutlichste Feedback abgegeben, weil jemand auf eine E-Mail gewartet hat und dann dort angerufen hat, was los ist...

    Denen ihr Admin ist zZ in den USA, versucht aber von dort schon seit mehreren Tagen das Problem zu lösen, kommt aber auch irgendwie nicht weiter. Also die waren zwar ziemlich angefressen, was aber nicht unbedingt an uns gelegen hat ;-)

    >Und die DAG nimmt die Mails direkt aus dem Netz an, oder kommt da noch ein Loadbalancer, Smarthost, Firewall davor?

    Kein Loadbalancer, kein Smarthost aber eine Firewall (TMG 2010). Der TMG reicht aber Port 25 einfach auf einen der DAG Member durch. Wir verschlüsseln zwar am Exchange, wenn die Gegenstelle es zulässt aber es ist mir nicht bekannt, dass der TMG, obwohl Layer 7, da in den Traffic schaut, dazu bräuchte er zum einen selber ein Zertifikat (hat er nicht) und zum anderen müsste er sich um den Handshake kümmern, was er afaik auch nicht tut (Stünde sonst nicht im Exchange Logfile). 100% sicher bin ich mir damit jetzt zwar nicht aber viel geht mir nicht dazu ab... ;-)

    Der Kunde weiß jetzt, dass es uns nicht egal ist und ich habe ihnen angeboten, dass sich deren Admin mit uns in Verbindung setzen kann, dann können wir das ggf. zusammen herausfinden aber derzeit gehe ich nicht mehr davon aus, dass es unser Problem ist.

    Abschließend aber noch die eigentliche Frage zum Verständnis: Wenn eine E-Mail am Exchange ankommt oder auch abgewiesen wird und nur ein Versuch eines erfolgreichen Verbindungsaufbau stattgefunden hat, sehe ich das im SMTP Receive Logfile? Ich kenne dort zB die Meldung im Logfile "Message rejected by conten filtering" und einige mehr. Es gibt keinen Fehler, der gar nichts im Logfile hinterlässt? Auch der Virenscanner kommt vermutlich erst viel später? Das die Kommunikation natürlich bis zu unserem Mailserver kommt, setze ich natürlich voraus.

    Thx & Bye Tom


    Mittwoch, 8. März 2017 13:22