none
Excel Makro RRS feed

  • Frage

  • hallo zusammen,

    vielleicht kann mir jemand bei einem Makro aushelfen. Ein Kollege hat eine Tabelle mit hunderten Datensätzen und er bräuchte die Zeit von jeder  zweite Zeile in einer eigenen Spalte. Also zb. 07:48 und 16:23 soll dann in Spalte C stehen. Der Aufbau ist exakt immer gleich. Es geht hier um Ein und Ausschaltzeiten.

    02.01.2010 07:44
    02.01.2010 07:48
    02.01.2010 16:19
    02.01.2010 16:23


    Chris

    Donnerstag, 14. Februar 2013 08:51

Antworten

  • Hallo Chris,

    wenn Du C10 = A10 schreibst und die Formel recht simpel ist, kann Excel automatisch ein Format erkennen und übernehmen. Wenn Du jedoch die etwas komplexere Formel mit dem Vergleich und der Bedingung verwendest, kann Excel keine eindeutige Formatierung mehr zuordnen und zeigt das Ergebnis als Zahl an. (Ein Datum bzw. eine Uhrzeit ist intern eine Zahl in Excel).

    Du kannst aber die Formatierung als Datum bzw. Uhrzeit setzen, indem Du die Formatierung einmalig manuell setzt oder die Formatierung der Spalte A nach B kopierst.

    PS: Deine Formel führt einen Vergleich der Stunden durch und setzt voraus, dass gleiche Stunden immer paarweise auftreten und z.B. untereinander keine Dreier-Kombinationen von Stunden (z.B. 07:10, 07:20 und 07:45) vorkommen.

    Gruß :-)


    Microsoft Excel MVP · Excel Formel Übersetzer · www.excel-translator.de





    • Bearbeitet Mourad LouhaMVP Donnerstag, 21. Februar 2013 10:16
    • Als Antwort markiert -- Chris -- Donnerstag, 21. Februar 2013 10:37
    Donnerstag, 21. Februar 2013 10:06

Alle Antworten

  • Hallo Chris,

    möglicherweise hilft auch eine Formellösung, in C1...

    =WENN(REST(ZEILE();2)<>1;ZEIT(STUNDE(A1);MINUTE(A1);SEKUNDE(A1));"")

    Wenn's die geraden Zeilen sind, ansonsten statt 1 dann 0 verwenden. Und es wird davon ausgegangen, dass in Spalte A die Zeiten auch im Datums- und Uhrzeitformat vorhanden sind.

    Gruß


    Microsoft Excel MVP · Excel Formel Übersetzer · www.excel-translator.de

    • Als Antwort vorgeschlagen Alex Pitulice Mittwoch, 20. Februar 2013 11:27
    Samstag, 16. Februar 2013 09:47
  • geht leider nicht

    aber ich habe eine einfachere Lösung gefunden

    =WENN(STUNDE(B10)=STUNDE(B9);A10;)

    leider steht in A10 jetzt noch anstelle des Datums eine Zahl. warum? Wenn ich zb. in C10 =A10 schreibe kommt ja auch ein Datum?


    Chris

    Donnerstag, 21. Februar 2013 09:43
  • Hallo Chris,

    wenn Du C10 = A10 schreibst und die Formel recht simpel ist, kann Excel automatisch ein Format erkennen und übernehmen. Wenn Du jedoch die etwas komplexere Formel mit dem Vergleich und der Bedingung verwendest, kann Excel keine eindeutige Formatierung mehr zuordnen und zeigt das Ergebnis als Zahl an. (Ein Datum bzw. eine Uhrzeit ist intern eine Zahl in Excel).

    Du kannst aber die Formatierung als Datum bzw. Uhrzeit setzen, indem Du die Formatierung einmalig manuell setzt oder die Formatierung der Spalte A nach B kopierst.

    PS: Deine Formel führt einen Vergleich der Stunden durch und setzt voraus, dass gleiche Stunden immer paarweise auftreten und z.B. untereinander keine Dreier-Kombinationen von Stunden (z.B. 07:10, 07:20 und 07:45) vorkommen.

    Gruß :-)


    Microsoft Excel MVP · Excel Formel Übersetzer · www.excel-translator.de





    • Bearbeitet Mourad LouhaMVP Donnerstag, 21. Februar 2013 10:16
    • Als Antwort markiert -- Chris -- Donnerstag, 21. Februar 2013 10:37
    Donnerstag, 21. Februar 2013 10:06
  • stimmt, da es immer ein und ausschaltzeiten sind passt es zu 99% Natürlich könnte es vorkommen, dass um 16:59 eingeschalten wird und um 17:10 aus dann passt meine Logik nicht - aber das wird dann händisch korrigiert!

    danke


    Chris

    Donnerstag, 21. Februar 2013 10:39