none
[Fehler] Application Crash mit dem Fehler 0xc0000005 RRS feed

  • Frage

  • Hallo Zusammen,

    auf zwei Windows Server 2008 R2 starten derzeit keine Programme (meist x86). Wir haben DEP bereits komplett abgeschaltet. (bcdedit /set nx AllwaysOff). 

    Jedoch funktioniert auf einem Server das Office (32 Bit). Das hebt die Einschränkung mit 32bit Programmen auf. Ich beschäftige mich schon seit einigen Stunden mit dem Thema...

    Das Thema http://social.technet.microsoft.com/Forums/de-DE/office_14de/thread/065c825f-0a9f-42b6-b7b5-021163a66fa4 ist sehr ähnlich!

    Hat Jemand eine Idee?

    Als Beispiel habe ich hier eine Fehlersignatur von Filezilla genommen:



    Dienstag, 26. Februar 2013 11:58

Antworten

  • Hi,

    ich habe jetzt eine Workaround-Anleitung von PC-Visit.

    Achtung! Ich habe dieses Workaround noch nicht ausprobiert!!
    (Und kann folglich nicht garantieren, dass es funktioniert)

    Zitat aus PC-Visit-Support-E-Mail:

    [...]

    1. Bitte löschen Sie die Pfade zu remoteProcStart_x64.dll bzw.
    remoteProcStart_x86.dll aus folgenden Schlüsseln

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
    Windows NT\CurrentVersion\Windows\AppInit_DLLs

    Und zusätzlich bei 64-Bit Systemen (außer Windows 8/Server 2012):
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\
    Windows NT\CurrentVersion\Windows\AppInit_DLLs

    2. Fügen Sie folgenden Registry-Eintrag hinzu, um ein erneutes Schreiben in
    den soeben bereinigten Schlüssel zu verhindern:

    Bei 32-Bit Systemen, Windows 8 und Windows Server 2012:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\
    pcvisit Software(caloa)\SharedConfig

    Bei 64-Bit Systemen, außer Windows 8 bzw. Windows Server 2012:
    HKEY_LOCAL_MACHINE\SOFTWARE\pcvisit Software(caloa)\SharedConfig

    neues Dword: disableDLLInjection
    Wert: 1

    1 heisst, dass keine Einträge in die AppInit_DLLs von Windows durch den Dienst
    vorgenommen werden,
    0 oder ein nicht vorhandener Key lässt Einträge dort zu (default: nicht
    vorhanden)

    Bitte starten Sie anschließend den Rechner neu. Ggf. genügt es, wenn sich die
    Windows-Benutzer einmal abmelden und wieder anmelden.

    [...]

    Ich werde das jetzt mal ausprobieren.

    Regards

    Burkhart

    Donnerstag, 28. Februar 2013 14:04
  • Lösungsansatz seitens PCvisit:

    1. Bitte löschen Sie die Pfade zu remoteProcStart_x64.dll bzw.

    remoteProcStart_x86.dll aus folgenden Schlüsseln

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

    Windows NT\CurrentVersion\Windows\AppInit_DLLs

     

    Und zusätzlich bei 64-Bit Systemen (außer Windows 8/Server 2012):

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\

    Windows NT\CurrentVersion\Windows\AppInit_DLLs

     

    2. Fügen Sie folgenden Registry-Eintrag hinzu, um ein erneutes Schreiben in den soeben bereinigten Schlüssel zu verhindern:

     

    Bei 32-Bit Systemen, Windows 8 und Windows Server 2012:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\

    pcvisit Software(caloa)\SharedConfig

     

    Bei 64-Bit Systemen, außer Windows 8 bzw. Windows Server 2012:

    HKEY_LOCAL_MACHINE\SOFTWARE\pcvisit Software(caloa)\SharedConfig

     

    neues Dword: disableDLLInjection

    Wert: 1

     

    1 heisst, dass keine Einträge in die AppInit_DLLs von Windows durch den Dienst vorgenommen werden,

    0 oder ein nicht vorhandener Key lässt Einträge dort zu (default: nicht

    vorhanden)

     

    Bitte starten Sie anschließend den Rechner neu. Ggf. genügt es, wenn sich die Windows-Benutzer einmal abmelden und wieder anmelden.

    Achtung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Die pcvisit Software AG kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.


    Donnerstag, 28. Februar 2013 14:03

Alle Antworten

  • Hallo Tobias,

    ich habe seit gestern das selbe Problem auf zwei Windows Server 2008 R2 Servern.

    Vermutlich läuft der Server bei dir als Remotedesktop-Server.

    Ich konnte bisher folgendes in erfahrung bringen:

    wenn ich die Remotedesktopdienste deinstalliere, starten alle Anwendungen wieder normal. Bei der Neuinstallation der Remotedesktopdienste crashen die Programm wieder. Die server haben SP1 installiert und sind mit den Updates auf dem neusten Stand.


    Habe schon folgendes versucht, leider ohne erfolg:

    sfc /scannow    --> alles ok

    updates nach folgender anleitung neuinstalliert h**p://www.petri.co.il/rdp-windows-server-2008-r2.htm    --> kein erfolg


    wenn jemand noch einen tipp hätte wäre ich sehr dankbar ;-)

    Mittwoch, 27. Februar 2013 11:36
  • Habe das gleiche Problem seit gestern verschiedenste Programme stürzen ab immer mit Verweis auf

    %windir%\syswow64\ntdll.dll oder %windir%\syswow64\ole32.dll

    Bin für jede Hilfe dankbar!!!

    Gruß Thomas  

    PS: Bei mir laufen auch die RDP-Rollen

    • Bearbeitet tommytom73 Mittwoch, 27. Februar 2013 15:07
    Mittwoch, 27. Februar 2013 14:50
  • Hallo Zusammen,

    bei mir ist genau das gleiche. Sobald die Remotedesktopdienste deinstalliert wurden, funktioniert alles wieder. 

    Wir haben ein Ticket bei Microsoft eingereicht und hoffen nun auf Antwort. 

    Wenn ich eine Lösung für das Problem habe, teile ich sie gern allen hier mit!

    Viele Grüße,

    Tobias Münch

    Mittwoch, 27. Februar 2013 17:18
  • Hallo Tobias

    Das wäre sehr Nett.

    Gruß Thomas

    Donnerstag, 28. Februar 2013 08:05
  • Hallo,

    ich habe auf einem Kundenserver seit dem 26.2.2013 das exakt gleiche Problem.
    Server 2008R2 Standard, mit Remotedesktop...diverse Anwendungen (32-bit) starten nichtmehr.

    Dienste etc. laufen normal.

    Fehlermeldung ist identisch wie beim Threadstarter.

    Alle bisher versuchten Fixes und Lösungsansätze waren bisher erfolglos.

    Bin für jede Hilfe dankbar.

    Gruss

    Donnerstag, 28. Februar 2013 08:12
  • Hallo,

    ich habe exakt das gleiche Problem bei verschiedenen Kunden auf vier verschiedenen Servern. Auf allen sind die RDP Rollen aktiviert, alle haben Windows 2008 R2 als BS aber nicht auf allen sind die Windows Updates aktuell.

    Suche verzweifelt nach weiteren Gemeinsamkeiten aber bisher Fehlanzeige.

    Bin auch für jede Hilfe dankbar.

    Gruß

    Mathias  

    Donnerstag, 28. Februar 2013 10:27
  • Hallo Forum,

    wir sind hier genauso weit...drei Server 2008 R2, alle mit RDP, verschiedene Anwenungen crashen mit ol32.dll oder ntdll.dll. Wir haben gerade bei Microsoft ein Ticket eröffnet und warten auf Rückruf...hat von euch schon jemand eine Lösung ?

    Andreas Ziegler

    Spider netzwerk & Software GmbH

    Marktplatz 13

    73614 Schorndorf

    Donnerstag, 28. Februar 2013 11:47
  • Hallo Zusammen,

    wir sind gerade auf der Suche nach dem kleinsten gemeinsamen Nenner.

    Habt ihr Fernwartungssoftware installiert? Wenn ja welche?

    Wir nutzen PCvisit.

    Viele Grüße,

    Tobias Münch

    Donnerstag, 28. Februar 2013 12:39
  • Wir nutzen auch PC-Visit Profisupport 12 RemoteHost installation

    Gruß Thomas

    Donnerstag, 28. Februar 2013 12:51
  • wir haben ebenfalls auf beiden Servern pcvisit im einsatz.

    ich habe es auf einem der beiden Server bereits deinstalliert, der Fehler blieb jedoch bestehen...

    Donnerstag, 28. Februar 2013 12:51
  • Hi,

    Yep, wir haben auch PC-Visit Remotehost Version 12 auf dem betreffenden Server!

    Regards

    Burkhart

    Donnerstag, 28. Februar 2013 13:11
  • Hi,

    ja wir haben auch PC Visit in der Version 10 im Einsatz. Nach einem  beenden von PC Visit, einem Neustart des Servers und verbinden über Teamviewer war wieder alles OK.

    Nur die Software beenden hat nicht ausgereicht.

    Gruß

    Mathias 

    Donnerstag, 28. Februar 2013 13:41
  • Hi,

    wir haben gerade mit PC-Visit telefoniert:
    Es sieht so aus, als ob das Problem mit dem Update des Remotehost vom 25.02.2013 zusammenhängt.
    Es betrifft nur Server ab 2008.
    Ich erwarte jetzt ein Workaround. An einer Lösung wird noch gearbeitet...

    Kann es sein, dass das Problem nur auf Servern auftritt, auf denen Remotedesktop-Dienste (Terminal-Server) installiert ist?
    Wir haben den Remotehost nämlich auch auf anderen Servern und dort (bisher) keine Probleme.

    Regards
    Burkhart

    Donnerstag, 28. Februar 2013 13:45
  • bei mir mit der version 12 funktioniert es nach deinstallation und reboot leider noch nicht.

    Gruß

    Christof

    Donnerstag, 28. Februar 2013 13:46
  • Der Remotehost ist Versionstand 1.9.29.5004 Änderungsdatum 25.02.2013 passt genau mit der Zeit.

    Gruß Thomas

    Donnerstag, 28. Februar 2013 13:48
  • Hi,

    wir haben gerade mit PC-Visit telefoniert:
    Es sieht so aus, als ob das Problem mit dem Update des Remotehost vom 25.02.2013 zusammenhängt.
    Es betrifft nur Server ab 2008.
    Ich erwarte jetzt ein Workaround. An einer Lösung wird noch gearbeitet...

    Kann es sein, dass das Problem nur auf Servern auftritt, auf denen Remotedesktop-Dienste (Terminal-Server) installiert ist?
    Wir haben den Remotehost nämlich auch auf anderen Servern und dort (bisher) keine Probleme.

    Regards
    Burkhart


    HI,

    bei uns trat es auch nur auf Servern auf, auf denen der RDP-Dienst installiert war.

    Gruß

    Mathias

    Donnerstag, 28. Februar 2013 13:56
  • Hallo die Herren,

    Folgender Sachstand nach ca 20 Stunden Fehlersuche: Erfolg !

    Wir haben das Problem auf unserem eigenen Server, diesen auf den Stand Montag 05.00 Uhr recovered --> ohne LAN. Nach Rücksicherung PC-Visit Remote Host deinstalliert, heruntergefahren. Server Start mit LAN....alles gut. Server bis jetzt drei mal durch- bzw neu gestartet...Server und Anwendungen laufen.

    Was nun ?

    ich habe das Problem aktuell noch auf zwei Kunden Server...die kann ich nicht einfach mal so eben zurücksetzten. 

    Gruß

    Andreas Ziegler

    Donnerstag, 28. Februar 2013 13:56
  • Lösungsansatz seitens PCvisit:

    1. Bitte löschen Sie die Pfade zu remoteProcStart_x64.dll bzw.

    remoteProcStart_x86.dll aus folgenden Schlüsseln

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\

    Windows NT\CurrentVersion\Windows\AppInit_DLLs

     

    Und zusätzlich bei 64-Bit Systemen (außer Windows 8/Server 2012):

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\

    Windows NT\CurrentVersion\Windows\AppInit_DLLs

     

    2. Fügen Sie folgenden Registry-Eintrag hinzu, um ein erneutes Schreiben in den soeben bereinigten Schlüssel zu verhindern:

     

    Bei 32-Bit Systemen, Windows 8 und Windows Server 2012:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\

    pcvisit Software(caloa)\SharedConfig

     

    Bei 64-Bit Systemen, außer Windows 8 bzw. Windows Server 2012:

    HKEY_LOCAL_MACHINE\SOFTWARE\pcvisit Software(caloa)\SharedConfig

     

    neues Dword: disableDLLInjection

    Wert: 1

     

    1 heisst, dass keine Einträge in die AppInit_DLLs von Windows durch den Dienst vorgenommen werden,

    0 oder ein nicht vorhandener Key lässt Einträge dort zu (default: nicht

    vorhanden)

     

    Bitte starten Sie anschließend den Rechner neu. Ggf. genügt es, wenn sich die Windows-Benutzer einmal abmelden und wieder anmelden.

    Achtung: Die unkorrekte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die das gesamte System betreffen und eine Neuinstallierung des Betriebssystems erforderlich machen. Die pcvisit Software AG kann nicht garantieren, dass Probleme, die von einer falschen Verwendung des Registrierungseditors herrühren, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.


    Donnerstag, 28. Februar 2013 14:03
  • Hi,

    ich habe jetzt eine Workaround-Anleitung von PC-Visit.

    Achtung! Ich habe dieses Workaround noch nicht ausprobiert!!
    (Und kann folglich nicht garantieren, dass es funktioniert)

    Zitat aus PC-Visit-Support-E-Mail:

    [...]

    1. Bitte löschen Sie die Pfade zu remoteProcStart_x64.dll bzw.
    remoteProcStart_x86.dll aus folgenden Schlüsseln

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
    Windows NT\CurrentVersion\Windows\AppInit_DLLs

    Und zusätzlich bei 64-Bit Systemen (außer Windows 8/Server 2012):
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\
    Windows NT\CurrentVersion\Windows\AppInit_DLLs

    2. Fügen Sie folgenden Registry-Eintrag hinzu, um ein erneutes Schreiben in
    den soeben bereinigten Schlüssel zu verhindern:

    Bei 32-Bit Systemen, Windows 8 und Windows Server 2012:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\
    pcvisit Software(caloa)\SharedConfig

    Bei 64-Bit Systemen, außer Windows 8 bzw. Windows Server 2012:
    HKEY_LOCAL_MACHINE\SOFTWARE\pcvisit Software(caloa)\SharedConfig

    neues Dword: disableDLLInjection
    Wert: 1

    1 heisst, dass keine Einträge in die AppInit_DLLs von Windows durch den Dienst
    vorgenommen werden,
    0 oder ein nicht vorhandener Key lässt Einträge dort zu (default: nicht
    vorhanden)

    Bitte starten Sie anschließend den Rechner neu. Ggf. genügt es, wenn sich die
    Windows-Benutzer einmal abmelden und wieder anmelden.

    [...]

    Ich werde das jetzt mal ausprobieren.

    Regards

    Burkhart

    Donnerstag, 28. Februar 2013 14:04
  • Alternativ:

    • Pcvisit Dienst deaktvieren
    • Ordner "pcvisit" unter ProgrammData verschieben.
    Donnerstag, 28. Februar 2013 14:15
  • Hi Leute,

    der Workaround von PC-Visit scheint zu funktionieren.

    Ich kann auf dem betroffenen Server jetzt wieder die vorher blockierten Anwendungen starten.

    Ein Server-Neustart war hier nicht nötig. Abmelden hat gereicht.

    Ich hoffe es hilft!!

    Regards

    Burkhart

    Donnerstag, 28. Februar 2013 14:16
  • Der Workaround hat schonmal als Administrator funktioniert wenn die RegKeys geändert sind.

    Ich brauchte den Admin Account nur abmelden und neu anmelden und schon waren die Anwendungen welche nicht liefen sofort wieder da.

    Vielen Dank für die Gute Zusammenarbeit bei der Lösung des Problems.

    Güße Thomas

     
    Donnerstag, 28. Februar 2013 14:26
  • Hallo liebes Forum, ich muss mich hier nun auch einmal zu Wort melden:

    Dank eurer Hilfe sind hier 10 user (wieder) glücklich, alle Programme laufen wieder! Danke an alle!!!

    Donnerstag, 28. Februar 2013 14:29
  • Hallo,

    ich wäre schon dafür diesen Umstand bei PC-Visit zu rügen und auf einen Schadensersatz zu pochen. Immerhin hatten ich und meine Kunden einen Ausfall von drei tagen...auf Produktiv Server die ja zum Arbeiten da sind. PC-Visit gibt ja auch mit ihrer Mail alles zu. Und PC-Visit ist ja nun nicht gerade billig.

    MfG

    Andreas Ziegler

    Donnerstag, 28. Februar 2013 14:37
  • Was mich irritiert ist das pc-visit sich selbst update konnte aber ich finde im Remotehost keine Einstellungen für automatische Updates.

    Dies gibt mir zu denken.

    Donnerstag, 28. Februar 2013 14:45
  • Was mich irritiert ist das pc-visit sich selbst update konnte aber ich finde im Remotehost keine Einstellungen für automatische Updates.

    Dies gibt mir zu denken.

    PC-Visit macht das Automatisch...da kommen ständig updates.
    Donnerstag, 28. Februar 2013 14:46
  • Hi Leute,

    @demad: Das sehe ich auch so! Bin stinksauer.

    Regards

    Burkhart

    Donnerstag, 28. Februar 2013 14:50
  • Also wir überlegen die RemoteHosts auf den Kundenservern zu deaktivieren. Wenn wir keine Kontrolle über die Updatetätigkeit des Remotehosts haben ist das fahrlässig. Sogar die Windows Updates werden bei uns vorher geprüft auf einem Testserver ob es irgend welche Probleme gibt und erst dann auf die Produktiven installiert.

    Hier haben wir keine Kontrolle über die Updates das finde ich mehr als übel!!!

    Gruß Thomas 

    Donnerstag, 28. Februar 2013 15:00
  • Hi,

    so wie es aussieht kam gestern abend noch ein Update für den Remotehost von PC-Visit, der das Problem beseitigt.

    Scheint jetzt wieder zu funktionieren.

    Die automatischen Updates bereiten uns allerdings auch Bauchschmerzen....

    Regards

    Burkhart

    Freitag, 1. März 2013 08:09
  • Am 01.03.2013 schrieb Burkhart Schaffrath:

    so wie es aussieht kam gestern abend noch ein Update für den Remotehost von PC-Visit, der das Problem beseitigt.

    Scheint jetzt wieder zu funktionieren.

    Für welchen zweck braucht man ein 3rd Party Tool, wenn es ein Tool
    (RDP) bereits On Board gibt?

    Die automatischen Updates bereiten uns allerdings auch Bauchschmerzen....

    Weshalb genau?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Freitag, 1. März 2013 21:16
  • Am 01.03.2013 schrieb Burkhart Schaffrath:


    Für welchen zweck braucht man ein 3rd Party Tool, wenn es ein Tool
    (RDP) bereits On Board gibt.

    Es gibst durchaus Gründe einen "richtigen" Zugriff auf einen Server Desktop zu haben...gerade bei RDP ist es als Admin nur so möglich im taskmanager alles zu sehen...

    MfG

    Andreas Ziegler

    Samstag, 2. März 2013 09:49
  • Am 01.03.2013 schrieb Burkhart Schaffrath:

    so wie es aussieht kam gestern abend noch ein Update für den Remotehost von PC-Visit, der das Problem beseitigt.

    Scheint jetzt wieder zu funktionieren.

    Für welchen zweck braucht man ein 3rd Party Tool, wenn es ein Tool
    (RDP) bereits On Board gibt?

    Die automatischen Updates bereiten uns allerdings auch Bauchschmerzen....

    Weshalb genau?

    Servus
    Winfried


    Connect2WSUS: http://www.grurili.de/tools/Connect2WSUS.exe
    GPO's: http://www.gruppenrichtlinien.de
    Community Forums NNTP Bridge: http://communitybridge.codeplex.com/

    Hallo Winfried

    Er meint die Automatischen Updates des PC-Visit Fernwartungsmoduls welche man nicht konfigurieren kann.

    Gruß Thomas

    Montag, 4. März 2013 13:00