none
Web-Authentifizerung über SmartTV RRS feed

  • Frage

  • Hallo liebe Mitglieder,

    folgende Grundkonfiguration:

    • Intranet (keine Verbindung nach "draußen")
    • IIS 7 (Windows-Authentifizierung)
    • Windows-Domäne
    • Windows-Clients
    • SQL-Server 2014 DB mit Benutzerdaten und -rechten

    Die Windows-Authentifizierung klappt an den Windows-Clients problemlos.

    Zusätzlich ist ein separates Anmeldeformular mit eingebaut, dass die Daten aus einer SQL-Datenbank bezieht, damit sich auch Benutzer anmelden können, die sich nicht in der Windows-Domäne befinden.

    Nun haben wir für ein Anzeigesystem eine SmartTV angeschafft, der die Informationen von einer Website im Intranet darstellen soll. Es handelt sich um ein Samsung SmartTV.
    Öffne ich nun hier die Website am TV, so kommt immer der Fehler 401, ohne das irgend ein Anmeldedialog erscheint. Das ist ja auch am Webserver als Antworttyp in den Einstellungen so festgelegt.

    Kann mir vielleicht jemand sagen, ob diese Art der Anmeldung per SmartTV überhaupt funktioniert?

    Ich habe bereits etwas mit der IIS-Konfiguration und auch per web.config und global.asax etwas herumprobiert, aber leider kein Erfolg. Entweder ich hänge am TV mit Fehler 401 oder am Windowsclient muss man sich erst jedesmal über die Formularauthentifizierung anmelden.

    Mag sein, dass ich da ein Verständnisproblem habe.

    Vielleicht kann mir ja jemand auf die Sprünge helfen.

    Vielen Dank


    Viele Grüße, Volker

    Dienstag, 10. Mai 2016 13:03

Antworten

  • Das Thema hat sich erledigt.

    Ich habe eine zusätzlich Domain angelegt, und hier nur die anonyme Authentifzierung eingeschaltet.

    Wird ein Domänenbenutzer oder ein Benutzer über einen URL-Parameter erkannt, so werden die Daten in diesem Kontext geladen, anderfalls wird der Mitarbeiter auf die Loginseite verwiesen.

    Das mag zwar nicht das gelbe vom Ei sein, ist aber erst mal das einfachste auf die Schnelle.

    Für "professionellere" Vorschläge bin ich gerne offen.

    Viele Grüß und schöne Pfingsten!


    Viele Grüße, Volker

    • Als Antwort vorgeschlagen Ben-neB Montag, 23. Mai 2016 06:20
    • Als Antwort markiert Volker S Dienstag, 24. Mai 2016 04:41
    Freitag, 13. Mai 2016 07:20

Alle Antworten

  • Hi Volker,

    ich habe auf die Schnelle andere Foreneinträge gefunden, in denen das lief (also formularbasierte Authentifizierung vom SmartTV aus). Hierzu zwei Fragen:
    1. Was für ein Modell habt Ihr da?
    2. Hast Du schon geprüft, ob es evtl. ein Firmware-Update für das Gerät gibt?


    Gruß

    Ben

    MCSA SQL Server MCSA Windows Client MCSA Windows Server

    Wenn Dir meine Antwort hilft, markiere sie bitte entsprechend als Antwort! Danke! :-)

    Hinweis: Meine Posts werden "wie besehen" ohne jedwede Gewähr bereitgestellt, da menschliche, technische und andere Fehler nicht ausgeschlossen werden können.

    Dienstag, 10. Mai 2016 13:10
  • Hallo ben,

    vielen Dank für dein Interesse.

    Es handelt sich um einen Samsung UE55J6250SU. Die Firmware haben ich eben aktualisiert, jedoch hat es nichts gebracht. Immer wieder 401.

    Ich denke, du hast mich evtl. falsch verstanden.

    Die reine formularbasierte Anmeldung funktioniert an sich schon. Eben nur nicht die Windows-Domänenanmeldung. Also das Popup, welches eigentlich erscheinen sollte, wenn man sich am Webserver authentifizieren muss.

    Vielleicht als kurze Erklärung:

    Die Windowsanmeldung ist dafür gedacht, dass nach einmaliger Anmeldung der Benutzer automatisch weitergeleitet wird, um sich nicht immer wieder neu anmelden zu müssen, da hier Seiten auch über Mobile-Devices abgerufen werden, die im Benutzerkontext laufen müssen. Und da möchte der Benutzer sich eben nicht immer anmelden, sondern gleich zum Ziel gelangen. Da gibt es mittlerweile genug Anwendungen, die ständig nach Anmeldung verlangen.

    Da es aber auch Benutzer gibt, die kein Windows-Login besitzen müssen diese eben auch über eine separate  Anmeldung Zugriff bekommen.

    Daher also der gemischt Modus.

    Am BB zum Beispiel funktioniert die Serverauthentifizierung problemlos.

    Halt nur nicht am SmartTV. Da läuft, soviel das Logfile am IIS verrät, ein Mozilla. Die Einstellungen im Browser sind auch sehr eingeschränkt.


    Viele Grüße, Volker

    Dienstag, 10. Mai 2016 13:54
  • Das Thema hat sich erledigt.

    Ich habe eine zusätzlich Domain angelegt, und hier nur die anonyme Authentifzierung eingeschaltet.

    Wird ein Domänenbenutzer oder ein Benutzer über einen URL-Parameter erkannt, so werden die Daten in diesem Kontext geladen, anderfalls wird der Mitarbeiter auf die Loginseite verwiesen.

    Das mag zwar nicht das gelbe vom Ei sein, ist aber erst mal das einfachste auf die Schnelle.

    Für "professionellere" Vorschläge bin ich gerne offen.

    Viele Grüß und schöne Pfingsten!


    Viele Grüße, Volker

    • Als Antwort vorgeschlagen Ben-neB Montag, 23. Mai 2016 06:20
    • Als Antwort markiert Volker S Dienstag, 24. Mai 2016 04:41
    Freitag, 13. Mai 2016 07:20