none
Exchange 2010 Installation / failed RRS feed

  • Frage

  • Hallo Community,

    ich verzweifel derzeit an der Exchange 2010 Installation.
    Folgende Konstellation

    Domänen-Stamm: abc.de
    1. Standort: firma1 (Exchange 2007, 2 DC's First-Standard-Site)
    2. Standort: firma2 (Exchange 2003, soll ersetzt werden durch 2010; 2x DC's First-Standard-Site, 1x firma1)

    Bei der Überprüfung zur Installation kommen folgende Fehler


    Voraussetzungen für Organisation
    Fehler

    Fehler:
    Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen, dieser Computer befindet sich jedoch nicht am gleichen Active Directory-Standort wie der Schemamaster (Standardname-des-ersten-Standorts).

    Fehler:
    Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen, dieser Computer befindet sich jedoch nicht in der gleichen Active Directory-Domäne wie der Schemamaster (DC=firma1,DC=abc,DC=de).

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die Gesamtstrukturfunktionsebene der aktuellen Active Directory-Grundstruktur ist nicht im einheitlichen Modus von Windows Server 2003 oder höher. Wenn Sie Exchange Server 2010 installieren möchten, muss die Gesamtstrukturfunktionsebene mindestens den einheitlichen Modus von Windows Server 2003 haben.

    Warnung:
    Der für die Domäne 'DC=firma1,DC=abc,DC=de' verantwortliche Empfängerupdatesdienst kann nicht gefunden werden. Neue und vorhandene Benutzer sind möglicherweise nicht ordnungsgemäß Exchange-aktiviert.

     

    Hub-Transport-Rolle Voraussetzungen
    Fehler

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die lokale Domäne muss vorbereitet werden (mithilfe von 'Setup /PrepareDomain'), bevor Serverrollen installiert werden können.


    Clientzugriffsrolle Voraussetzungen

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die lokale Domäne muss vorbereitet werden (mithilfe von 'Setup /PrepareDomain'), bevor Serverrollen installiert werden können.


    Postfachrolle Voraussetzungen

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die lokale Domäne muss vorbereitet werden (mithilfe von 'Setup /PrepareDomain'), bevor Serverrollen installiert werden können.

    Warnung:
    Der für die Domäne 'DC=firma1,DC=abc,DC=de' verantwortliche Empfängerupdatesdienst kann nicht gefunden werden. Neue und vorhandene Benutzer sind möglicherweise nicht ordnungsgemäß Exchange-aktiviert.

     

    Ehrlich gesagt, bin ich mir auch nicht ganz sicher, was bei den Befehlen /prepareDomain /prepareAD und /prepareSchema passiert. Ich hoffe ihr könnt mir dabei etwas helfen.

    Vielen Dank im Voraus.

    Dienstag, 7. Januar 2014 13:35

Antworten

  • Es gibt einen Schemamaster in der Gesamten Struktur. Dort mußt du das Setup ausführen. Also wenn deine Gesamtstruktur abc.de heißt, dann führe das Setup dort aus.

    Gruß

    Jörg 

    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:53
    Mittwoch, 8. Januar 2014 13:57
  • Moin,

    nimm Dir irgendeinen DC, öffne dort eine CMD und führe den folgenden Befehl aus:

    netdom query fsmo

    Dann geh zu dem DC, der dort als "Schema-Master" geliestet ist und führe auf diesem mit den passenden Berechtigungen /preparead des SP 3 durch.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:53
    Mittwoch, 8. Januar 2014 14:44
  • Hallo,

    wurde erledigt. Leider ist unsere Struktur, wie mir auffiel, Mist.
    Schemamaster Windows Server 2008 32-Bit, d.h. ich muss das mit Exhange 2007 SP3, dass /prepareSchema machen.

    Das Schema wurde erweitert, danach /prepareAD, ebenfalls erfolgreich. Aber ich habe immer noch die gleichen Fehler:


    Voraussetzungen für Organisation
    Fehler

    Fehler:
    Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen, dieser Computer befindet sich jedoch nicht in der gleichen Active Directory-Domäne wie der Schemamaster (DC=firma1,DC=abc,DC=de).

    --> Schemamaster befindet sich in firma1

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die Gesamtstrukturfunktionsebene der aktuellen Active Directory-Grundstruktur ist nicht im einheitlichen Modus von Windows Server 2003 oder höher. Wenn Sie Exchange Server 2010 installieren möchten, muss die Gesamtstrukturfunktionsebene mindestens den einheitlichen Modus von Windows Server 2003 haben.

    -> Der Exchange 2003 - Betriebsmodus = einheitlicher Modus

    Warnung:
    Der für die Domäne 'DC=firma1,DC=abc,DC=de' verantwortliche Empfängerupdatesdienst kann nicht gefunden werden. Neue und vorhandene Benutzer sind möglicherweise nicht ordnungsgemäß Exchange-aktiviert.

    Hub-Transport-Rolle Voraussetzungen

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.


    Fehler:
    Exchange Server 2010 und Exchange Server-Versionen, die älter sind als Exchange Server 2007 SP2, können nicht gleichzeitig im selben Active Directory-Standort installiert sein.

    --> 2007 befindet sich im Standort der firma1 / 2010 soll in den Standort firma2

    Fehler:
    Die lokale Domäne muss vorbereitet werden (mithilfe von 'Setup /PrepareDomain'), bevor Serverrollen installiert werden können.

    --> Habe ich noch nicht durchgeführt / Veränderungen? Der Exchange 2003 muss bis zum Ende mit laufen.

    Da die Infrastruktur seit 1991 gewachsen ist und niemand damals wirklich Ahnung von IT hatte, wurde das frei nach Schnauze aufgesetzt. Zwar ist abc.de die Rootdomain, aber seltsamerweise hat die Domäne firma1 mehr Rechte als firma2.


    • Bearbeitet MartinMA Mittwoch, 8. Januar 2014 15:14
    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:54
    Mittwoch, 8. Januar 2014 15:13

Alle Antworten

  • Moin,

    was die Befehle machen, ist ausführlich hier beschrieben.

    Du musst in Deiner Umgebung erst das AD vorbereiten und das muss in der Domäne passieren, in der die FSMO stehen (i.d.R. die Root-Domäne) und Du brauchst dafür die passenden Berechtigungen -> Enterprise Admins und Schema Admin - je nach Schritt.

    Nimm das SP 3 und führe setup.com und führe in der korrekten Domäne und mit den passenden Berechtigungen die "prepare"-Befehle aus. Danach kannst Du in der unter geordneten Domäne die Installation selbst wieder mit Grafik durchführen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Dienstag, 7. Januar 2014 15:00
  • Moin,

    was die Befehle machen, ist ausführlich hier beschrieben.

    Du musst in Deiner Umgebung erst das AD vorbereiten und das muss in der Domäne passieren, in der die FSMO stehen (i.d.R. die Root-Domäne) und Du brauchst dafür die passenden Berechtigungen -> Enterprise Admins und Schema Admin - je nach Schritt.

    Nimm das SP 3 und führe setup.com und führe in der korrekten Domäne und mit den passenden Berechtigungen die "prepare"-Befehle aus. Danach kannst Du in der unter geordneten Domäne die Installation selbst wieder mit Grafik durchführen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Hallo Robert,

    vielen Dank für deine Antwort.
    Ich wollte so eben bei "firma2" ein setup /prepareAD machen. Folgende Fehler:

        Organisationsüberprüfungen                            FEHLER
     Der für die Domäne 'DC=firma1,DC=abc,DC=de' verantwortliche Empfänger
    updatesdienst kann nicht gefunden werden. Neue und vorhandene Benutzer sind mögl
    icherweise nicht ordnungsgemäß Exchange-aktiviert.
         Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen
    , dieser Computer befindet sich jedoch nicht am gleichen Active Directory-Stando
    rt wie der Schemamaster (Standardname-des-ersten-Standorts).

         Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen
    , dieser Computer befindet sich jedoch nicht in der gleichen Active Directory-Do
    mäne wie der Schemamaster (DC=firma1,DC=abc,DC=de).

         Problem beim Überprüfen des Status von Active Directory: Es wurden keine Ex
    change-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht währe
    nd der Installation erstellt werden, weil sich der lokale Computer nicht in ders
    elben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen
    Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'witte
    nburg' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie a
    uf den Abschluss der Replikation.

         Die Gesamtstrukturfunktionsebene der aktuellen Active Directory-Grundstrukt
    ur ist nicht im einheitlichen Modus von Windows Server 2003 oder höher. Wenn Sie
     Exchange Server 2010 installieren möchten, muss die Gesamtstrukturfunktionseben
    e mindestens den einheitlichen Modus von Windows Server 2003 haben.


    Setup von Exchange Server wurde nicht abgeschlossen. Weitere Details finden Sie
    im Protokoll 'ExchangeSetup.log' im Ordner '<SystemDrive>:\ExchangeSetupLogs'.

    Fehler beim Setup von Exchange Server.

    Der Betriebsmodus vom Exchange 2003 befindet sich auf dem "einheitlichen Modus".

    Nur warum kann das Setup bzw. das /prepareAD keine Verbindung zum Schemamaster aufbauen, warum auch immer. Zwei unterschiedliche Standardname-des-ersten-Standorts?

    In der Struktur der firma1, brauch kein /prepareAD gemacht werden, da dieser auf Exchange 2007 läuft. Ich weiß nicht, ob ich irgendwo ein Denkfehler habe.

    Mittwoch, 8. Januar 2014 13:15
  • Es gibt einen Schemamaster in der Gesamten Struktur. Dort mußt du das Setup ausführen. Also wenn deine Gesamtstruktur abc.de heißt, dann führe das Setup dort aus.

    Gruß

    Jörg 

    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:53
    Mittwoch, 8. Januar 2014 13:57
  • Moin,

    nimm Dir irgendeinen DC, öffne dort eine CMD und führe den folgenden Befehl aus:

    netdom query fsmo

    Dann geh zu dem DC, der dort als "Schema-Master" geliestet ist und führe auf diesem mit den passenden Berechtigungen /preparead des SP 3 durch.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:53
    Mittwoch, 8. Januar 2014 14:44
  • Hallo,

    wurde erledigt. Leider ist unsere Struktur, wie mir auffiel, Mist.
    Schemamaster Windows Server 2008 32-Bit, d.h. ich muss das mit Exhange 2007 SP3, dass /prepareSchema machen.

    Das Schema wurde erweitert, danach /prepareAD, ebenfalls erfolgreich. Aber ich habe immer noch die gleichen Fehler:


    Voraussetzungen für Organisation
    Fehler

    Fehler:
    Setup muss eine Verbindung mit dem Active Directory-Schemamaster herstellen, dieser Computer befindet sich jedoch nicht in der gleichen Active Directory-Domäne wie der Schemamaster (DC=firma1,DC=abc,DC=de).

    --> Schemamaster befindet sich in firma1

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.

    Fehler:
    Die Gesamtstrukturfunktionsebene der aktuellen Active Directory-Grundstruktur ist nicht im einheitlichen Modus von Windows Server 2003 oder höher. Wenn Sie Exchange Server 2010 installieren möchten, muss die Gesamtstrukturfunktionsebene mindestens den einheitlichen Modus von Windows Server 2003 haben.

    -> Der Exchange 2003 - Betriebsmodus = einheitlicher Modus

    Warnung:
    Der für die Domäne 'DC=firma1,DC=abc,DC=de' verantwortliche Empfängerupdatesdienst kann nicht gefunden werden. Neue und vorhandene Benutzer sind möglicherweise nicht ordnungsgemäß Exchange-aktiviert.

    Hub-Transport-Rolle Voraussetzungen

    Fehler:
    Problem beim Überprüfen des Status von Active Directory: Es wurden keine Exchange-Objekte auf Organisationsebene erstellt. Diese Objekte können nicht während der Installation erstellt werden, weil sich der lokale Computer nicht in derselben Domäne und nicht im selben Standort wie der Schemamaster befindet. Führen Sie Setup mit dem Parameter '/prepareAD' auf einem Computer in der Domäne 'firma1' und im Standort 'Standardname-des-ersten-Standorts' aus, und warten Sie auf den Abschluss der Replikation.


    Fehler:
    Exchange Server 2010 und Exchange Server-Versionen, die älter sind als Exchange Server 2007 SP2, können nicht gleichzeitig im selben Active Directory-Standort installiert sein.

    --> 2007 befindet sich im Standort der firma1 / 2010 soll in den Standort firma2

    Fehler:
    Die lokale Domäne muss vorbereitet werden (mithilfe von 'Setup /PrepareDomain'), bevor Serverrollen installiert werden können.

    --> Habe ich noch nicht durchgeführt / Veränderungen? Der Exchange 2003 muss bis zum Ende mit laufen.

    Da die Infrastruktur seit 1991 gewachsen ist und niemand damals wirklich Ahnung von IT hatte, wurde das frei nach Schnauze aufgesetzt. Zwar ist abc.de die Rootdomain, aber seltsamerweise hat die Domäne firma1 mehr Rechte als firma2.


    • Bearbeitet MartinMA Mittwoch, 8. Januar 2014 15:14
    • Als Antwort markiert Alex Pitulice Montag, 3. Februar 2014 11:54
    Mittwoch, 8. Januar 2014 15:13
  • Warum installierst Du das Schema von 2007, wenn Du 2010 installieren willst? Dann musst Du die Änderungen von 2010 installieren (die kummulativ sind, also die von 2007 enthalten).

    Mit entsprechendem Fachwissen könnte man in Deiner Umgebung da AD auch von einem anderen Server aktualisieren.

    Aber es wäre vermutlich deutlich besser und zukunftssicherer, wenn Du zumindest den Halter der FSMO auf ein aktuelles (bis 2010) 64-Bit Betriebssystem bringst.

    Ansonsten ist das ein interessantes Beispiel, was bei Exchange auf jeden Fall vorher sauber laufen muss: Active Directory.

    Ich denke, eine Hilfe in einem Forum wird die Möglichkeiten übersteigen. Hole Dir jemanden ins Haus, der sich damit auskennt. Natürlich kostet das Geld, aber das wurde ja vorher gespart. ;)


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Mittwoch, 8. Januar 2014 15:30
  • Recht hast du.

    Hatte heute schon überlegt die FSMO Rolle an einem 64bit Rechner zu übergeben, nur ist mir das noch zu heiß, da von uns beiden Administratoren niemand wirklich weiß, was in dem Zeitraum von '91 - 2009 geschehen ist.

    Die wohlbeste Option ware, alle neu hoch zuziehen, aber wer gibt uns schon mind. 3 Wochen Zeit dafür. ;)

    Aber erstmal Vielen Dank für eure Hilfe!

    Mittwoch, 8. Januar 2014 17:26
  • Naja wenn das AD sonst ordentlich funktioniert kannst du die Rollen doch einfach per MMC verschieben. Dapssiert ja erstmal nix. Falls es nicht geht bleiben sie einfach auf dem alten FSMO Owner.

    Gruß

    Jörg

    Donnerstag, 9. Januar 2014 08:02
  • Selbst wenn der Verschiebevorgang unproblematisch ist, sollte man sich über die Auswirkungen in der Praxis vorher Gedanken machen. Wenn PDC-Emulator nicht erreichbar ist, kann das bei den Anwendern viel Spaß verursachen. Gibt es Probleme beim RID-Master, kann man den eventuell nicht einfach wieder wegschieben, sondern muss vorher den RID-Pool anpassen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Donnerstag, 9. Januar 2014 08:44
  • Fehler:
    Die Gesamtstrukturfunktionsebene der aktuellen Active Directory-Grundstruktur ist nicht im einheitlichen Modus von Windows Server 2003 oder höher. Wenn Sie Exchange Server 2010 installieren möchten, muss die Gesamtstrukturfunktionsebene mindestens den einheitlichen Modus von Windows Server 2003 haben.

    -> Der Exchange 2003 - Betriebsmodus = einheitlicher Modus


    Hallo,

    hier geht's nicht um den Betriebsmodus von Exchange 2003, sondern um die Gesamtstrukturfunktionsebene der Active Directory, die in dieser Umgebung wohl noch auf 2000 steht.

    Grüße,

    Toni

    Donnerstag, 9. Januar 2014 15:56
  • Selbst wenn der Verschiebevorgang unproblematisch ist, sollte man sich über die Auswirkungen in der Praxis vorher Gedanken machen. Wenn PDC-Emulator nicht erreichbar ist, kann das bei den Anwendern viel Spaß verursachen. Gibt es Probleme beim RID-Master, kann man den eventuell nicht einfach wieder wegschieben, sondern muss vorher den RID-Pool anpassen.


    Gruesse aus Berlin schickt Robert - MVP Exchange Server

    Hallo,

    also der Verschiebevorgang der FSMO von einem Windows Server 2008 x86 auf einen W2K8 R2 verlief ohne Probleme. Doch sehe ich derzeit mehrere Probleme innerhalb der Domäne.

    Der nächste DC der bei uns ausgetauscht werden soll, ist ein W2K3 SP2 x86. Dieser halt noch folgende Rollen

    - Infrastrukturmaster
    - RID-Pool-Manager
    - PDC

    Das hieße, dass die Rollen schnellmöglich einem anderen DC Version 2008 R2 übertragen werden sollten, korrekt?

    Freitag, 10. Januar 2014 11:15