none
CPU bei 100% RRS feed

  • Frage

  • Wir haben seit kurzen einen Windows Server 2012 mit der Fileserver-Rolle virtuell unter VMware installiert (unser 1. 2012 Server). Alle anderen Serverb (meist 2008 R2) laufen normal, dieser Server ist aber sehr oft bei einer CPU-Auslastung von 100%.

    Habe deswegen schon einen Case bei VMware eröffnet, von welchen ich folgende Aussage bekam:

    Thanks for the web session. We did the following:

                - checked guest OS (Windows Server 2012), system process at 99% CPU usage

                - checked processes with process manager, unable to access stack from system process

            - checked VM settings, no limitations, host ESXi also fine

            - moved VM out of ressource pool, same behaviour

    Since this seems to be an issue within the OS, please file a case with Microsoft to check this issue from their side. Please get back to us with the result, as i will keep this case "on hold".

    Können Sie mir deswegen bitte weiterhelfen?

    Freitag, 14. März 2014 11:33

Antworten

Alle Antworten

  • > Serverb (meist 2008 R2) laufen normal, dieser Server ist aber sehr oft
    > bei einer CPU-Auslastung von 100%.
     
    Sysinternals Process Explorer - welcher Prozess und welcher Thread in
    diesem Prozess verursachen die Auslastung?
     
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Freitag, 14. März 2014 12:15
  • HI,

    ggf. wäre es interessant zu wissen, welche VM Ware version verwender wird. Sowie ob es sich um einen Standalone Host oder einen vCenter Managed System.

    Dann wäre es gut zu Wissen wie der Server 2012 ausgestattet ist (CPU und RAM), ggf. muss man hier was drehen. Würde mal min 4 CPU und 8 GB RAM sagen

    Gruß

    Marius

    Freitag, 14. März 2014 13:05
  • Der System-Prozess und darunter ist etwa 20 mal der Ntoskrnl.exe- Thread zu sehen
    Freitag, 14. März 2014 13:06
  • Die VM läuft unter einem ESXi 5.1.0, 1612806, demnächst führen wir dann das Update auf ESXi 5.5 durch, es ist ein vCenter Managed System, wir haben drei ESX-Server.

    Der Server müsste eigentlich ausreichend bestückt sein, im Moment hat er 6 GB RAM und drei CPUs, ist im Moment halt nicht ganz das was Du vorschlägst, haben wir aber auch schon ausprobiert, und das hat nichts gebracht. Unser vorheriger Fileserver lief übrigens unter Novell, und da hatten wir nur 2 CPUs und 4 GB RAM. 

    Freitag, 14. März 2014 13:26
  • Hallo Neugart,

    zum einen sagt ja VMWare das mehere vCPUs auch kontraproduktiv sein können. Daher empfehlen sie mit einem vCPU anzufangen und verschiedene Parameter ggf. anzupassen, bevor man weitere vCPUs hinzufügt.

    Zum anderen macht es sich VMWare natürlich relativ einfach mit Ihrer Aussage.

    Die 100% CPU sind die im Task-Manager, in der VMWare "Leistung", oder im Alert zu finden?

    Welche VMWare Version benutzt der Gast? (VM-Version im vCenter)

    Viele Grüße

    Rolf


    - Carpe Diem - -Ist mir jetzt egal, ich lass das jetzt so.-

    Freitag, 14. März 2014 15:02
  • Hi, 

    aus meiner Erfahrung heraus würde ich nem 2012 immer 8 GB RAM geben, dann rennt die Server "recht" Performant.

    Leider sagt mir die Ntoskrnl.exe aus dem Stegreif nicht so viel, jedoch gibt es hier diesen Troubleshooting Artikel, was man bei einer Hohen CPU Auslastung alles machen kann:

    http://blogs.technet.com/b/yongrhee/archive/2009/08/07/how-to-troubleshoot-high-cpu-in-the-system-process.aspx

    ggf. Hilft dir das weiter

    Gruß

    Marius

    Freitag, 14. März 2014 15:07
  • Die 100% CPU-Auslastung sind im Task-Manager und unter "Alert" zu finden. Der Gast hat die VM-Version 8, was bis dahin auch die aktuellste Version ist.
    Montag, 17. März 2014 07:11
  • 8 GB? Bis auf unserem ERP-System haben wir noch nie einem Server so viele CPUs zugewiesen.

    Den Artikel schau ich mir mal an.

    Heute hat sich der Server aber anscheinend wieder beruhigt nachdem ich letzte Woche die "Shadow Copies" abgeschaltet habe.

    Montag, 17. März 2014 07:14
  • In dem Artikel steht übrigens nichts passendes, entweder haben wir die Vorschläge schon alle ausprobiert oder die Punkte treffen nicht auf uns zu.
    Montag, 17. März 2014 07:16
  • Kommando zurück,

    das Deaktivieren der "Shadow Copies" hat doch nichts gebracht, die CPU-Auslastung ist immer noch bei 100%.

    Dienstag, 18. März 2014 08:05
  • Hallo Neugart,

    Ist RSS auf dem NIC des Fileservers aktiviert? http://msdn.microsoft.com/en-us/library/windows/hardware/ff567236(v=vs.85).aspx

    Du schreibst, die Maschine sei oft am Anschlag. Kannst du beobachten, wie es sich nach einem Boot verhält und wann die CPU dann in die Höhe schnellt?
    Vorschlag wäre dann nämlich, mal einen Boottrace mit XPERF zu machen und zu sehen, wann die CPU hoch geht. Mit diesem Trace kannst du dich dann auch getrost an den MS Support wenden - Kernel Debugging funktioniert in der Community aufgrund der fehlenden Symbols leider schlecht (anschauen kann ich mir den Trace aber trotzdem).

    http://blogs.technet.com/b/austria/archive/2011/10/16/high-cpu-analyse-mit-xperf-oder-wie-sie-hohe-cpu-auslastung-analysieren-k-246-nnen.aspx

    http://blogs.technet.com/b/askperf/archive/2008/06/27/an-intro-to-xperf.aspx

    Gruß
    Lennart

    Dienstag, 18. März 2014 14:25
  • RSS ist übrigens auf der NIC des Fileservers disabled, zu dem Bootverhalten kann ich jetzt nichts genaues sagen, erst eventuell wieder am WE, da der Server im Dauer-Produktivbetrieb ist.
    Dienstag, 18. März 2014 15:22
  • Hab einen Artikel von Microsoft gefunden, uin dem steht, dass ABE schuld ist.

    Nur ist der Artikel über Windows 7 und Windows Server 2008 R2.

    Das ist aber genau unser Problem, nur dass wir eben nen 2012-Server haben. Gibt's da auch ein Hotfix?

    Haben nämlich gerade eben mal ABE deaktiviert, und sofort war die CPU unten, mit eingeschaltetem ABE ist die CPU sofort wieder hoch auf 100%. Also scheint es das tatsächlich zu sein.

    ABE brauchen wir aber unbedingt.

    Mittwoch, 19. März 2014 15:23
  • Die KB dazu ist 2920591.
    Donnerstag, 20. März 2014 06:30
  • Problem ist behoben, lag tatsächlich an einem Share mit zig Unterordnern und tausenden Dateien darin, bei welchem ABE aktiviert war, nachdem ABE da deaktiviert wurde ist die CPU-Auslastung da wieder dauerhaft bei 1%.

    Dankeschön!

    • Als Antwort markiert Alex Pitulice Dienstag, 25. März 2014 09:38
    Donnerstag, 20. März 2014 14:00
  • Hi,
    das Thema ist zwar schon gegessen aber es gibt einen Hotfix zu dem Thema:
    http://support.microsoft.com/kb/2732618/en-us

    Gruß
    Lennart

    Dienstag, 1. April 2014 12:45