none
Windows Server 2008R2 - 2 Netzwerkkarten - Routing RRS feed

  • Allgemeine Diskussion

  • Hallo,

    kann mir jemand sagen wo mein Fehler bei folgender Konfiguration liegt.

    Ich habe einen Windows 2008 R2 Server mit zwei Netzwerkkarten.

    erste Karte:

    10.0.0.1/24

    GW: 10.0.0.254

     

    zweite Karte:

    192.168.0.1/24

     

    Routing und RAS ist installiert und LAN-Routing aktiviert.

    Von einem Host im 192.168.0.0/24 Netz kann ich die 10.0.0.1 erreichen, allerdings keinen anderen Host aus dem Netz.

    Muss ich noch eine statische Route setzen (Server bzw. Host) um andere Hosts im 192.168.0.0/24 Netz zu erreichen oder was fehlt mir noch? Hatte schon einige Konfigurationen probiert, leider ohne Erfolg.

    Hab hier wohl einen Denkfehler.

     

    Herzlichen Dank,

    Grüße Petersen

    Montag, 11. Juli 2011 09:09

Alle Antworten

  • Hallo,

    also laut Design sollten schon einmal beide Karten KEIN Gateway haben.

    Das wäre zunächst der erste Schritt.

    >GW:10.0.0.254 

    Ist dieser Router ebenfall mit dem 192.168.0.0 Netzwerk verbunden?


    Montag, 11. Juli 2011 09:25
  • * Matthias Wolf (Mon, 11 Jul 2011 09:25:04 +0000)

    also laut Design sollten schon einmal beide Karten KEIN Gateway haben.

    Laut "Design" sollte maximal eine Karte ein Gateway haben.

    Das wäre zunächst der erste Schritt.

    Das hat doch nichts mit dem Problem zu tun.

    GW:10.0.0.254 

    Ist dieser Router ebenfall mit dem 192.168.0.0 Netzwerk verbunden?

    Wozu? Er hat doch schon einen Router zwischen 10.0.0.1/24 und 192.168.0.1/24: den Server.

    Thorsten

    Montag, 11. Juli 2011 16:28
  • * Petersen. _ (Mon, 11 Jul 2011 09:09:12 +0000)

    kann mir jemand sagen wo mein Fehler bei folgender Konfiguration
    liegt.

    Ich habe einen Windows 2008 R2 Server mit zwei Netzwerkkarten.

    erste Karte:

    10.0.0.1/24

    GW: 10.0.0.254

    zweite Karte:

    192.168.0.1/24

    Routing und RAS ist installiert und LAN-Routing aktiviert.

    Von einem Host im 192.168.0.0/24 Netz kann ich die 10.0.0.1 erreichen,
    allerdings keinen anderen Host aus dem Netz.

    Doch, das kannst du schon. Nur nicht umgekehrt.

    Muss ich noch eine statische Route setzen (Server bzw. Host) um andere
    Hosts im 192.168.0.0/24 Netz zu erreichen oder was fehlt mir noch?

    Eine Route für 192.168.0.0/24 -> 10.0.0.1/24 hast du ja offensichtlich schon (sonst könntest du nicht 10.0.0.1 erreichen). Sieht so aus, als ob die die Rueckroute vergessen hast.

    Thorsten

    Montag, 11. Juli 2011 16:39
  • Hi,

    poste doch mal ein ipconfig /all und ein route print.

    Dann schreib mal, welche Adresse du erreichen kannst und welche nicht. Wir der Rechner über die IP oder den Namen angesprochen ?


    Viele Grüße Carsten
    Montag, 11. Juli 2011 22:17
  • >Wozu? Er hat doch schon einen Router zwischen 10.0.0.1/24 und 192.168.0.1/24: den Server´

    Die Frage zielte darauf ab, ob er diesen überhaupt benötigt,
    wenn er ohnehin bereits einen Router hat.

    Dazu müsste man allerdings wissen, welches Netzwerkgerät die 10.0.0.254 ist
    und mit welchen Netzwerken dieses Verbunden ist.

    >also laut Design sollten schon einmal beide Karten KEIN Gateway haben.

    Das war zumindest mein Kenntnisstand den ich von Andreas Altermann hatte:

    http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/3726d8d7-3506-4b9c-a498-6cf685d2a9f7/ 

    Gibt es hier irgendwo offizielle Aussagen in der Technet?




    Dienstag, 12. Juli 2011 06:52
  • * Matthias Wolf (Tue, 12 Jul 2011 06:52:28 +0000)

    Wozu? Er hat doch schon einen Router zwischen 10.0.0.1/24 und
    192.168.0.1/24: den Server´

    Die Frage zielte darauf ab, ob er diesen überhaupt benötigt, wenn er
    ohnehin bereits einen Router hat.

    Nun, wenn du so fragst: höchstwahrscheinlich nicht. Den Router routen zu lassen ist immer die bessere Lösung.

    also laut Design sollten schon einmal beide Karten KEIN Gateway
    haben.

    Das war zumindest mein Kenntnisstand den ich von Andreas Altermann
    hatte:

    http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/3726d8d7-3506-4b9c-a498-6cf685d2a9f7/ 

    Das ist ja unglaublich: Eddy_2010 löscht das Default Gateway und kann deshalb nicht mehr ins Internet ("Wenn ich das Standardgateway auf dem Server entferne kommt kein Client und der Server selber auch nicht mehr ins Internet - ist ja auch so zu erwarten.")

    Andreas antwortet: "Hier hättest Du noch anstatt des GW eine Route am Server eintragen müssen (0.0.0.0 mask 0.0.0.0 gw 192.168.1.100 /Permanent)".

    "0.0.0.0 mask 0.0.0.0 gw 192.168.1.100" ist das Default Gateway (= die Default Gateway-Route).

    Gibt es hier irgendwo offizielle Aussagen in der Technet?

    a) Wenn eine Maschine kein Default Gateway hat, kommt sie nicht (direkt) ins Internet. Das glaubst du mir auch ohne Technet.

    b) Wenn eine Maschine kein Default Gateway hat und die Maschine routet, kommen auch die gerouteten Pakete nicht ins Internet. Das glaubst du mir hoffentlich auch ohne Technet.

    c) Eine Maschine braucht kein Default Gateway - entweder weil sie nicht ins Internet soll oder weil sie keinen direkten Zugang zum Internet haben soll (sondern zum Beispiel nur über einen Proxy). Dies ist aber völlig unabhängig davon, ob die Maschine routet.

    Thorsten  

    Dienstag, 12. Juli 2011 10:58
  • Hallo Thorsten,

     

    was mir damals in Erinnerung blieb, war:

    >ein Server der zwischen zwei Netzen routet, sollte vom Design her keine GW haben (auf beiden Nics)
    >Aber Dein Problem ist das Dein DSL-Router den Rückweg nicht ins 10.0.0.0/24 findet. Hier mußt Du
    >auf dem Router explizit eine Route ins 10er Netz eintragen.

    Aber: 

    >"0.0.0.0 mask 0.0.0.0 gw 192.168.1.100" ist das Default Gateway (= die Default Gateway-Route)

    Das hatte ich übersehen. Du hast natürlich recht, hiermit wird der gleiche Effekt erreicht.

    >a) Wenn eine Maschine kein Default Gateway hat, kommt sie nicht (direkt) ins Internet. Das glaubst du mir auch ohne Technet.
    >b) Wenn eine Maschine kein Default Gateway hat und die Maschine routet, kommen auch die gerouteten Pakete nicht ins Internet. Das glaubst du mir hoffentlich auch >ohne Technet.
    >c) Eine Maschine braucht kein Default Gateway - entweder weil sie nicht ins Internet soll oder weil sie keinendirekten Zugang zum Internet haben soll (sondern zum >Beispiel nur über einen Proxy). Dies ist aber völlig unabhängig davon, ob die Maschine routet.

    Danke, das die Clients auch ins Internet kommen sollen, hatte ich bei meinen Überlegungen völlig außer acht gelassen.

     


    Dienstag, 12. Juli 2011 14:29
  • * Matthias Wolf (Tue, 12 Jul 2011 14:29:40 +0000)

    "0.0.0.0 mask 0.0.0.0 gw 192.168.1.100" ist das Default Gateway (=
    die Default Gateway-Route)

    Das hatte ich übersehen. Du hast natürlich recht, hiermit wird der
    gleiche Effekt erreicht.

    Nicht nur der gleiche Effekt. Das Setzen des Default-Gateways über die GUI setzt genau diese Route, das ist ja der Witz.

    Thorsten

    Dienstag, 12. Juli 2011 15:36