none
Windows Server 2012 R2 RemoteDesktopSitzungshost - Bildaufbau ruckelt... RRS feed

  • Frage

  • Hallo zusammen,

    ich habe ein Performance-Thema und suche nach einer Lösung aus Mangel an weiteren Ideen...

    Folgende Umgebung:

    - Hyper-V-Host unter Windows Server 2012 R2 auf Basis HP ProLiant DL380 Gen 8
    - Der Host verfügt über folgende Ausstattung:
       > 2x Intel Xeon E5-2630v2 mit jeweils 6 Kernen
       > 80 GB RAM
       > RAID I aus 4 x SATA HDD
       > 2 TB Nettospeicherkapazität

    Auf dem Host laufen 3 VMs, die betreffende VM in Generation II.
    Die 3 VMs nutzen in der maximalen Summe 72 GB RAM.

    Die betreffende VM hat 16 GB RAM und 8 virtuelle Prozessoren zugewiesen bekommen und läuft mit der konfigurierten Rolle "Remotedesktopdienste".
    Auf dem Terminalserver arbeiten im Schnitt 4-5 Personen, welche im "Normalbetrieb" ca. 15 % der CPU- und ca. 30 % der RAM-Ressourcen innerhalb der VM verwenden.
    In der Summe aller drei VMs wurden 36 virtuelle CPUs zugewiesen.

    Die betreffende VM ist über einen externen, nicht geteilten virtuellen Switch, der auch von den anderen beiden VMs genutzt wird, über 1 GBit/s NIC mit einem HP ProCurve 2530 an einem der beiden Gig-Ports verbunden.
    Der Hyper-V-Host nutzt als Management Interface den anderen der beiden 1 GBit/s Ports des Switchs.

    Alle Server sowie alle Clients laufen in der AD-Gesamtstrukturdomäne.

    In einem Benchmark durch den Anbieter eines Fachverfahrens, welche auf dem betreffenden Server läuft und mit einem SQL-Server (weiter VM) kommuniziert, konnten keinerlei Unauffälligkeiten beobachten werden.

    Bei allen Clients sind in der Registerkarte "Leistung" der Punkt ausgewählt: "Verbindungsqualität automatisch erkennen".

    Problembeschreibung:

    Der Kunde klagt über deutliche Reaktionszeiten beim Bildaufbau über RDP, gemessen an einer PDF, die Grafiken enthält und die lokal ausgeführt einfach super schnell angezeigt wird.
    Dabei ist es unerheblich, an welchem Client der Kunde die "Test"-PDF über PDF aufruft.

    >>> Ergo, die lokale Grafikkarte fällt für mich als Ursache weg.

    In einer anderen Umgebung hatten wir eine ähnliche Situation, aber da waren es Linux-Kisten, die RDP nutzten. Die Probleme hatten wir nie lösen können - die Clients wurden gegen Windows Maschinen ausgetauscht... :-(

    Was wurde bisher versucht:

    - Ich habe die CPU und RAM Zuweisung des Terminalservers verändert und wieder in den Zustand zurück konfiguriert, wie er hier beschrieben ist (ohne Erfolg)
    - ich habe die Leistung im RDP-Client für die Verbindung reduziert (ohne Erfolg)
    - Speed und Duplex-Einstellungen im Hyper-V-Host und auf der Portseite des Switches auf Auto-1000 geändert (ohne Erfolg)

    Fragen:

    - Wo habe ich nach der Beschreibung zur Folge einen Bock drinne, der die Performanceproblematik verursacht?
    - welche Stellschrauben sollte ich drehen, damit die Bildübertragung wieder flott ist?

    Hat dazu jemand eine Idee?

    Vielen Dank für eure Unterstützung...


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;




    • Bearbeitet H.Haas Montag, 20. Juni 2016 12:37
    Montag, 20. Juni 2016 12:26

Antworten

  • Hi,

    Meines Wissens nach sind die Grenzen der CPU Zuweisung an die VMs seit Windows Server 2012 R2 gänzlich weggefallen (OK, zu viel ist zu viel)

    Das ist auch richtig, bei 2008 R2 waren es noch Verhältnisse von 4:1 oder 8:1 (vCPU:LP) und mit 2012 fallen diese overcommit Festgrenzen. Es sollte verträglich überbucht werden.

    Ich würde in Deinem Fall ein Perfmon Monitoring starten und auch die Integrationsdienste prüfen hinsichtlich
    der synthetischen Treiber. Hinzu kommt, dass eine SATA Konfiguration im RAID 1 möglicherweise nicht die nötigen IOPS
    liefern kann. Diskspd ist Dein Freund.

    Add: Es gibt natürlich einige Offload-Schalter, doch vorab prüfe die C-States:

    https://blogs.technet.microsoft.com/virtualpfe/2012/09/14/hyper-v-and-bios-power-plans-c-states/

    Gruß,
    Marcel


    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.



    Montag, 20. Juni 2016 14:55

Alle Antworten

  • Moin, erstens hast Du ein CPU Overcommitment auf dem Host, was sicherlich nicht hilfreich ist. Du hast 24 Threads, daher sollten die VMs in Summe nicht mehr als 22 vCPUs haben. Zweitens ist die PDF-Wiedergabe extrem von der eingesetzten Acrobat-Version abhängig. Ich würde wie folgt vorgehen: 1. Selben Patchstand Server+Acrobat auf irgendeinem Blech installieren und schauen, ob ich über RDP die gleichen Probleme habe. Falls ja, mit der Acrobat-Version experimentieren und in der dortigen KB nach Optimierungs-Tipps schauen. 2. Wenn es auf Blech geht, die Ressourcen für den TS testweise komplett reservieren. Wenn das hilft, Overcommitment beseitigen und auf die Performance Counter (Host und Gast) schauen. 3. Ergebnisse wieder hier posten.

    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Montag, 20. Juni 2016 12:53
  • Moin...

    Meines Wissens nach sind die Grenzen der CPU Zuweisung an die VMs seit Windows Server 2012 R2 gänzlich weggefallen (OK, zu viel ist zu viel)

    Eine weiteres Blech liegt halt nicht vor...

    Sorry der Nachfrage: Wie kommst du auf die 24 Threads?

    Ich werde erst mal die Anzahl der vCPUs anpassen, die Ressourcen reservieren und einen anderen PDF Reader testen.

    Ich poste die Ergebnisse, was aber sicher etwas dauern wird.


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    Montag, 20. Juni 2016 13:35
  • Moin, Nein, CPU Scheduling hat niemand abgeschafft. In der wohlwollenden Annahme, dass auf dem Host HyperThreading aktiviert ist, hat Du 2(Sockets) x 2(HT) x 6(Cores per Socket) = 24x (virtuelle Cores).

    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Montag, 20. Juni 2016 14:19
  • Hi,

    Meines Wissens nach sind die Grenzen der CPU Zuweisung an die VMs seit Windows Server 2012 R2 gänzlich weggefallen (OK, zu viel ist zu viel)

    Das ist auch richtig, bei 2008 R2 waren es noch Verhältnisse von 4:1 oder 8:1 (vCPU:LP) und mit 2012 fallen diese overcommit Festgrenzen. Es sollte verträglich überbucht werden.

    Ich würde in Deinem Fall ein Perfmon Monitoring starten und auch die Integrationsdienste prüfen hinsichtlich
    der synthetischen Treiber. Hinzu kommt, dass eine SATA Konfiguration im RAID 1 möglicherweise nicht die nötigen IOPS
    liefern kann. Diskspd ist Dein Freund.

    Add: Es gibt natürlich einige Offload-Schalter, doch vorab prüfe die C-States:

    https://blogs.technet.microsoft.com/virtualpfe/2012/09/14/hyper-v-and-bios-power-plans-c-states/

    Gruß,
    Marcel


    https://www.windowspro.de/marcel-kueppers

    I write here only in private interest

    Disclaimer: This posting is provided AS IS with no warranties or guarantees, and confers no rights.



    Montag, 20. Juni 2016 14:55
  • Hallo zusammen,

    ich denke, der Thread kann geschlossen und als gelöst angesehen werden.

    Zwar waren die C-States so eingestellt, wie es im Link des Beitrages von Marcel empfohlen war, jedoch brachte die Option "Maximum Performance" in dem HP Power Profile einen entsprechenden Zuwachs an Performance, die den Kunden zufriedenstellte.


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    • Als Antwort markiert H.Haas Dienstag, 12. Juli 2016 04:28
    • Tag als Antwort aufgehoben H.Haas Dienstag, 12. Juli 2016 06:29
    Dienstag, 12. Juli 2016 04:28
  • Hallo Herr Haas, wenn ihnen die Antwort von Marcel geholfen hat und auch die Lösung war, dann würde ich sie bitten diese auch zu markieren. Sich selbst als antwort zu fragensteller auch als antwortgeber zu markieren ist äußerst unfair gegenüber dem eigentlichen antwortgeber.


    Kind regards, Flo

    Dienstag, 12. Juli 2016 05:53
  • kein Thema...

    Es liegt mir fern, mich hier zu profilieren bzw. meine Punkte durch Eigenantworten zu erhöhen.

    Die Antwort von Marcel wurde natürlich als Antwort markiert.

    Ich bin froh, dass mir hier geholfen wurde...

    Danke für den Hinweis.


    Mit freundlichem Gruss - Harald Haas - MCSE Server Infrastructure 2012; MCTS Exchange Server 2010 Configuration;

    Dienstag, 12. Juli 2016 06:30
  • Es liegt mir fern, mich hier zu profilieren bzw. meine Punkte durch Eigenantworten zu erhöhen.


    Für das Markieren der eigenen Antwort gibt es keine Punkte.

    Evgenij Smirnov

    msg services ag, Berlin -> http://www.msg-services.de
    my personal blog (mostly German) -> http://it-pro-berlin.de
    Windows Server User Group, Berlin -> http://www.winsvr-berlin.de
    Mark Minasi Technical Forum, reloaded -> http://newforum.minasi.com

    In theory, there is no difference between theory and practice. In practice, there is.

    Dienstag, 12. Juli 2016 06:31