locked
Windows XP Automatische Updates nicht startbar RRS feed

  • Frage

  • Hallo,

    Problem:
    auf einem Client (Windows XP SP3) einer Windows-2003-Domäne mit WSUS-Server (3.0 SP2) lässt sich der Automatische-Update-Dienst nicht mehr starten. Der Dienst steht auf automatisch, läuft aber nicht. Startet man ihn manuell, dann erscheint die Meldung:
    Fehler 0x80070005 Zugriff verweigert.

    Prinzipiell würde ich die Kiste neu aufsetzen, aber dort ist sehr spezielle Software installiert und eingerichtet, was einen großen Aufwand bei einer Neuinstallation bedeuten würde. Windows ist topaktuell (im Bezug auf Patches), bis auf ein Update von vor einigen Tagen. Wuauclt /detectnow oder wuauclt /reportnow bringt auch nichts, nicht mal einen Bericht.

    Was ich schon getan habe:
    Komponenten über Microsoft Windows Update-Webseite registrieren lassen (siehe unten), Komponenten manuell (cmd) registriert, verschiedene Berechtigungen in Regedit gesetzt (Standardrechte nach unten vererbt), Ordner "SoftwareDistribution" und "CatRoot2" neu erstellen lassen.

    Analyseprotokolle:
    Auf der Microsoft Windows Update Seite (aufgerufen über den Browser - Extras - Windows Update) erscheint der Hinweis "Die gewünschte Seite kann nicht angezeigt werden, da auf der Website ein Problem aufgetreten ist. Mit den folgenden Optionen kann das Problem möglicherweise behoben werden. (0x80070005)".
    Vorher erschien die Meldung, es müssen Komponenten registriert werden (was man über die Webseite reparieren könne). Das habe ich getan und danach neu gestartet.

    Das Microsoft Genuine Advantage Diagnostic Tool spuckt folgende Informationen aus:
    Diagnostic Report (1.9.0011.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A
    Windows Product Key: *****-*****-XFYGJ-QH9FF-C7QX6
    Windows Product Key Hash: OjEvSU4oYNIoJ2iLrbyb2bhBx7o=
    Windows Product ID: 76497-OEM-2260614-45278
    Windows Product ID Type: 3
    Windows License Type: OEM System Builder
    Windows OS version: 5.1.2600.2.00010100.3.0.pro
    ID: {F09E2B80-3276-4A2A-868F-01121C0EE342}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: Registered, 1.9.40.0
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic: 025D1FF3-230-1
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A
    Version: N/A

    WGA Notifications Data-->
    Cached Result: 0
    File Exists: Yes
    Version: 1.9.40.0
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 100 Genuine
    Microsoft Office Small Business Edition 2003 - 119 Cryptographics Error
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 77F760FE-153-80070002_7E90FEE8-175-80070002_025D1FF3-230-1

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Programme\Internet Explorer\IEXPLORE.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{F09E2B80-3276-4A2A-868F-01121C0EE342}</UGUID><Version>1.9.0011.0</Version><OS>5.1.2600.2.00010100.3.0.pro</OS><Architecture>x32</Architecture><PKey>*****-*****-*****-*****-C7QX6</PKey><PID>76497-OEM-2260614-45278</PID><PIDType>3</PIDType><SID>S-1-5-21-4186351856-1059056517-275720292</SID><SYSTEM><Manufacturer>MAXDATA</Manufacturer><Model>*</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>1002.002</Version><SMBIOSVersion major="2" minor="3"/><Date>20050628000000.000000+000</Date><SLPBIOS>MAXDATA,MAXDATA</SLPBIOS></BIOS><HWID>039130EF0184226D</HWID><UserLCID>0407</UserLCID><SystemLCID>0407</SystemLCID><TimeZone>Westeuropäische Normalzeit(GMT+01:00)</TimeZone><iJoin>1</iJoin><SBID><stat>2</stat><msppid></msppid><name>MAXDATA</name><model></model></SBID><OEM/><GANotification><File Name="WgaTray.exe" Version="1.9.40.0"/><File Name="WgaLogon.dll" Version="1.9.40.0"/></GANotification></MachineData><Software><Office><Result>100</Result><Products><Product GUID="{91CA0407-6000-11D3-8CFE-0150048383C9}"><LegitResult>119</LegitResult><Name>Microsoft Office Small Business Edition 2003</Name><Ver>11</Ver><Val>27199CCD8D28724</Val><Hash>EjssCZ/JG+UYChK5AcqJg12Qoiw=</Hash><Pid>72874-OEM-5691412-11415</Pid><PidType>6</PidType></Product></Products><Applications><App Id="16" Version="11" Result="100"/><App Id="18" Version="11" Result="100"/><App Id="19" Version="11" Result="100"/><App Id="1A" Version="11" Result="100"/><App Id="1B" Version="11" Result="100"/></Applications></Office></Software></GenuineResults> 

    Licensing Data-->
    N/A

    HWID Data-->
    N/A

    OEM Activation 1.0 Data-->
    BIOS string matches: yes
    Marker string from BIOS: 1058B:MAXDATA AG
    Marker string from OEMBIOS.DAT: MAXDATA,MAXDATA

    OEM Activation 2.0 Data-->
    N/A

    Die WindowsUpdate.log spuckt folgendes aus:
    2009-08-27 10:13:02:935 2156 168 Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:13:02:935 2156 168 Misc   = Process: C:\WINDOWS\System32\svchost.exe
    2009-08-27 10:13:02:935 2156 168 Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2009-08-27 10:13:02:935 2156 168 Service *************
    2009-08-27 10:13:02:951 2156 168 Service ** START **  Service: Service startup
    2009-08-27 10:13:02:951 2156 168 Service *********
    2009-08-27 10:13:02:951 2156 168 Setup FATAL: ProcessDelayedCopies failed: 0x80070005
    2009-08-27 10:13:02:951 2156 168 Service FATAL: Failed to fix up registration at service startup: 0x80070005
    2009-08-27 10:13:02:951 2156 168 Service *********
    2009-08-27 10:13:02:951 2156 168 Service **  END  **  Service: Service exit [Exit code = 0x80070005]
    2009-08-27 10:13:02:951 2156 168 Service *************
    2009-08-27 10:13:07:263 2156 2a8 Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:13:07:263 2156 2a8 Misc   = Process: C:\WINDOWS\System32\svchost.exe
    2009-08-27 10:13:07:263 2156 2a8 Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2009-08-27 10:13:07:263 2156 2a8 Service *************
    2009-08-27 10:13:07:263 2156 2a8 Service ** START **  Service: Service startup
    2009-08-27 10:13:07:263 2156 2a8 Service *********
    2009-08-27 10:13:07:263 2156 2a8 Setup FATAL: ProcessDelayedCopies failed: 0x80070005
    2009-08-27 10:13:07:263 2156 2a8 Service FATAL: Failed to fix up registration at service startup: 0x80070005
    2009-08-27 10:13:07:263 2156 2a8 Service *********
    2009-08-27 10:13:07:263 2156 2a8 Service **  END  **  Service: Service exit [Exit code = 0x80070005]
    2009-08-27 10:13:07:263 2156 2a8 Service *************
    2009-08-27 10:24:50:605  716 c04 Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:24:50:605  716 c04 Misc   = Process: \??\C:\WINDOWS\system32\winlogon.exe
    2009-08-27 10:24:50:605  716 c04 Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2009-08-27 10:24:50:605  716 c04 Shutdwn FATAL: WUAutoUpdateAtShutdown failed, hr=80240FFF
    2009-08-27 10:23:52:093 1144 67c Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:23:52:093 1144 67c Misc   = Process: C:\WINDOWS\system32\svchost.exe
    2009-08-27 10:23:52:093 1144 67c Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2009-08-27 10:23:52:093 1144 67c Service *************
    2009-08-27 10:23:52:093 1144 67c Service ** START **  Service: Service startup
    2009-08-27 10:23:52:093 1144 67c Service *********
    2009-08-27 10:23:52:187 1144 67c Setup FATAL: ProcessDelayedCopies failed: 0x80070005
    2009-08-27 10:23:52:187 1144 67c Service FATAL: Failed to fix up registration at service startup: 0x80070005
    2009-08-27 10:23:52:203 1144 67c Service *********
    2009-08-27 10:23:52:203 1144 67c Service **  END  **  Service: Service exit [Exit code = 0x80070005]
    2009-08-27 10:23:52:203 1144 67c Service *************
    2009-08-27 10:41:37:834 1320 68c Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:41:37:884 1320 68c Misc   = Process: C:\Programme\Microsoft Baseline Security Analyzer\mbsa.exe
    2009-08-27 10:41:37:884 1320 68c Misc   = Module: C:\WINDOWS\system32\WUAPI.DLL
    2009-08-27 10:41:37:834 1320 68c COMAPI -------------
    2009-08-27 10:41:37:884 1320 68c COMAPI -- START --  COMAPI: Search [ClientId = MBSA]
    2009-08-27 10:41:37:900 1320 68c COMAPI ---------
    2009-08-27 10:41:39:091 1144 a98 Misc ===========  Logging initialized (build: 7.1.6001.65, tz: +0200)  ===========
    2009-08-27 10:41:39:091 1144 a98 Misc   = Process: C:\WINDOWS\system32\svchost.exe
    2009-08-27 10:41:39:091 1144 a98 Misc   = Module: C:\WINDOWS\system32\wuaueng.dll
    2009-08-27 10:41:39:091 1144 a98 Service *************
    2009-08-27 10:41:39:091 1144 a98 Service ** START **  Service: Service startup
    2009-08-27 10:41:39:091 1144 a98 Service *********
    2009-08-27 10:41:39:157 1144 a98 Setup FATAL: ProcessDelayedCopies failed: 0x80070005
    2009-08-27 10:41:39:157 1144 a98 Service FATAL: Failed to fix up registration at service startup: 0x80070005
    2009-08-27 10:41:39:157 1144 a98 Service *********
    2009-08-27 10:41:39:157 1144 a98 Service **  END  **  Service: Service exit [Exit code = 0x80070005]
    2009-08-27 10:41:39:157 1144 a98 Service *************
    2009-08-27 10:42:09:656 1320 68c COMAPI FATAL: Unable to connect to the service (hr=80080005)
    2009-08-27 10:42:09:656 1320 68c COMAPI WARNING: Unable to establish connection to the service. (hr=80080005)
    2009-08-27 10:42:09:656 1320 68c COMAPI   - WARNING: Exit code = 0x80080005
    2009-08-27 10:42:09:656 1320 68c COMAPI ---------
    2009-08-27 10:42:09:656 1320 68c COMAPI --  END  --  COMAPI: Search [ClientId = <NULL>]
    2009-08-27 10:42:09:656 1320 68c COMAPI -------------
    2009-08-27 10:42:09:656 1320 68c COMAPI FATAL: Unable to perform synchronous search. (hr=80080005)

    In der Ereignisanzeige habe ich DCOM-Fehler:
    "Der Server "{E60687F7-01A1-40AA-86AC-DB1CBF673334}" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden.Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp." (Ereigniskennung 10010)

    und Service Control Manager Fehler:
    "Der Dienst "Automatische Updates" wurde mit folgendem Fehler beendet: Allgemeiner "Zugriff verweigert"-Fehler. Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp." (Ereigniskennung 7023)




    Hab schon viele Foren durchblättert, aber noch keine guten Anhaltspunkte gefunden.
    Prinzipiell sieht es immer wie ein Zugriffsproblem aus, aber weshalb?
    Die Komponenten scheinen registriert, der WSUS ist verfügbar, ich bin als Admin angemeldet.

    Hat jemand Anhaltspunkte?


    Ich wünsche allen einen schönen Tag,
    der Admin aus dem Souterrain

    Donnerstag, 27. August 2009 09:19

Alle Antworten