none
Exchange 2019 - OUTLOOK-Sync Postfachmigration RRS feed

  • Frage

  • Hallo Leute,
    ich habe mal wieder eine etwas ratlose Frage.

    Ich bin an der Postfachmigration von Exchange 2013 auf 2019 dran. Es ist eine recht große Umgebung bei der viele externe Kunden ihre Postfächer bei uns hosten.
    Im Feld ist Clienttechnisch alles von O365 bis 2010 vorhanden. Alles was noch älter ist wird einfach nicht mehr bedient!

    Soweit funktioniert auch alles recht reibungslos und zügig nur habe ich das Problem das bei einigen Postfächern nach der Migration der Abwesenheitsasistent und die Postfachgröße nicht richtig angezeigt bzw. bei Abwesenheitsassistent das Fenster nicht aufgeht und die Fehlermeldung (siehe Screenshoot) erscheint.

    Abwesenheitsassistent

    Es gibt da auch keinen erkennbaren Zusammenhang für mich zwischen der Anzeige der Postfachgröße und den Abwesenheitsassistenten. Es kann mal beides nicht passen oder eben das eine oder das andere nicht. Das ganze normalisiert sich dann über einen Zeitraum von 5 Min bis 8 Std wieder und dann funktioniert das alles wieder ganz normal ohne Zutun. Das lustige ist das es beim selben Kunden beispielsweise bei 2 Postfächern sofort alles funktioniert und bei 5 weiteren dann nicht oder nur teilweise. Die restlichen Funktionalitäten wie Mails senden und empfangen, Kalender, Adressbücher, etc. funktionieren immer alle.

    FRAGE:
    Ich vermutete, dass es ein Cache auf dem Outlookclient gibt der sich nach einer gewissen Zeit aktualisiert, jedoch ist es so dass dieses Problem mitwandert. Sprich wenn ich auf einem total anderen Client den selben User einrichte bekomme ich das selbe Fehlerbild. Im OWA funktioniert der Abwesenheitsassistent sofort. Somit scheint mir das Problem dann doch auf dem Exchange zu sein, nur wo? Bei dem Moverequest Statistic bekomme ich eine 100% completed zurück was mir vermittelt das die Migration vollständig abgeschlossen ist. Ich habe dann auch schon mal einen sync bei den DC´s angeworfen da ich da ein syncproblem vermutete. Hat hier irgendjemand die selben Erfahrungen gemacht oder eine Idee und weiß vielleicht wo hier das Problem ist oder wo ich da hinschauen kann? Im Idealfall auch eine Lösung hat wie man hier eingreifen kann und das gleich bereinigt? Gibt es irgendwo auf dem Postfachinfos (get-Mailbox) einen Hinweis auf mein Problem den ich einfach nicht sehe?

    Ich habe noch ein paar sehr komplizierte Kunden in der Pipeline denen ich nicht sagen möchte das sie einfach geduldig sein müssen und warten müssen bis eine Selbst Heilung eintritt.

    Ich hoffe ihr habt genug Infos. Ansonsten bitte einfach noch kurz melden, wenn etwas fehlt.

    Gruss
    Joschy

    Mittwoch, 30. September 2020 10:31

Alle Antworten

  • Moin,

    die von Dir beobachteten Phänomene sind Autodiscover-Phänomene. Bei Massenmigrationen wird daher gern auf den Postfachservern in regelmäßigen Abständen der IIS-AppPool für Autodiscover recycelt. Kombiniert mit dem beherzten Löschen der Autodiscover Cache-XML-datei auf den Clients, kann man solche Phänomene in der Regel wirkungsvoll bekämpfen :-)


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Mittwoch, 30. September 2020 11:30
  • Hallo Evgenij

    Verstehe!!!! Sehr gut,... das ist ja immerhin ein Ansatz. Das werde ich gleich mal testen.

    Vielen dank schon mal im Voraus.  Wie sicher bist du dir bei dieser Information? Vermutest du das oder ist das so? kann man das In dem Autodiscover.xml irgendwo sehen? 

    Kannst du mir dann auch erklären warum die Postfachgröße dann sich auf einmal reguliert, der Abwesenheitsassistent dann aber nicht? Der Client wird doch nicht nur teile der XML erneuern, oder doch? 


    Mittwoch, 30. September 2020 11:37
  • Moin,

    wenn Du Garantien willst, mach ein Ticket bei Microsoft auf. In ein paar Monaten hast Du dann eine belastbare Aussage.

    Ich kann nur aus Erfahrung sprechen. Die App Pools sind wichtiger als die Client-XML, denn sie cachen die tatsächlichen Informationen über die Mailboxen, die XML hingegen nur die URLs der Autodiscover-Endpunkte plus ein paar grundlegende Infos.


    Evgenij Smirnov

    http://evgenij.smirnov.de

    Mittwoch, 30. September 2020 11:43
  • Garantie brauche ich keine,... ;)

    Ich habe es aber gerade ausprobiert und den Autodiscover pool recycle mehrfach durchgeschossen und auch beim Client die Autodiscover xml löschen lassen,... Outlook neustart hat aber leider nichts gebracht.

    Hast du vielleicht noch was wo dir einfällt oder vielleicht sonst noch jemandem?

    SG

    Joschy

    Mittwoch, 30. September 2020 12:21