none
Speicherauslastung W2k8R2 Fileserver RRS feed

  • Frage

  • Hallo,

    wir haben seit ein paar Tagen den Fileserver auf W2k8R2 umgezogen. Der Server läuft wie zuvor als virtuelle Maschine auf VMWare. Er macht nur Fileablage und sonst nichts! Außer einem Virenscanner ist nichts installiert!
    Der Server hat "physikalisch" 8 GB zugewiesen bekommen und benutzt diese auch prompt, ohne das ersichtlich ist, was den RAM belegt. Weder im Taskmanager noch im Processexplorer komme ich annähernd auf die 8GB wenn ich den RAM-Bedarf der einzelnen Prozesse zusammenrechne. Selbst im VMWare zeigt er mir nur ca. 4GB an.

    Hat jemand eine Idee was das sein könnte und wie man den RAMVerbrauch aufschlüsseln kann, so das man den Verursacher erkennt?

    Danke!

    Montag, 31. Oktober 2011 08:40

Antworten

  • Hallo,

    die Ursache war VMWare, bzw. der, der die Einstellungen darin vorgenommen hat!

    Mit RAMMap konnte man feststellen, dass irgend ein Driver konstant 8GB belegt hatte. Wenn man im VMWare in der Performance die RAM Belegung kontrollierte, sah man, dass genau diese 8GB RAM balloned wurden.

    Ursache war in den RAM Einstellungen unter Resourcen, dass der Haken unbegrenzt nicht aktiviert war, sondern ein Grenzwert von 4GB gesetzt war. Das bewirkt, das der Node nur 4GB verwenden darf und der darüber hinausgehende Werte wird von VMWare balloned. 

    Danke für eure Unterstützung!

     

    Freitag, 11. November 2011 07:06

Alle Antworten

  • Sysinternals: RAMMap und VMMap. Dürfte aber nur NTFS-Caching sein...
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Montag, 31. Oktober 2011 08:51
  • Hallo,

    wie großt sind die Volumes auf denen die Daten liegen?

    Mach bitte einmal einen Screenshot vom "Ressourcenmonitor".

    Ich vermute, dass der größte Teil davon nur Cache ist.

    Schau dir bitte auch diesen aktuellen Betrag bei uns an:

    http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/thread/8eb67108-16d3-4525-a385-68e88d09ef4f

     


    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Montag, 31. Oktober 2011 08:54
  • Vielleicht hilft Dir auch das hier weiter:
     
    mfg Martin
     

    A bissle "Experience", a bissle GMV...
    Montag, 31. Oktober 2011 08:57
  • @Martin:

    Jo, 2mal hilft besser :)

    Aber es war wohl eine sehr knappe Überschneidung.


    MVP - Group Policy http://matthiaswolf.blogspot.com/
    Montag, 31. Oktober 2011 10:15
  • Hallo und danke!

    Im Perfmon zeigt er für den System Cache ca. 4 GB als belegt an. Von daher habt ihr wohl Recht mit eurer Vermutung.

    Anstatt den Regwert für die Dirty Caches hochzusetzen sollte doch auch das Erhöhen des RAMs zum Erfolg führen!? Ich werde das erstmal testen bevor ich die Regestry verbiege!

    Danke!

    Montag, 31. Oktober 2011 13:25
  • Hallo,

    hast Du es schon getestet? Haben die Tipps auch geholfen? Wenn ja, dann bitte auch die Antworten entsprechend markieren.

    Gruss,
    Raul

    Donnerstag, 3. November 2011 12:09
  • Ich teste es am Wochenende und melde mich dann selbstverständlich!
    Donnerstag, 3. November 2011 12:13
  • Hallo,

    ich habe am Wochenende den RAM des Servers um 8GB erweitert und nun hat er sich diesen Speicher auch noch genommen.
    Auffällig ist dabei nur, dass der Wert für Memory\System Cache Resident Bytes immer noch gleich hoch ist wie vor der RAM Erweiterung. Stellt sich die Frage wer nimmt sich den Rest des Speichers, wenn es der Cache nicht ist?

    Ich habe im Perfmon noch andere Werte eingefügt, die die RAM Verwendung anzeigen. Aber keiner der Werte zeigt eine solche Verwendung der fehlenden 8GB an.

    Ich werde nun doch mal die Regwerte verwenden.

    Montag, 7. November 2011 09:40
  • Hallo,

    die Ursache war VMWare, bzw. der, der die Einstellungen darin vorgenommen hat!

    Mit RAMMap konnte man feststellen, dass irgend ein Driver konstant 8GB belegt hatte. Wenn man im VMWare in der Performance die RAM Belegung kontrollierte, sah man, dass genau diese 8GB RAM balloned wurden.

    Ursache war in den RAM Einstellungen unter Resourcen, dass der Haken unbegrenzt nicht aktiviert war, sondern ein Grenzwert von 4GB gesetzt war. Das bewirkt, das der Node nur 4GB verwenden darf und der darüber hinausgehende Werte wird von VMWare balloned. 

    Danke für eure Unterstützung!

     

    Freitag, 11. November 2011 07:06
  • Hallo,

    danke dass Du uns die Lösung zurück gepostet hast.

    Gruss,
    Raul

    Freitag, 11. November 2011 14:38