none
Hyper-V Snapshot Problem RRS feed

  • Frage

  • DRINGEND brauch Hilfe!!!

    Erstmal zum System:
    Windows Server 2008 R2
    Datenträger C: 200GB (Hier liegt VHD der Partition C der VM)
    Datenträger D: 500GB ( Hier ... VHD der Partition E: der VM)
    VM: Win Server 2003

    Also ich versuche mal mein Problem so gut wie möglich zu schildern:

    Es sind im Laufe der Zeit mehrere Snapshots der VM erstellt worden, welche ich gestern löschen wollte. (....grrrr und auch getan habe)
    In der Hyper-V werden also keine Snapshots mehr angezeigt.
    Dadurch ist jetzt die Situation entstanden, das auf C: eine VHD-Datei mit ca. 103Gb, eine AVHD mit 11Gb und eine AVHD mit 84Gb liegt.
    Freier Speicher also nur noch ca 5Mb face-sad ((
    Die Hyper-V versucht nun permanent eine Zusammenführung und bleibt bei ca. 2% hängen. Nach meinem Verständniss muss die AVHD zuerst in die VHD integriert werden bevor die AVHD gelöscht wird. Oder lieg ich da falsch?
    Das Heisst also 103Gb+84Gb = 187Gb zzgl. der beiden AVHD Dateien die ja vorher nicht gelöscht werden können wesentlich mehr als 200Gb face-sad

    Lösungsansätze: Offline Merge der VHD & AVHD Dateien?
    Ich habe eine weitere Festplatte mit 278Gb zur Verfügung auf die ich die VHD und die AVHD Dateien kopiert habe. Ist es möglich die der VM zuzuweisen und dort zusammenzuführen?

    Des weiteren habe ich die VM auf eine externe Platte exportiert. Auf dieser sind jetzt die VHD von C und D aber ich weiss nicht, ob die Zusammenführung beim Export mit ausgeführt wurde.


    Bin wirklich um jeden Hinweis dankbar.



    PS: Sollte ich etwas vergessen haben bitte ich diese zu entschuldigen, da ich jetzt durchgehend seit 22Uhr gestern Abend hier an der Kiste sitze face-sad
    Freitag, 17. Dezember 2010 14:10

Antworten

  • Habe das Problem nun selber gelöst.

    1. Freie Platte in Hyper-V eingebunden.
    2. VHD und AVHD Dateien dort.hin kopiert.
    3. Dateien manuell zusammengeführt.
    4. VHD an Ursprungsort zurück kopiert.
    5. neu VM aufgesetzt und VHD zugewiesen.

    Funktioniert alles einwandfrei.
    Samstag, 18. Dezember 2010 16:25

Alle Antworten

  • Habe das Problem nun selber gelöst.

    1. Freie Platte in Hyper-V eingebunden.
    2. VHD und AVHD Dateien dort.hin kopiert.
    3. Dateien manuell zusammengeführt.
    4. VHD an Ursprungsort zurück kopiert.
    5. neu VM aufgesetzt und VHD zugewiesen.

    Funktioniert alles einwandfrei.
    Samstag, 18. Dezember 2010 16:25
  • Hi <realname please>,
     
    > Habe das Problem nun selber gelöst.
    >
    > 1. Freie Platte in Hyper-V eingebunden.
    > 2. VHD und AVHD Dateien dort.hin kopiert.
    > 3. Dateien manuell zusammengeführt.
    > 4. VHD an Ursprungsort zurück kopiert.
    > 5. neu VM aufgesetzt und VHD zugewiesen.
    >
    > Funktioniert alles einwandfrei.
     
    Danke für's Feedback.
     
    Und merke Dir für die Zukunft: KEINE manuellen Snapshots (in produktiven
    Umgebungen)!
     
    Wieso? Weil einfach zu viele Probleme damit entstehen können bzw. viele
    damit falsche Dinge tun..
     
    Wieso es dann Microsoft, VMware, Citrix usw. doch anbieten? Weil es eine
    technische Möglichkeit ist, jedoch manuelle Snapshots ausdrücklich nur für
    Testumgebungen und/oder nur von sehr versierten Fachpersonal verwendet
    werden sollten.
     
    S.a.:
     
    Hyper-V Virtual Machine Snapshots: FAQ
    http://technet.microsoft.com/en-us/library/dd560637.aspx
     
    Understanding virtual machine snapshots in VMware ESX
    http://kb.vmware.com/kb/1015180
     
    XenServer: Understanding Snapshots
    http://support.citrix.com/article/CTX122978
     
    --
    Tobias Redelberger
    StarNET Services (HomeOffice)
    Frankfurter Allee 193
    D-10365 Berlin
    Tel: +49 (30) 86 87 02 678
    Mobil: +49 (163) 84 74 421
    Email: T.Redelberger@starnet-services.net
    Web: http://www.starnet-services.net
     
     
     
    Montag, 27. Dezember 2010 10:15