none
Exchange 2010: Defekten Server entfernen RRS feed

  • Frage

  • Hallo zusammen,

    hier ist ein Exchange Server 2010 komplett ausgefallen (Hardwaredefekt). Da der alte Server schon vorher Probleme machte, soll dieser nicht wiederhergestellt werden, sondern ein komplett neuer Exchange-Server aufgebaut werden. Die EDB-Dateien der Mailbox- und Öffentlichem-Ordner-Datenbanken liegen komplett vor - wir können aus den EDB-Dateien PST-Dateien exportieren - es sind also keine wichtigen Daten verlorengegangen.

    Wie entfernt man den alten Exchange 2010 Server am besten komplett aus dem Active Directory? Der alte Exchange-Server läßt sich nicht mehr starten - eine normale Deinstallation scheidet also aus. Gibt es da einen Weg, der offiziell von Microsoft supported wird?

    Oder kann /sollte man den neuen Server in die alte, ja noch vorhandene Exchange/AD-Struktur integrieren? Falls ja - wie geht man da am besten vor?

    Grüße,

    Jörg Goldmann

    Freitag, 14. November 2014 05:30

Antworten

  • Hallo Jörg,

    der Tipp von Stefan arbeitet zwar, ist allerdings offiziell nicht supportet.

    Besser wäre m.E. eine neue Maschine mit gleichem Namen und gleicher IP aufzusetzten, geht auch als VM.

    1. Im AD das Konto für den Server zurücksetzen.

    2. Maschine mit gleichem Namen / IP ins AD aufnehmen

    3. komplett durchpatchen, Pre-Req erfüllen

    4. Exchange am administrativem CMD mit Setup.com /M:RecoverServer installieren
        - ACHTUNG - es muss exact das SP und RU aus der defekten Maschine verwendet werden!!!!

    5. Die Datenbanken Offline nehmen und die DB´s aus dem Backup unterschieben

    6. Vorhandenes Zertifikat installieren

    6. Neustart und alles ist gut.

    Das habe ich diverse Male erfolgreich durchgeführt.

    Vorteil ist u.a. das du keinen Client anfassen musst.

    Du wirst mit der Suchmaschine deiner Wahl noch diverse Anleitungen finden.

    Viel Erfolg!

    ;)


    Gruß Norbert

    Freitag, 14. November 2014 06:42
    Moderator

Alle Antworten

  • Hallo Jörg,

    vielleicht hilft dir dieser Link weiter.

    http://www.hertes.net/?p=1443

    Gruß
    Stefan


    st_fbg

    Freitag, 14. November 2014 06:14
  • Hallo Jörg,

    der Tipp von Stefan arbeitet zwar, ist allerdings offiziell nicht supportet.

    Besser wäre m.E. eine neue Maschine mit gleichem Namen und gleicher IP aufzusetzten, geht auch als VM.

    1. Im AD das Konto für den Server zurücksetzen.

    2. Maschine mit gleichem Namen / IP ins AD aufnehmen

    3. komplett durchpatchen, Pre-Req erfüllen

    4. Exchange am administrativem CMD mit Setup.com /M:RecoverServer installieren
        - ACHTUNG - es muss exact das SP und RU aus der defekten Maschine verwendet werden!!!!

    5. Die Datenbanken Offline nehmen und die DB´s aus dem Backup unterschieben

    6. Vorhandenes Zertifikat installieren

    6. Neustart und alles ist gut.

    Das habe ich diverse Male erfolgreich durchgeführt.

    Vorteil ist u.a. das du keinen Client anfassen musst.

    Du wirst mit der Suchmaschine deiner Wahl noch diverse Anleitungen finden.

    Viel Erfolg!

    ;)


    Gruß Norbert

    Freitag, 14. November 2014 06:42
    Moderator
  • Hallo Norbert, vielen Dank für die Info. Kann ich anhand eines AD-Eintrages oder anhand der Datenbank feststellen, welches SP / RU der alte Server hatte?

    Grüße,

    Jörg Goldmann

    Freitag, 14. November 2014 10:58
  • Hallo Jörg,

    wenn du die DB´s aus einer Datensicherung hast, vielleicht auch den Ordner \bin aus dem Exchange von C:?

    Wenn ja, hilft dir die Version der Store.exe, da bist du sicher, auch das richtige RU zu haben.

    Über das AD müsste es auch gehen, Yusuf hat mal geschrieben:
    http://blog.dikmenoglu.de/2011/01/die-ad-und-exchange-schemaversion-abfragen/

    ;)


    Gruß Norbert

    Freitag, 14. November 2014 15:07
    Moderator
  • Hallo,

    vielen Dank für die Hinweise und Hilfen. Ich habe den Server mit dem alten Namen erfolgreich neu aufgesetzt.

    Hier noch einmal eine etwas ausführlichere Auflistung der Schritte mit eigenen Ergänzugen, die bei unserem Recover aufgetreten sind.

    Defekten Exchange Server vom Netz nehmen. Das Active Directory muss noch intakt sein!

    Altes Exchange-Server Computerkonto zurücksetzen - falls nicht möglich, weil Konto z.B. DC war (war hier der Fall!), Computer-Konto löschen

    Neuen Windows Server aufsetzen (<= Windows-Version des alten Servers) - mit gleichem Name und gleicher IP-Adresse wie defekter Server in die Domäne aufnehmen

    Exchange 2010 Server mit gleichem Servicepack / Rollup installieren mit dem Kommando: setup.com /m:recoverserver

    Bei Problemen bei der Installation (Hub Transport Service, Berechtigungen etc.) liegt es oft daran (insbesondere, wenn man das alte Computerkonto löschen musste), dass das gerade neu aufgesetzte Server-Computerkonto noch  nicht genug Berechtigungen hat. Folgende Stellen im AD auf dem Domaincontroller prüfen:

    In der OU Microsoft Exchange Security Groups:

    Das Computerkonto des neuen Servers der Gruppe Exchange Servers zuordnen.

    Das Computerkonto des neuen Servers der Gruppe Exchange Trusted Subsystem zuordnen.

    Gruppenrichtlinien Default Domain Policy:

    Computerkonfiguration/Windows-Einstellungen/Sicherheitseinstellungen/Lokale Richtlinien/Zuweisen von Benutzerrechten/Verwalten von Überwachungs- und Sicherheitsprotokollen - hier Richtlinieneinstellungen definieren und dem Domänenadministrator und die Gruppe "Exchange Servers" hinzufügen.

    Powershell auf neuem Exchange-Server aufrufen:

    Set-ExecutionPolicy -executionpolicy unrestricted -scope localmachine Prüfen mit: get-executionPolicy –list :Lokale Maschine sollte auf "unrestricted" stehen.

    Sollte dies alles nicht ausreichen, von der Exchange 2010 Installations-DVD setup /preparedomain aufrufen.

    ACHTUNG: Nach jeder fehlgeschlagenen Installation in der Registry des neuen Exchange-Servers gesetzte Watermarks des Exchange-Setups entfernen:

    z.B. Regedit aufrufen:  HKLM\Software\Microsoft\ExchangeServer\V14\HubtransportRole - hier den Schlüssel "Watermark" entfernen und den Server neustarten.

    http://blogs.technet.com/b/exchange/archive/2007/05/21/3402900.aspx

    ACHTUNG: Soll nach einem fehlgeschlagenem setup.com /m:recoverserver ein DVD setup /preparedomain ausprobiert werden, an obigem Registry-Key auch den Eintrag ACTION löschen, Server neu starten, damit setup /preparedomain überhaupt durchläuft.

    Nach setup /preparedomain die Installation erneut mit setup.com /m:recoverserver starten.

    Nach nun hoffentlich erfolgreicher Installation des Exchange Server dem Server wieder die Original-Mailbox Databases / PublicFolder-Databases aus einem Backup inkl. LOG-Dateien unterschieben und den Informationsspeicher neu starten.

    Nach erfolgreicher Einbindung der Speicher Server neu starten und BPA durchlaufen lassen. Bei mir trat ein Problem mit dem PublicFolder-Standort-Ordner auf, welches so gelöst werden konnte:

    http://technet.microsoft.com/de-de/de/library/4a057fc7-fbaf-4863-9675-318d5d0139f0.aspx

    Zudem waren noch einigen Fehler in Zusammenhang mit dem Offline-Adressbuch zu lösen, die aber anhand einer Suche nach den Event-IDs recht schnell gelöst werden konnten.

    Ich hoffe, die Tipps helfen anderen bei einem ServerRecover - was ja nicht so oft vorkommt :-)

    Grüße,

    Jörg Goldmann

    Montag, 17. November 2014 17:22
  • Hallo Jörg,

    danke für die Rückmeldung.

    Ist ja im Wesentlichen das, was ich dir geschrieben habe.

    Als Anmerkung sei noch zu vermerken, das der Watermark in der Regel nicht entsteht und NUR auf Anweisung eines Microsoft Senior Engineers entfernt werden darf!

    Im Normalfall läuft das sauber durch, das habe ich bereits diverse Mal erfolgreich durchgeführt.

    Allerdings nehme ich nicht die Install-DVD sondern das jeweils passende, in einen Ordner entpackte Servicepack (Bereitstellung..) mit dem passenden RU im Upgrade-Ordner. Achtung, das geht nur bei Neu / Recover-Installationen!

    ;)


    Gruß Norbert

    Dienstag, 18. November 2014 13:42
    Moderator