none
Netzwerk fällt teilweise(!) aus nach EventLog ID 16002, Quelle AFD, nach KB4015217(?) RRS feed

  • Allgemeine Diskussion

  • Hallo,

    seit April friert regelmäßig nach etwa 13h bis 2 Tagen der Rechner ein, nachdem die Netzwerkverbindung teilweise gestört ist.
    Auffällig ist im EventLog ein Fehler mit der ID 16002, Quelle AFD. Die Treiber und Sicherheitspatches sind auf dem neuesten Stand. Es gibt weitere Benutzer mit ähnlichen Problemen. 

    In der Community wurden wir gebeten das Thema hier in TechNet anzusprechen.

    Der ursprüngliche Diskussionsfaden findet sich hier:

    https://answers.microsoft.com/de-de/windows/forum/windows_10-update/kb4015217/90a95447-8e17-45b6-9e9d-b25f2a2d38b5?rtAction=1494926627249

    Vielleicht ist das hier auch relevant oder ähnlich (aber XP).
    https://answers.microsoft.com/en-us/windows/forum/windows_xp-networking/afd-is-not-working-preventing-dhcp-from-working/2532dc30-9bc3-4ed8-a292-8f8097e8b3c6

    Ich habe kurz vor einem AFD-Fehler Side-by-Side Fehler und DCOM-Fehler:

    3x ID 33 im Zusammenhang mit "Assessment and Deployment Kit".

    ID 33, Quelle SideBySide: "Fehler beim Generieren des Aktivierungskontextes für "C:\Program Files (x86)\Windows Kits\8.1\Assessment and Deployment Kit\Windows Assessment Toolkit\Memory Assessments\arm\memoryfp.exe". Die abhängige Assemblierung "Microsoft.Windows.Common-Controls,language="*",processorArchitecture="arm",publicKeyToken="6595b64144ccf1df",type="win32",version="6.0.0.0"" konnte nicht gefunden werden. Verwenden Sie für eine detaillierte Diagnose das Programm "sxstrace.exe"."

    Weitere ID 33 mit Adobe-Programmen.

    ID 10010, Quelle DistributetCOM: "Der Server "{5DC4F9AD-3A2B-4DF4-AC39-3FF5A19FCF4C}" konnte innerhalb des angegebenen Zeitabschnitts mit DCOM nicht registriert werden."

    HCR\CLSID\{5DC4F9AD-3A2B-4DF4-AC39-3FF5A19FCF4C}
     Standard ShadowPlayServerClass
     AppID {5DC4F9AD-3A2B-4DF4-AC39-3FF5A19FCF4C}

    HLM\Softwar\Classes\CLSID\{5DC4F9AD-3A2B-4DF4-AC39-3FF5A19FCF4C}
     Standard ShadowPlayServerClass
     AppID {5DC4F9AD-3A2B-4DF4-AC39-3FF5A19FCF4C}
     LocalServer32
      Standard "C:\Program Files\NVIDIA Corporation\ShadowPlay\nvspcaps64.exe"
      ServerExecutable C:\Program Files\NVIDIA Corporation\ShadowPlay\nvspcaps64.exe
     Programmable
      Standard (nicht festgelegt)
     TypeLib
      Standard {BFBE7DEF-BD95-42B3-A0CD-7C05529B9CCB}
     Version
      Standard 1.0
     

    Sonst keine weiteren Einträge in der Registry.


    Mit freundlichen Grüßen

    Gerhard Gaußling





    Dienstag, 16. Mai 2017 16:15

Alle Antworten

  • Der letzte Fehler lässt sich wohl beheben, wir hatten eine Migration von einer Domain (HWGDOM) in eine andere (HWG):

    "Solved. Just go to C:\Program Files\NVIDIA Corporation\ShadowPlay\nvspcaps64.exe open proprieties and run as admin + give all the rights to your user " https://forums.geforce.com/default/topic/660632/geforce-experience/nvidia-1-8-1-0-crashing-windows-8-1/post/4060210/

    nvspcaps64v.dll fehlt aber, daher funktioniert nvspcaps64.exe auch nicht.

    Ich denke aber kaum, dass das in Verbindung mit den Netzwerkproblemen steht. Möglicherweise aber ein ähnlicher Fehler aufgrund der Domain-Migration?
    Donnerstag, 18. Mai 2017 08:17
  • Hallo zusammen,

    gibt es hier etwas neues von Microsoft-Seite?

    Der Fehler trat beginnend mit dem 24.4. am 25., 26., 28., 29. und 30. April, sowie am 1., 2., 4., 6., 7., 8., 11., 12., 13., 14., 17. Mai auf, seit dem nicht mehr.

    Ich habe versucht die anderen Fehler aus dem EventLog zum Anlass zu nehmen, um einige Probleme zu lösen. Ich habe zum Beispiel NVIDIA Geforce Experience deinstalliert, After Effects 5.5 und Windows ADK 8.1 wegen SideBySide Event-ID 33 deinstalliert und den iSCSI-Initiator-Treiber aus dem Gerätemanager entfernt und den Initiator-Dienst deaktiviert, weil ich nicht weiß, wie ich das ganz entfernen kann.

    Bei dem Versuch den iSCSI-Initiator-Treiber aus dem Gerätemanager zu entfernen, stürzte der Computer ab mit einem Memory.dmp DRIVER_POWER_STATE_FAILURE https://answers.microsoft.com/en-us/windows/forum/windows_10-desktop/driverpowerstatefailure-windows-10/d38b3306-f6fb-4a1c-a99a-79c78ff22868

    MEMORY.DMP    18.05.2017 14:42:56    DRIVER_POWER_STATE_FAILURE    0x0000009f    00000000`00000004    00000000`0000012c    ffffde06`dbd09640    ffff8a81`42f7c980                            x64                        C:\WINDOWS\MEMORY.DMP    4    15    14393    1.579.226.917    18.05.2017 14:43:57   

    Nach dem erzwungenen Reboot und einem weiteren initiierten reboot ging es dann irgendwann zu entfernen.

    Ich glaube fast, dass der AFD-Fehler mit dem iSCSI-Initiator zusammenhängen könnte. Vielleicht ist da beim Update von 7 auf 10 etwas falsch gelaufen?

    Vor dem Update fror der Rechner etwa alle viertel Jahre mal ein und störte dann den gesamten Netztwerkabschnitt und ich musste den Computer ausschalten und vom Netzt nehmen (Netzkabel ziehen) und den Switch resetten, damit der Teilbereich des Netzwerks wieder funktionierte.

    Die Netzwerkkarte/Treiber hatte also schon damals für Probleme gesorgt. Nach dem Update auf Windows 10 war Ruhe, bis es am 24. April mit dn AFD-Fehlern losging, etwas über eine Woche nachdem KB4015217 installiert wurde (danach wurden bis zum 24 weitere etwa 3 KBs installiert).

    Auffällig war beim AFD-Fehler zuerst, Fehler wie "No buffer space available" z.B. bei cygwin ssh oder auch anderen Anwendungen. Ein weiterer Fehler deutete daraufhin, dass keine weiteren Ports mehr bereitgestellt werden konnten (ephemeral ports), das erhöhte ich in der Registry aber ohne Erfolg. Dann stolperte ich über den Artikel von Lutz Wienecke zu KB4015217 in der Community. Dort wurden wir hierher zu TechNet verwiesen. Ich entdeckte darüber, dass der AFD-Fehler mit den Netzausfällen und dem Einfrieren des Rechners assoziiert ist.

    Möglicherweise störte also der iSCSI-Initiator, wahrscheinlich im Konflikt mit einem Sicherheitsupdate, vielleicht KB4015217 (danach hatte ich bis zum ersten Auftreten des Fehlers aber weitere Patches installiert). 

    Ich habe keinerlei Patches deinstalliert, aber den iSCSI Treiber aus dem Gerätemanager unter BSOD Ereignissen entfernt und den Initiator Dienst deaktiviert.

    Bislang handelt es sich um die längste Periode ohne Auftreten des AFD-Fehlers. Ich habe aber auch weitere Software, über die sich im EventLog beschwert wurde entfernt oder die zugrundeliegenden Fehler beseitigt.

    Ein SideBySide Fehler tritt aber auch mit dem HKL für Windows 10 auf, das ich neu installiert habe um den Memory.dmp oder ähnliche Dumps "analysieren" zu können, so weit mir das möglich erscheint.

    Am 16.05.2017 wurde als letzter Sicherheitspatch KB3150513 installiert. Aber danach, am 17.05. ereignete sich der letzte AFD-Fehler. Dieses letzte KB update brachte also keine Behebung des Fehlers.

    Der Status des Pakets KB3150513 wurde erfolgreich in "Installiert" geändert.

    Dasss es an dem iSCSI Initiator liegen könnte ist reine Spekulation meinerseits.

    Mit freundlichen Grüßen

    Gerhard Gaußling





    Montag, 22. Mai 2017 08:13
  • Hallo zusammen,

    ich kann den Ansatz mit dem iScsi von Gerhard betätigen, auch bei mir führte die Deaktivierung des iScsi Initiatordienstes mindestens zu einer längeren Laufzeit des Systems (bisher 22h statt 13h).

    Es ist also wohl keine reine Spekulation.

    Auch ich vermisse eine Reaktion seitens Microsoft. Ich kann die Maschine seit einem Monat nicht mehr nutzen.

    Mit freundlichen Grüßen

    Lutz Wienecke

    Dienstag, 23. Mai 2017 20:20
  • ID 2, 24.04.2017, Der Status des Pakets KB3150513 wurde erfolgreich in "Installiert" geändert.
    
    ID 1, 20.04.2017, Änderungen für Paket KB4013429 werden initiiert. Der aktuelle Status ist "Abgelöst". Der Zielstatus ist "Abwesend". Client-ID: DISM Package Manager Provider.
    
    ID 2, 20.04.2017, Der Status des Pakets KB4015217 wurde erfolgreich in "Installiert" geändert.
    
    ID 2, 12.04.2017, Der Status des Pakets KB4018483 wurde erfolgreich in "Installiert" geändert.

    Hallo,

    wie Lutz Wienecke bestätigt, hat es mit einem KB Sicherheitspatch ab Mitte April bis zum 24. April zu tun und hängt mit dem iSCSI-Initiator-Dienst zusammen, denn Lutz Wienecke hat den iSCSI Treiber nicht aus dem Gerätemanager entfernt, aber den Dienst abgeschaltet. Nun ist seit 22h Ruhe, obwohl bei ihm der AFD-Fehler sonst nach 13h auftrat. Bei mir alle 1-1,5 Tage.

    Ich nehme an, dass der iSCSI Dienst zu viele "ephemeral ports" öffnet, was zu Fehlern wie "No buffer space available" oder "no more ports available" also dem AFD-Fehler ID 16002 führt *). Die genaue Fehlermeldung ist meinen früheren Posts zu entnehmen.

    Ich hatte auch orphaned iSCSI Targets im Initiator stehen, aber das schon seit zwei Jahren. Erst nach der Installation eines Sicherheitspatches begann das Probleme zu machen.

    Ich benötige iSCSI im Moment nicht, anders Lutz, der darauf angewiesen zu sein scheint.
    Ich hatte damit mittels mhvtl und einer lacie etherdisk auf dem die virtuellen Bänder lagen Acronis, Bacula und Symantec Band-Backup-Software ausprobiert. Vor ein paar Jahren verabschiedete sich dann das LaCie, das mit einem embedded Windows-XP ausgestattet war, dass die 4 2TB-Platten leider als spanning Storage-Pool mit zwei Partitionen C: 4GB und die restlichen 8TB auf D: ausgelegt war. Bei einem Blockfehler auf einer HDD fiel natürlich der gesamte Storage-Pool samt OS aus. Doofes System-Layout. Seit dem benötige ich den Initiator nicht mehr.

    Das ist aber eigentlich kein Workaround. Deshalb wäre es wünschenswert, wenn Microsoft sich mal diesem Fehler annehmen würde.

    Mit freundlichen Grüßen

    Gerhard Gaußling

    *)

    Unter cygwin bekomme ich dann, wenn ich eine ssh-Verbindung aufbauern möchte: "no buffer space available" andere beschweren sich, dass keine Ports mehr verfügbar sind.

    https://support.microsoft.com/de-de/help/2577795/kernel-sockets-leak-on-a-multiprocessor-computer-that-is-running-windows-server-2008-r2-or-windows-7


    https://www.windowstechupdates.com/no-buffer-space-available-maximum-connections-reached/



    Dienstag, 23. Mai 2017 21:43
  • Hallo Lutz,

    da von Microsoft-Seite bisher keine Reaktion erfolgt, kannst Du denn etwas zu a) den KBs sagen, die mit dem iSCSI-Initiator interferrieren, und weißt Du schon, ob der Fehler nicht mehr auftritt trotz aktiven Initiator UND installiertem KB, welches die Probleme macht, wenn Du b) die obsoleten, das heißt unerreichbaren Targets entfernst? Das wolltest Du ja testen.

    Falls das klappen sollte, hätten wir zumindest einen Workaround.

    Vielen Dank im Voraus, für eine Klärung, und danke für die Mitarbeit.

    Ich kopiere das auch in den Diskussionsfaden zum KB, den ich weiter oben hier verlinkt habe.

    Hir der Direktlink: https://answers.microsoft.com/de-de/windows/forum/windows_10-update/kb4015217/90a95447-8e17-45b6-9e9d-b25f2a2d38b5?rtAction=1495718923316


    Donnerstag, 25. Mai 2017 13:30
  • Hallo Gerhard,


    nachdem ich die nicht mehr vorhandenen Targets entfernt hatte, den Start des iScsi Initiators wieder auf automatisch gesetzt hatte und die Maschine neu gestartet habe läuft sie seit 22h problemlos.


    Das Problem liegt also wahrscheinlich an eingetragenen, nicht mehr vorhandenen Targets im iScsi Initiator.


    Systemstand ist 1703 mit aktuellen Patches.


    Vielen Dank für die Hilfe, nach iScsi Fehlern hätte ich wahrscheinlich noch lange gesucht.


    Mit freundlichen Grüßen

    Lutz Wienecke

    Donnerstag, 25. Mai 2017 16:08
  • Hallo Lutz,

    vielen Dank für die Bestätigung meiner Vermutungen. So haben wir wahrscheinlich einen funktionierenden workaround.

    An Microsoft: Es handelt sich trotzdem um einen Bug, da seit dem Sicherheitspatch, wahrscheinlich KB4015217,orphaned iSCSI Targets im Microsoft iSCSI Initiator nicht mehr richtig abgefangen werden. So wird wohl wohl der Fehler mit Event-ID 16002 im AFD-Treiber ausgelöst und neue Ports können nicht mehr geöffnet werden, womit das Netzwerk dann teilweise ausfällt, aber bestehende Verbindungen teilweise weiter funktionieren, bis der Computer dann einfriert.  Möglicherweise sorgen so verursachter Timeouts für das Einfrieren des Rechners. Diese Beschreibung ist zwar hypothetisch, aber einiges deutet darauf hin.

    Mit freundlichen Grüßen

    Gerhard Gaußling


    Freitag, 26. Mai 2017 07:37
  • Hallo Zusammen,

    ich habe mit der Feedback HUB App folgenden Eintrag erstellt: https://aka.ms/Y4biqc

    Ich hoffe, dass so das Problem erkannt und als Bug behandelt wird.

    Mit freundlichen Grüßen

    Gerhard Gaußling

    Montag, 29. Mai 2017 08:23
  • Hallo, Der Fehler ist nun wieder da, mit 500 Einträgen seit dem 4.06. 17:06 bis jetzt, dem 6.06. 9:11. Seit dem 17.05. 13:14 war Ruhe. Der iSCSI-Initiator ist samt Treiber deaktiviert.
    Scheinbar ergibt sich der Fehler wohl auch durch andere Anwendungen die TCP oder UDP Ports öffnen oder temorär neu erstellen. Was es diesmal war kann ich nicht sagen.
    - System
      - Provider
       [ Name]  AFD
     
      - EventID 16002
       [ Qualifiers]  32768
     
       Level 3
     
       Task 0
     
       Keywords 0x80000000000000
     
      -
    Das Schließen einer UDP-Socket mit der lokalen Portnummer "56922" im Prozess "75968" dauert länger als erwartet. Die lokale Portnummer ist möglicherweise erst nach Abschluss dieses Vorgangs wieder verfügbar. Der Grund hierfür liegt in der Regel im fehlerhaften Verhalten von Netzwerktreibern. Stellen Sie sicher, dass die neuesten Updates für Windows und für die Netzwerksoftware von Drittanbietern einschließlich NIC-Treibern, Firewalls oder anderer Sicherheitsprodukte installiert sind. 
    Dienstag, 6. Juni 2017 07:32
  • Habe den Fehler auch, alle Ports werden unbrauchbar und es können keine Verbindungen mehr aufgebaut werden. Durch das erneute starten der Netzwerkverbindung geht wieder alles für ... 12 Stunden... ISCSI nutze ich nicht.
    Sonntag, 15. Juli 2018 17:23