none
WINRM Service kann nicht verwendet werden wenn ein SPN auf HTTP/Servername gesetzt ist. RRS feed

  • Allgemeine Diskussion

  • Hallo,

    ich habe Folgendes Problem auf Grund von SharePoint mit Kerberos Authentication musste ich den spn HTTP/Servername (Domain\ServiceUser) und  HTTP/Servername.Domain.net (Domain\ServiceUser)  setzten. Jetzt hat sich herausgestellt dass ich zwar die CA super mit Kerberos öffnen kann allerdings die WINRM dienste nicht mehr verwenden kann. Ich bekomme im Eventlog Entsprechende Fehlermeldungen ID4 (Kerberos etc.) und die Powershell meldet dass sie einen Unbekannten Sicherheitsfehler hat.

    Entfehrne ich den SPN vom User ist alles wieder gut.

    hat da jemand eine Idee wie ich beides verwenden kann?

    mfg

    Mittwoch, 18. April 2012 12:17

Alle Antworten

  • http://www.sbrickey.com/Tech/Blog/Post/SharePoint_PowerShell_and_Service_Principal_Names

    Please click “Mark as Answer” if my post answers your question and click Vote as Help if my Post helps you.
    Bitte markiere hilfreiche Beiträge von mir als Hilfreich und Beiträge die deine Frage ganz oder teilweise beantwortet haben als Antwort.
    My PowerShell Blog http://www.admin-source.info
    [string](0..21|%{[char][int]([int]("{0:d}" -f 0x28)+('755964655967-86965747271757624-8796158066061').substring(($_*2),2))})-replace' '

    Mittwoch, 18. April 2012 13:36
  • Hallo Florian !

    Ist dein Problem gelöst?


    Please click “Mark as Answer” if my post answers your question and click Vote as Help if my Post helps you.
    Bitte markiere hilfreiche Beiträge von mir als Hilfreich und Beiträge die deine Frage ganz oder teilweise beantwortet haben als Antwort.
    My PowerShell Blog http://www.admin-source.info
    [string](0..21|%{[char][int]([int]("{0:d}" -f 0x28)+('755964655967-86965747271757624-8796158066061').substring(($_*2),2))})-replace' '

    Montag, 23. April 2012 05:27