none
WMI Filter für Server 2003/R2 RRS feed

  • Frage

  • Hi,

    ich habe eine GPO die Einstellungen nur für Windows Server 2003 betreffen. In der OU sind aber 2003er sowie 2008er Server enthalten.

    Also versuche ich diese über WMI zu filtern. Ich habe hier 2 verschieden ansätze verfolgt:

    • select * from Win32_OperatingSystem WHERE Version LIKE "5.2%" AND ProductType = "3"
    • SELECT Version FROM Win32_OperatingSystem WHERE Version < "6

    Beide bringen leider nicht das gewünschte Ergebnis. In der GPO Modellierung wird die GPO auch auf 2008er Server angewegndet, der Wert ist dort "true", müsste aber "false" sein. Muss ich noch was beachten oder hab ich etwas übersehen?

    Dienstag, 13. März 2012 10:44

Antworten

Alle Antworten

  •  
    > SELECT Version FROM Win32_OperatingSystem WHERE Version < "6
     
    Die Version ist ein String, keine Zahl. Schau Dir stattdessen mal
    BuildLevel an...
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Dienstag, 13. März 2012 11:08
    Beantworter
  • Es scheint das die "GPO Modellierung" hier den Wert default auf TRUE setzt.

    Habe gerade in einer Testumebung die Einstellung mal machen lassen und siehe da, er hat den Filter erfolgreich und wie gewünscht angewendet. Die GPResults bestätigen das.

    Verwendet habe ich hier den oberen Filter und dieser Funktioniert soweit ganz gut.

    Dienstag, 13. März 2012 11:20
  • Hallo,

    Es scheint das die "GPO Modellierung" hier den Wert default auf TRUE setzt.

    Bei der Modellierung wird keine Verbindung zum jeweiligen Computer ausgewählt.
    (diese funktioniert auch wenn der Computer während der Modellierung gar nicht am Netz ist).
    Deshalb kann auch der WMI-Filter nicht geprüft werden.

    Zum Prüfen der WMI Filter gibt es z.B. dieses Tool:

    http://www.gpoguy.com/FreeTools/FreeToolsLibrary/tabid/67/agentType/View/PropertyID/93/Default.aspx


    MVP Group Policy - Mythen, Insiderinfos und Troubleshooting zum Thema GPOs: Let's go, use GPO!



    Dienstag, 13. März 2012 12:45
    Beantworter
  •  
    > Es scheint das die "GPO Modellierung" hier den Wert default auf TRUE
    > setzt.
    >
     
    Bei der Modellierung kannst Du angeben, welche Filter wahr oder falsch
    sein sollen.
     
    mfg Martin
     

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    Wenn meine Antwort hilfreich war, freue ich mich über eine Bewertung! If my answer was helpful, I'm glad about a rating!
    Dienstag, 13. März 2012 12:46
    Beantworter
  • Hi,
     
    Am 13.03.2012 11:44, schrieb _noc:
    > ich habe eine GPO die Einstellungen nur für Windows Server 2003 betreffen.
     
    WMI muss immer TRUE ergeben, damit er funktioniert.Den 2003
    identifiziere ich immer über die BuildNumber und den Producttype.
     
    BuildNumer: alles was kleiner als 5999 ist, ist XP oder 2003 und der
    Produkttyp ist NICHT = 1 oder 2 bzw. 3
     
    1 Work Station, 2 Domain Controller, 3 Server
     
    Deine Anführungszeichen sollten nut ' sein anstelle von "
     
    select * from Win32_OperatingSystem WHERE BuildNumber < '5000'  AND
    ProductType = '3'
     
    Tschö
    Mark
     
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    Homepage:       www.gruppenrichtlinien.de - deutsch
    GPO Tool:       www.reg2xml.com - Registry Export File Converter
    NetworkTrayTool www.gruppenrichtlinien.de/tools/Networktraytool.htm
     
    Mittwoch, 14. März 2012 07:38