none
Sendeconnector ohne Smarthost RRS feed

  • Frage

  • Hallo,

    wie ist es möglich ohne Smarthost, mails an z.b. GMX, T-online , Yahoo und so weiter zu versenden.

    MX ist gesetzt, Prt und DNS-Reverse ist auch gesetzt. 

    Jemand eine Idee. Mit Smarthost kann ich keine Abwesendheitsnachrichten versenden.

    Danke für Ihre/eure Hilfe. 

    Montag, 20. Juli 2015 17:07

Antworten

  • Moin Frank,

    wo kommt denn diese Fehlermeldung, mit welcher ID und wer generiert die?

    Über MX Record kann man nicht senden, das passiert per DNS Auflösung, wenn die nicht passt, hat man da das 1te Problem.

    Wenn im Sende-Connector ein Smarthost eingetragen wird, werden alle Mails darüber versendet.

    Es kann sein, das bei OOF dein Provider die Mail nicht annimmt, da der Absender bei einem OOF gemäß RFC leer ist.

    Ich würde mal das SMTP-Logging einschalten und sehen, was da genau passiert.

    Wenn du was am Sende-Connector änderst, den Exchange Transport neu starten.

    ;)


    Gruß Norbert

    Dienstag, 21. Juli 2015 06:23
    Moderator

Alle Antworten

  • Moin,

    ja, das geht natürlich, alleine bei meinen ca. 300 Kunden einwandfrei.

    Die o.g. Empfänger machen in der Regel Reverse-DNS-Anfrage, kommt da nicht dein Server, schade.

    Allerdings verstehe ich deine Frage / dein Problem gerade nicht.

    Wie viele MX-Einträge bzw PTR gibt es zu deiner Domäne?

    Feste IP mit Namensauflösung hat dein Server?

    Spiel - oder Produktivumgebung?

    Und was hat Smarthost oder nicht mit dem OOF zu tun?

    Passt dein Zertifikat?

    Und über was für eine Exchange-Version reden wir hier?

    ;)

    Nachtrag: Änderungen am externen DNS können je nach TTL bis 48h dauern, es sei denn, man hat Einfluß auf die Lebensdauer...


    Gruß Norbert


    Montag, 20. Juli 2015 18:49
    Moderator
  • Moin Frank,

    wenn Dein Smarthost den Versand von automatischen Antworten nicht zuläßt, empfehle ich zunächst, das Problem zu lösen ; ein direkter Versand via MX ins Internet kann noch andere Nebenwirkungen auslösen.
    Das ist tendentiell weniger ein Exchange-Thema, als vielmehr in der Infrastruktur vor Exchange zu suchen. Aber leider beschreibst Du dazu keine Details.

    Prüfe dies:
    * SPF Record gesetzt
    * Reverse Lookup sollte einen der MX ergeben
    so : https://technet.microsoft.com/de-de/library/Ff714972.aspx

    Lass uns wissen, ob es Dein Problem gelöst hat.

    Viele Grüße,
    Martin

    Dienstag, 21. Juli 2015 01:52


  • Okay ich versuche mal alle eure Fragen zu beantworten.

    Feste IP hat der Kunde. Live Betrieb. Exchange 2013, Client OUTlook2013. Zertifikat passt. Das Problem ist wenn ich via mx versende werden die Mails teilweise mit dem Fehler nicht versendet.

    Requested hat diesen Fehler ausgegeben:
    Requested action not taken: mailbox unavailable

    Aktivere ich den Smarthost funktioniert alles wieder, nur die OOF nicht mehr. OOFs werden aber direkt über dem MX verschickt.

    Vorhanden ist nur ein MX Eintrag, ein Reverse Lookup ergibt den MX Eintrag.

    Dienstag, 21. Juli 2015 05:52
  • Moin Frank,

    wo kommt denn diese Fehlermeldung, mit welcher ID und wer generiert die?

    Über MX Record kann man nicht senden, das passiert per DNS Auflösung, wenn die nicht passt, hat man da das 1te Problem.

    Wenn im Sende-Connector ein Smarthost eingetragen wird, werden alle Mails darüber versendet.

    Es kann sein, das bei OOF dein Provider die Mail nicht annimmt, da der Absender bei einem OOF gemäß RFC leer ist.

    Ich würde mal das SMTP-Logging einschalten und sehen, was da genau passiert.

    Wenn du was am Sende-Connector änderst, den Exchange Transport neu starten.

    ;)


    Gruß Norbert

    Dienstag, 21. Juli 2015 06:23
    Moderator