none
odbcad32 Verwaltungskonsole als Benutzer starten RRS feed

  • Frage

  • Hallo,

    wir haben einen 2012 R2 Server mit Remotedesktop Diensten installiert. Bei den bisherigen Servern zumindest bis 2008 R2 konnte jeder Benutzer einen Benutzerdsn ODBC Eintrag erstellen. (habe mich hoffentlich verständlich ausgedrückt) Beim 2012 R2 Server kommt immer das Anmeldefenster für den Administrator und somit erstelle ich immer einen ODBC DSN für den Administrator und nicht für den eigentlichen Benutzer.

    Hoffe mir kann jemand helfen.

    Mfg

    Hornauer Chrisitan


    Hornauer

    Montag, 9. Juni 2014 21:35

Antworten

  • Lösung weis ich keine. Aber einen Workarround.

    Man könnte die ODBC Verbindungen direkt in die Registry eintragen unter HKEY_CURRENT_USER\Software\ODBC\ODBC.INI - am besten im Logonscript dann kriegts der User gar nicht mit.

    Gruß

    Sebastian

    Mittwoch, 11. Juni 2014 05:32
  • > mit normalem Bemutzer komme ich nicht rein.
     
    Ich weiß ja nicht, was Du genau machst und wie Du UAC konfiguriert hast...
     
    Bei einer OOBE-Installation starte ich ODBC (32 bit) als normaler User,
    gebe meine normale User-ID und deren Kennwort einfach noch mal an und
    kann dann problemlos User-DSNs hinzufügen. Ja, auch unter 2012R2 - grad
    eben extra für Dich ausprobiert :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Mittwoch, 11. Juni 2014 07:29

Alle Antworten

  • > Anmeldefenster für den Administrator und somit erstelle ich immer einen
    > ODBC DSN für den Administrator und nicht für den eigentlichen Benutzer.
     
    Und was passiert, wenn der User in diesem Anmeldefenster einfach seine
    eigene User-ID + Kennwort eingibt?
     
    Manche Programme haben als Manifest "requireadministrator", da muss ein
    Admin eingegeben werden. Andere haben "highestavailable", da kommt zwar
    auch die UAC-Anmeldung, aber es muss kein Admin sein...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Dienstag, 10. Juni 2014 07:55
  • Hallo,

    mit normalem Bemutzer komme ich nicht rein.

    Mfg

    Hornauer Christian


    Hornauer

    Dienstag, 10. Juni 2014 20:59
  • Lösung weis ich keine. Aber einen Workarround.

    Man könnte die ODBC Verbindungen direkt in die Registry eintragen unter HKEY_CURRENT_USER\Software\ODBC\ODBC.INI - am besten im Logonscript dann kriegts der User gar nicht mit.

    Gruß

    Sebastian

    Mittwoch, 11. Juni 2014 05:32
  • > mit normalem Bemutzer komme ich nicht rein.
     
    Ich weiß ja nicht, was Du genau machst und wie Du UAC konfiguriert hast...
     
    Bei einer OOBE-Installation starte ich ODBC (32 bit) als normaler User,
    gebe meine normale User-ID und deren Kennwort einfach noch mal an und
    kann dann problemlos User-DSNs hinzufügen. Ja, auch unter 2012R2 - grad
    eben extra für Dich ausprobiert :)
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Mittwoch, 11. Juni 2014 07:29