none
SCCM - MUI Deployment

    Frage

  • Hallo zusammen,

    ich versuche nun seit geraumer Zeit nachträglich zu einer Office 2016 Installation MUI's deployen zu können. Das funktioniert auch relativ gut, bis Zusatzanwendungen (Visio, Project) installiert sind / werden. Aus irgendeinem Grund verursacht die MUI Installation dann massive Probleme mit anderen Office Anwendungen, z.B. stürzt Outlook beim Wechseln zum Kalender oder beim öffnen von Mails mit Anhängen einfach ab. Hat hier jemand Erfahrung damit / einen Rat?

    Ich verwende das PSDeploymentToolkit für die Installation. Hier ist die Routine:

    Show-InstallationWelcome -CloseApps 'outlook,winword,excel,powerpnt,lync,onenote' -CheckDiskSpace -PersistPrompt -BlockExecution
    Show-InstallationProgress -StatusMessage "Installing Office 2016 Professional Plus Languagepack: DE-DE"        
    Execute-Process -Path "setup.exe" -Parameters "/config OMUI.de-de\config.xml"
    Set-PackageStatus -StatusText "installed" -AppKey "O2016LanguagePack.DE-DE"

    Die config.xml sieht folgendermaßen aus:

    <Configuration Product="OMUI.de-de">
    	<Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
    </Configuration>

    Leider habe ich nirgends wirklich gute Literatur zu diesem Thema finden können.

    Eventuell hat jemand noch einen Tipp wie man vorzugehen hat, wenn Visio oder Project nach dem MUI installiert wird.

    Mittwoch, 1. August 2018 07:42

Alle Antworten

  • Dies hat ggf. mit Inkompatibilitäten der verschiedenen Office-Produkte zu tun.
    Mit Viso und Project muss ich z.B. mindestens Office Pro haben, eine Office 365 ist vollkommen inkompatibel.
    Ebenso ist auf die Bit-Kompatibilität 32/64-Bit zu achten.
    Mittwoch, 1. August 2018 13:22
  • Vielen Dank für die Antwort. Wir verwenden Office 2016 Professional Plus in der x86 Variante. Das MUI ist ebenfalls für die 2016er x86 Version. Ich bin mir im Moment nicht mehr sicher, ob die beschriebenen Probleme eventuell auch ohne die Installation von Project und / oder Visio auftraten - aber Versionstechnisch sind wir auf jeden Fall auf demselben Stand.

    Was ich vergaß zu erwähnen: Führt man die Installation der MUI manuell durch (d.h. über die GUI) funktioniert im Anschluss alles wie es soll. Lediglich für Project und Visio muss die MUI separat jeweils noch einmal installiert werden (da sie nicht von der OMUI.DE.DE abgedeckt ist?).

    Mittwoch, 1. August 2018 13:46