none
Exchange 2016 - E-Mails über OWA werden sporadisch nicht verschickt RRS feed

  • Frage

  • Guten Morgen,

    folgende Konstellation: Microsoft Exchange 2016 - RA-Micro Kanzleiprogramm - allgemeines Exchange Sekretariatspostfach. RA-Micro verschickt E-mails über HTTPS OWA. RA-Micro liegt selbst auf einem anderen Server (Uhrzeiten per NTP gleich).

    Im Exchange ist die Journal Funktion aktiv für die E-Mail Archivierung mit Mailstore.

    Von ungefähr 300 E-Mails kommen ca. 4 E-Mails beim Mandanten nicht an. Die E-mails sind auch beim Mandanten nicht im SPAM Ordner zu finden (geht ja auch erst gar nicht vom Exchange raus)

    Stichprobe bei einer E-Mail: E-Mail wurde von seitens RA-Micro erfolgreich an den Exchange übermittelt. Diese E-Mail ist dann auch in Outlook unter gesendete Objekte zu finden. Mailstore hat dieseE-mail jedoch nicht - sprich - sie landet schon nicht im Journal Postfach.

    Prüfe ich diese E-Mail im Exchange nach den Logs finde ich zu diesem Zeitpunkt keinen einzigen Eintrag. Um ein Zeitenproblem auszugehen suche ich nach der E-Mail Adresse mehrere Tage - kein Ergebnis:

    get-transportservice | get-messagetrackinglog -wa 0 -recipient "mandant@gmx.de" -Start ("01.02.2017 00:00" | Get-Date) -End ("28.02.2017 23:56" | get-date) | where {$_.sender -notmatch "HealthMailbox" -and $_.recipients -notmatch "Health"}

    Das Problem besteht lediglich bei E-Mails, die über RA-Micro versandt werden - E-Mails über Outlook oder Handy kommen immer beim Empfänger an.

    Hat jemand eine Idee, wonach ich gucken könnte, oder was das Problem sein kann?

    Vielen Dank im Voraus und Grüße

    Uwe



    • Bearbeitet UweHa16 Dienstag, 21. Februar 2017 09:45
    Dienstag, 21. Februar 2017 09:12

Antworten

  • Moin,

    ich denke, Du solltest Dich da eher an den Support von RA-Micro wenden.

    Ich finde bei denen keine genaue Infos, denke aber, dass die nicht OWA sondern EWS benutzen. OWA wäre doch sehr ungewöhnlich, weil das keine genormte Schnittstelle im Gegensatz zu EWS ist.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Dienstag, 21. Februar 2017 16:29

Alle Antworten

  • Moin,

    ich denke, Du solltest Dich da eher an den Support von RA-Micro wenden.

    Ich finde bei denen keine genaue Infos, denke aber, dass die nicht OWA sondern EWS benutzen. OWA wäre doch sehr ungewöhnlich, weil das keine genormte Schnittstelle im Gegensatz zu EWS ist.


    Gruesse aus Berlin schickt Robert - MVP Office Servers and Services (Exchange Server)

    Dienstag, 21. Februar 2017 16:29
  • Hallo Robert,

    dann nutzen diese EWS. Man muss zur Konfiguration die Zugangsdaten und die OWA-Adresse angeben.

    Komisch ist jedoch, dass die E-Mail im Ordner gesendete Objekte zu sehen ist, es aber im Exchange keine Log-Einträge zu finden sind.

    Sicher, dass es sich hier um ein RA-Micro Problem handelt, da dieses Problem erst seit der Umstellung SBS2011 auf Server2012 & Exchange 2016 ?!

    Dienstag, 21. Februar 2017 16:54
  • Moin,

    das Logging muss man explizit einschalten, sonst findet man auch nichts.

    Über welche Exchange 2016 Version reden wir hier?
    http://blog-schulenburg.de/index.php/kategorie-als-blog/87-exchange-build-nummern

    Darf der sendende Server überhaupt an den 2016 einliefern?

    Und man müsste schon genauer wissen, wie die Software die Mails an den Exchange übergibt. Möglich wäre da, MAPI, EWS, SMTP (habe ich was vergessen - achja, IMAP..)

    ;)


    Gruß Norbert

    Dienstag, 21. Februar 2017 17:21
    Moderator
  • Moin,

    es handelt sich um die Version: Standard Version 15.1 (Build 544.27)

    Wie schalte ich das Loging ein, damit ich etwas erkennen kann?

    Ja, da über den Port 443 https Schnittstelle versand wird, darf jeder - wie die Hanys auch.

    Welches Verfahren hier genau genutzt wird, kann ich leider nicht beantworten. SMTP und IMAP kann ich ausschließen, da lediglich E-Mails versendet werden und alle gesendeten E-Mails auch unte gesendete Objekte zu finden sind. Dies ist nach meinen Tests her bei reinem SMTP Versand nicht möglich, oder doch ?!

    Dienstag, 21. Februar 2017 20:32
  • Hallo Uwe,

    du hast also mit CU3 installiert - hmm, solche Probleme hatte das eigentlich nicht, trotzdem solltest du zeitnah auf das CU4 gehen, da dort viele kleinere Problem, u.a. Search behoben wurden.

    Und Mitte März kommt ja schon das CU5, wenn nicht noch was dazwischen kommt.

    Ist die RA micro-Version überhaupt mit Exchange 2016 freigegeben vom Hersteller?

    Im OP habe ich noch was von Mailstore gelesen, welche Version, auch die ist für 2016 schon freigegeben?

    Ist die (hoffentlich..) auf einem anderen Server drauf?

    Und du hast Recht, sendet man direkt per SMTP, sieht man es nicht in den gesendeten Objekten.

    ;)


    Gruß Norbert

    Mittwoch, 22. Februar 2017 13:00
    Moderator
  • Hallo Norbert,

    ja Exchange 2016 ist sowohl für RA-Micro als auch MailStore freigegeben.

    RA-Micro benötigt nur Datenablage - Exchange - DC - RA-Micro sind alles getrennte VMs.

    Angenommen, es gibt keine Lösung, gäbe es denn eine Möglichkeit per SMTP zu versenden und irgendwie trotzdem die gesendeten gesendeten E-Mails im Ordner gesendete Objekte zu erhalten?

    Leider erhalten wir seitens RA-Micro aktuell keine Antwort.

    Dienstag, 28. Februar 2017 15:57
  • Liebe Gemeinde,

    könnten hier die Throttling-Richtlinien zuschlagen.
    https://msdn.microsoft.com/de-de/library/office/jj945066(v=exchg.150).aspx
    Bezieht sich zwar auf EWS. Es gibt aber auch Einschränkungen für andere Dienste.

    Bei vielen Anwendungen, die impersonation nutzen, muss eine spezielle Trhottling-Richtlinie erstellt werden.

    Beispiele: EnterpriseVault, Mailstore, BES, ...

    Gruß Malte Pabst

    Dienstag, 28. Februar 2017 17:40
  • Hallo Malte,

    dies kann sehr gut möglich sein, da bereits bei der Installation des Exchange Server das Throttling gegriffen hat, weil es 15 PC-Systeme gibt, die auf das Postfach zugreifen, über das auch die E-Mails aus RA-Micro versendet werden.

    Welche Informationen brauchst du zum beurteilen, ob dies hier greift?

    Viele Grüße

    Uwe

    Dienstag, 28. Februar 2017 18:21
  • Hallo Uwe,

    zu Anfang eine Frage & eine Bitte: Hast Du ein Testsystem?
    Das wäre von Vorteil. Die Webinformationen von RA-Micro sind wirklich nicht ergiebig.
    Bitte bis zum Ende lesen, denn wir gehen tief in die Konfiguration der Exchangedienste und das birgt einige Gefahren.

    Ob Throttling zuschlägt, kann nur (nach meinem Kenntnisstand) durch Aktivierung in der Datei "Microsoft.Exchange.RpcClientAccess.Service.exe.config" erfolgen. Wenn hier aber ein Syntaxfehler eingebaut wird kann es sein, das die Dienste nicht korrekt starten (besser gesagt - gar nicht starten).
    Die Config-Datei befindet sich im Exchange Installationsordner im BIN Verzeichnis (normalerweise C:\Program Files\Microsoft\Exchange Server\V15\Bin). Bitte vor Änderungen einfach kopieren.

    Suche in der Config-Datei nach <add key=”LoggingTag” value=”ConnectDisconnect, Logon, Failures, ApplicationData, Warnings” /> und füge (, Throttling) ein. Groß/Kleinschreibung muss beachtet werden. Die neue Zeile sollte so aussehen: <add key=”LoggingTag” value=”ConnectDisconnect, Logon, Failures, ApplicationData, Warnings, Throttling” />

    Anschließend den "Microsoft Exchange RPC Client Access" neu starten.

    Starten die Dienste nicht, dann die "gesicherte" original Config-Datei wieder bereitstellen. U.U. war die Codierung falsch (Die korrecte Codierung kannst Du mit einem Web-Browser prüfen)

    Das entsprechende Logfile findest Du in Exchange Install Verzeichnis (normalerweise C:\Program Files\Microsoft\Exchange Server\V15\Logging\RPC Client Access). Hier suchst Du nach "Connection Limit Exceeded". Hast Du einen Treffer, dann könnte es die Ursache sein.

    Wenn Du einen Call beim Hersteller öffnen kannst, verkürzt das sicher Deinen Aufwand. Da ich RA-Micro noch nie konfiguriert habe, kann ich auch nicht sagen, welche Informationen benötigt werden. Wichtig ist "Welche Exchange Schnittstelle nutzt RA-Micro?"

    Viele Grüße Malte Pabst

    Dienstag, 28. Februar 2017 19:32