none
SQL Express 2014, SQL Browser startet nicht - SQL-Instanz Konnektivitätsermittlung - Der SQL Server-Browserdienst konnte die SQL-Instanz und die Konnektivitätsermittlung nicht einrichten. RRS feed

  • Frage

  • Hallo, ich bräuchte von euch Hilfe.

    Ich habe eine SQL Express 2014 installiert, der Browser startet aber nicht.

    Fehlermeldung Browser beim Start:
    siehe Bild


    Fehlermeldung Ereignisanzeige:
    Protokollname: Application
    Quelle: SQLBrowser
    Datum: 22.12.2016 10:32:39
    Ereignis-ID: 10
    Aufgabenkategorie:Keine
    Ebene: Fehler
    Schlüsselwörter:Klassisch
    Benutzer: Nicht zutreffend
    Computer: EXONE-PC
    Beschreibung:
    Der SQL Server-Browserdienst konnte die SQL-Instanz und die Konnektivitätsermittlung nicht einrichten.


    Weiteres:
    Die Konfiguration der SQL-Instanz SDCO ist ungültig. -> Ist nicht in den Diensten da!

    Weiteres:
    Der SQL Server-Browser aktiviert die Unterstützung für die SQL-Instanz und die Konnektivitätsermittlung.
    Der SQL Server-Browserdienst wurde gestartet.
    Der SQL Server-Browserdienst wurde angehalten.


    Weiteres:
    Die Konfiguration der SQL-Instanz IQS ist ungültig.
    Diese Instanz wurde aber gelöscht, woher kommt diese Meldung?


    Hinweis: Die SQL wurde komplett deinstalliert und wieder Installiert.

    Es geht darum, das ein Programm den Browser braucht um darüber über das Netzwerk zu arbeiten (Client/Server).


    Entscheidend ist doch die Aussage:
    Der SQL Server-Browserdienst konnte die SQL-Instanz und die Konnektivitätsermittlung nicht einrichten.



    Was bedeutet dies genau?
    Was kann ich tun?



    .

    Hinweis: Ich habe die gleiche Frage auf ein anderen Forum gepostet, da ich in Google nichts weiter gefunden habe und scheinbar sehr selten vorkommt.

    http://www.datenbankforum.com/threads/sql-express-2014-sql-browser-startet-nicht-sql-instanz-konnektivitaetsermittlung.3631/
    Über jede Hilfe bin ich sehr Dankbar.


    • Bearbeitet RycoDePsyco Dienstag, 27. Dezember 2016 12:12
    Dienstag, 27. Dezember 2016 12:11

Antworten

Alle Antworten

  • Hallo

    Warum der Browser Dienst nicht funktioniert kann ich auch nicht sagen. Aber um die Datenbank erstmal wieder lauffähig zu bekommen kannst du die SQL Server Instanz von der dynamischen Portzuweisung auf einen festen Port umstellen und die Verbindungsinformation der Anwendung anpassen, dass dort nicht der Instanz Name sondern der Port steht.

    Dafür musst du in den Configuration Manager gehen und dort die Netzwerk Einstellungen bearbeiten

    Hier ist eine Anleitung wie es gemacht wird. https://technet.microsoft.com/en-us/library/ms345327%28v=sql.100%29.aspx?f=255&MSPPError=-2147217396


    Benjamin Hoch
    MCSE: Data Platform
    MCSE: Data Management and Analytics
    MCSA: SQL Server 2012/2014
    MCSA: Windows Server 2012
    Blog

    Dienstag, 27. Dezember 2016 12:46
  • Danke für die Hilfe, aber die SQL läuft, es startet nur der Browser und geht sofort wieder aus.

    Er muss aber für das Netzwerk laufen.

    Vielen Dank

    Mittwoch, 4. Januar 2017 09:38
  • Ja das habe ich auch verstanden, aber wenn du der SQL Instanz einen Statischen Port gibst dann brauchst du den Browser nicht.

    Die Aufgabe des Browsers ist es den Instanznamen mit dem dynamischen Port zu verknüpfen. Wenn du den Port aber statisch machst und in den Verbindungsdaten den Instanznamen durch den Port ersetzt brauchst du den Browser auch für den Zugriff über Netzwerk nicht.


    Benjamin Hoch
    MCSE: Data Platform
    MCSE: Data Management and Analytics
    MCSA: SQL Server 2012/2014
    MCSA: Windows Server 2012
    Blog

    Mittwoch, 4. Januar 2017 09:45
  • Hallo!

    Den gleichen Fehler hatte ich vor kurzem auch bei einer Installation, die etwas verkorkst war. Zahlreiche Installations- und Deinstallationsversuche hatten ihre Spuren hinterlassen.

    Ich habe den Process Monitor zu Hilfe genommen und den Start des Service überwacht. Am einfachsten den Service starten und danach den Filter setzen, so dass alles eliminiert wird, was nicht zu dem Service gehört. Dann den Service neu starten. Ich habe mir alle Aktionen ausgeben lassen. Dort kamen bei mir dann zumindest zwei Fehler.

    Ich konnte eine fehlende DLL und einen fehlenden Registry Zweig ausmachen:

    -          MSVCR100.DLL

    -          HKLM\SOFTWARE\Wow6432Node\Microsoft\Microsoft SQL Server\90\SQL Browser

    Die DLL habe ich aus der Installation in das Verzeichnis c$\Program Files (x86)\Microsoft SQL Server\90\Shared kopiert.

    Den Registry Zweig habe ich angelegt, aber keine Keys angelegt.

    Damit ließ sich der Browser-Service auch starten. Ob die DLL wirklich notwendig war, habe ich nicht mehr getestet.

    Bei Dir ist die Sachlage vielleicht anders, aber mit dem Process Monitor solltest Du die Ursache finden.

    HTH!


    Einen schönen Tag noch, Christoph -- Data Platform MVP - http://www.insidesql.org/blogs/cmu

    Mittwoch, 4. Januar 2017 14:16