none
MDT - Display Scaling

    Question

  • Hello,

    Wondering if someone can advise. We are looking to roll out windows 10 in our company and to start with we are going to use MDT with WDS. With that in mind i have created a windows 10 1709 reference image using hyper v and captured it. Everything appears to work well with this process. When i run a production task sequence based on this image every single one of my lenovos comes up "A custom scale factor is set". When the intel driver is installed it sets this to 175%. When i remove the driver from the task its stuck at 150% but this is on a screen with max resolution of 1600x900 that the microsoft recommended settings would be 100% scaling. If i disable custom scaling it reverts to these recommended settings but every new user that logs in it goes back to custom scaling until disabled. 

    I have checked my reference image and it doesn't come up with "A custom scale factor is set". I can't figure out if the sysprep action is doing something to cause this or not. During the process i convert my Lenovos to use EFI and secure boot. Saying that however when i apply my reference image task sequence to the same computers there is no issues with the scaling. It only happens when using my captured image.

    Any help would be appreciated. It's driving me nuts!!

    Thanks

    Friday, May 4, 2018 10:29 AM

All replies

  • I trying to work through this same issue. I capture my wim from a vm on vshere host running in audit mode and use the captured wim for the deployment. The Laptops all end up with 150% display scaling for any new user logging in and I don't believe that should be the "recommended" since all the programs are huge and many, such as Slack, fill the entire screen until manually setting at 125% or less.  
    Tuesday, June 12, 2018 7:50 PM
  • I am not sure what is causing this behavior, so I am afraid I can only offer you a workaround.

    You can set display scaling on a per-user level via the registry. You could accomplish this via a RunOnce script (I can provide details on how to set it up), a GPO or possible via default user profile.

    For details visit following two links:


    Cheers,
    Anton

    Vacuum Breather Blog | Wing Commander Saga | Twitter

    Note: Posts are provided "AS IS" without warranty of any kind. If posts are helpful please don't forget to rate them as "Helpful" or as "Answer".

    Wednesday, June 13, 2018 10:59 AM

  • Hey.. Few months back I've encountered with same Issues. this problems generally occurs when capturing the Image with Display Drivers. have you tried to unmount the captured wim or in deployed device can you see the exact version of display drivers.

    Apart from doing changes in Devices you've to define the Resolution & DPI in Answers File [Unattended.xml]

    Example:

              <Display>
                    <ColorDepth>32</ColorDepth>
                    <HorizontalResolution>1920</HorizontalResolution>
                    <RefreshRate>72</RefreshRate>
                    <VerticalResolution>1200</VerticalResolution>
                    <DPI>175</DPI>
                </Display>


    • Edited by JiteshKumar Wednesday, June 13, 2018 2:47 PM
    Wednesday, June 13, 2018 2:46 PM
  • One issue about setting the unattend for resolution...

    The unattend, at least in my situation, is for the 'image', not the specific model.
    I have a custom image that I drop on Dells and Panasonic models as well. There really isn't a way, that
    I'm aware of, to set the unattend display one way for one model and another way for a different model(make).

    I need 175% on my Panasonic 33 but not on any Dells. So, the unattend in my case won't work because
    that unattend would apply to any make/model.

    Thursday, June 14, 2018 3:42 PM