locked
Too many mappy sessions for 1 outlook client - event 9646 - exchange server 2007 SP3 RRS feed

  • Question

  • Hi,

    We have exchange 2007 SP3 installed on a win 2008 64 bit SP1 server.
    Everything works fine but there is one client on another location that has problems with connecting and then his outlook is asking for logon/password but that doesn't do anything.

    We have a site 2 site VPN connection with that site and all other programs work fine and the connection is stable.
    In the exchange log on the server here i get:
    Mapi session "/o=XXXXXXXXXXXXXX/ou=First Administrative Group/cn=Recipients/cn=rmd" exceeded the maximum of 32 objects of type "session".

    When i check with tcpview on the server i can see that that client has 32 connection to store.exe.
    Other clients in that office don't have that problem, however they tell me that outlook sometimes asks for their logon/password but i don't know if that is related.
    I can only make his outlook work again if i restart the Microsoft Exchange Information store.
    Then it works fine and i can see only 2 mapi connections to store.exe from that client with tcpview on the server and then he can work fine all day.
    His mailbox is not that big and he has no connections to other people's mailbox or calendar.
    His RPC over HTTPS is also configured.

    But when he connects the next day, it's the same misery.
    I already uninstalled a lot of other software on his computer to make sure that no other program is responsible for this behavior but the problem stays the same.

    some message on the internet mentioned to do the following:
    netsh int ipset chimney disabled
    But i don't know what it means and i ran it on a test server and i get:
    The following command was not found: int ipset chimney disabled.

    anybody an idea ?
    thanks,
    Verus.
    Thursday, April 21, 2011 7:49 AM

Answers

  • Generally, we can raise the limitations for MAPI sessions to troubleshoot this issue.

     

    1.    Click Start, click Run, type regedit in the Open box, and then click OK.

    2.    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    3.    If the Maximum Allowed Sessions Per User entry does not exist, do the following:

    a.    On the Edit menu, point to New, and then click DWORD Value.

    b.    Type Maximum Allowed Sessions Per User as the entry name, and then press ENTER.

    4.    Right-click the Maximum Allowed Sessions Per User entry, and then click Modify.

    5.    Click Decimal, type the value that you want to set in the Value data box, and then click OK. (I suggest we set to 64)

    6.    Exit Registry Editor.

    7.    Click Start, click Run, type services.msc in the Open box, and then click OK.

    8.    Click the MSExchange Information Store service, and then click Restart Service.

     

    Thanks,

    Simon

     

    Monday, April 25, 2011 2:36 AM
    Moderator

All replies

  • Generally, we can raise the limitations for MAPI sessions to troubleshoot this issue.

     

    1.    Click Start, click Run, type regedit in the Open box, and then click OK.

    2.    Locate and then click the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\ParametersSystem

    3.    If the Maximum Allowed Sessions Per User entry does not exist, do the following:

    a.    On the Edit menu, point to New, and then click DWORD Value.

    b.    Type Maximum Allowed Sessions Per User as the entry name, and then press ENTER.

    4.    Right-click the Maximum Allowed Sessions Per User entry, and then click Modify.

    5.    Click Decimal, type the value that you want to set in the Value data box, and then click OK. (I suggest we set to 64)

    6.    Exit Registry Editor.

    7.    Click Start, click Run, type services.msc in the Open box, and then click OK.

    8.    Click the MSExchange Information Store service, and then click Restart Service.

     

    Thanks,

    Simon

     

    Monday, April 25, 2011 2:36 AM
    Moderator
  • "I can only make his outlook work again if i restart the Microsoft Exchange Information store."

    Actually you can terminate some of his 32 sessions with tcpview. Couple things you can look at.

     

    1. Does the user have a laptop and is docking\undocking frequently?

    2. Is his mailbox shared ie. other users opening his mailbox?

     

    Should be netsh chimney disabled


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Monday, April 25, 2011 2:42 PM
  • Hi,

    We have exchange 2007 SP3 installed on a win 2008 64 bit SP1 server.
    Everything works fine but there is one client on another location that has problems with connecting and then his outlook is asking for logon/password but that doesn't do anything.

    We have a site 2 site VPN connection with that site and all other programs work fine and the connection is stable.
    In the exchange log on the server here i get:
    Mapi session "/o=XXXXXXXXXXXXXX/ou=First Administrative Group/cn=Recipients/cn=rmd" exceeded the maximum of 32 objects of type "session".

    When i check with tcpview on the server i can see that that client has 32 connection to store.exe.
    Other clients in that office don't have that problem, however they tell me that outlook sometimes asks for their logon/password but i don't know if that is related.
    I can only make his outlook work again if i restart the Microsoft Exchange Information store.
    Then it works fine and i can see only 2 mapi connections to store.exe from that client with tcpview on the server and then he can work fine all day.
    His mailbox is not that big and he has no connections to other people's mailbox or calendar.
    His RPC over HTTPS is also configured.

    But when he connects the next day, it's the same misery.
    I already uninstalled a lot of other software on his computer to make sure that no other program is responsible for this behavior but the problem stays the same.

    some message on the internet mentioned to do the following:
    netsh int ipset chimney disabled
    But i don't know what it means and i ran it on a test server and i get:
    The following command was not found: int ipset chimney disabled.

    anybody an idea ?
    thanks,
    Verus.

    Check to see if the user has shared mailboxes in his Outlook profile. If so, verify that those shared mailboxes arent cached or remove them from his profile and test.
    Monday, April 25, 2011 10:00 PM
  • Were you able to find a fix for this?  We have the same problem.  Exchange 2007 Sp3 on Windows 2008.  Once a month we get one or two users that have exceeded the exceeded the maximum of 32 objects of type "session.

    I have also noticed that the tcpip parameter KeepAliveTime value is set to 4294967295 Decimal.

    Anyone have ideas?

    Thanks

    Friday, October 28, 2011 5:13 PM