none
Problem beim Deployment für Visual Studio 2017

    Question

  • Liebe Community,

    ich habe folgendes Szenario.

    Ich möchte Visual Studio 2017 über eine Netzwerkfreigabe via SCCM verteilen.
    https://docs.microsoft.com/en-us/visualstudio/install/create-a-network-installation-of-visual-studio

    Auf der Netzwerkfreigabe liegt das gesamte Layout von VS 2017. Das Paket im Softwarecenter soll ausschließlich die exe in der Freigabe öffnen. Das läuft auch, bisher keine Schwierigkeiten.

    Allerdings habe ich dann das Problem, das trotz folgender Commandozeile:
    start /WAIT \\BlaBlaBla\VS2017\vs_Professional.exe
    der Installer vs_Professional.exe nach dem Klick auf Weiter bei den Lizenzbedingungen beendet wird, der Prozess vs_installshell.exe übernimmt dann und das SCCM Paket läuft auf einen Fehler.

    Hat wer eine Idee, was ich ändern kann bzw. was ich übersehen habe?

    Besten Dank
    Steffen

    Tuesday, January 09, 2018 7:42 AM

All replies

  • In deinem Link ist doch folgendes erwähnt. Sollte das nicht sinngemäß auch bei Dir dann so gemacht werden?
    \\server\products\VS2017\vs_enterprise.exe --quiet --wait --norestart

    Torsten Meringer | http://www.mssccmfaq.de

    Tuesday, January 09, 2018 10:02 AM
    Answerer
  • Besten Dank für deine Antwort.

    Ich habe die Response.json Datei so angepasst, dass diese Parameter eigentlich nicht mehr nötig sind:
    https://docs.microsoft.com/de-de/visualstudio/install/automated-installation-with-response-file

    {
    "installChannelUri":".\\ChannelManifest.json",
    "channelUri":"https://aka.ms/vs/15/release/channel",
    "installCatalogUri":".\\Catalog.json",
    "channelId":"VisualStudio.15.Release",
    "productId":"Microsoft.VisualStudio.Product.Professional",

    "quiet": false,
    "passive": false,
    "norestart": true,

    "addProductLang": [
    "en-US",
    "de-DE"
    ]
    }

    Und bei der Angabe von --quiet hat der Nutzer ja später nicht mehr die Auswahl seine eigenen Pakete zu- oder abzuwählen., denke ich zumindest.

    Tuesday, January 09, 2018 1:55 PM