none
Collapse Issue or Missing Row Problem? RRS feed

  • Question

  • I am opening a schedule from Project Server 2010 in Project Professional 2010. In Project Server 2010, all rows show in the browser. When the schedule is opened in Project Professional 2010, all of the rows appear uncollapsed (no visible plus signs), but many of the rows are not displayed (many gaps in the row numbers).

    If you start clicking on the minus signs, additional rows begin appearing. Obviously, this is a work around but it is confusing to many of our users. Attached are screen shots that hopefully demonstrate the issue.

    Am I missing something? Are there some type of filters or something that are preventing all rows from being displayed in Project Pro 2010? Thank you.

    Wednesday, April 16, 2014 2:33 PM

Answers

  • Hi Stacy,

    It looks like the file is corrupted. I save the file as XML format, then import it again in MPP format and it works well now.

    This used to happened when the file is coming from an earlier version.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    • Marked as answer by StacyLo Wednesday, April 16, 2014 6:22 PM
    Wednesday, April 16, 2014 5:18 PM
    Moderator

All replies

  • Hi Stacy,

    do you have the same behavior also in other views? And please check the Resource Table in this project plan. In the past we had a bug, where the Resource Name of used resources were empty.

    And which SP / CU do you have installed. The latest Version is SP 2 with CU April 2014 with Version Number 14.0.7121.5000.

    Regards

    Bernhard Fischer


    Bernhard Fischer [MVP] | www.wodey.de

    Wednesday, April 16, 2014 3:08 PM
  • StacyLo,

    Two things.

    First, make sure you have SP2 installed. If not, install it.

    Second, I see that autofilter is enabled so I'm guessing that one of the fields has an autofilter selecting out task lines. Is there any field criteria that is common to each of the task lines that are not showing? To remove any applied autofilter, hit the down arrow on the right side of the filter selection box. Select Display AutoFilter.

    Hope this helps.

    John

    Wednesday, April 16, 2014 3:11 PM
  • Hi John,

    I though you were right (good spot, I didn't think of it), but after trying I see that with autofilter, hiting the minus or plus sign doesn't display filtered tasks. Thus it should be something else I guess. Checking SP and CU might help.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, April 16, 2014 3:30 PM
    Moderator
  • Attached are the versions I have for Office & Project Pro. Looks like we are behind on CUs/SPs? Our IT area installs these. Looksl like I need to have them get us up to date.

    Also, how can you tell that autofilter is enabled? There is a "No Filter" by the Filter on the View tab. I originally was thinking it was some type of filter, but couldn't figure out where any were applied.

    Wednesday, April 16, 2014 3:56 PM
  • I guess that what John meant is that you could have filtered some tasks using the auto-filter functionality in the column header, as per my screenshot:

    But clicking on the plus or minus sign (in Project 2010) doesn't display again the filtered tasks, so it should not be your culprit.

    I'd go more for the SP/CU issue.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, April 16, 2014 4:13 PM
    Moderator
  • Yes, this does help. I don't see the filter icon on any of the displayed fields; therefore, I don't think any columns are filtered. He said that he saw "auto filtered" was enabled so I was wondering how he knew that from the screen shot since I didn't see the filter icon on any of the fields. Thank you!
    Wednesday, April 16, 2014 4:20 PM
  • Hi Stacy,

    I have to admit that I don't know if and where the auto-filter can be disable.

    But check at the bottom left of your MS Project Pro, if you have some autofilters, you'll see it as per my screenshot:

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, April 16, 2014 4:41 PM
    Moderator
  • Just found it: file, options, advanced:

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, April 16, 2014 4:48 PM
    Moderator
  • When I open the project from Server to Pro, this is what the bottom of the screen looks like.

    I tried applying a filter to one of the fields and this is what it looks like. So upon opening this from Server into Pro, I don't think there are any Auto Filters on. Thanks!

    Wednesday, April 16, 2014 4:50 PM
  • So no auto-filter...

    Something I noticed is that your task IDs in the first greyed column are in italic, so I'm thinking that there is something wrong with your table or view. If you change view, does it occur again? Try also to click on "reset to default" under the view drop-down list.

    Otherwise, send me your file to guillaumeDOTrouyreATgcosiDOTcom (replace caps).

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, April 16, 2014 4:56 PM
    Moderator
  • Hi Stacy,

    It looks like the file is corrupted. I save the file as XML format, then import it again in MPP format and it works well now.

    This used to happened when the file is coming from an earlier version.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    • Marked as answer by StacyLo Wednesday, April 16, 2014 6:22 PM
    Wednesday, April 16, 2014 5:18 PM
    Moderator
  • StacyLo,

    I see Guillaume has jumped in but I do have some followup.

    First, when autofilter is on you will see a little down arrow in the header of each column. That's how I knew autofilter was enabled in your file.

    Second, the options determine whether autofilter is enabled for new projects as Guillaume pointed out. However, you can remove any applied autofilters via the method I mentioned in my first response.

    Third, your version number (14.0.7015.1000) is the same as mine. I have SP2 and the June 2013 cumulative update installed. I also have a 32 bit version of Project which is probably what you have.

    John

    Wednesday, April 16, 2014 5:47 PM
  • Thanks John. I see how you can tell the AutoFilter is enabled now.  There weren't any autofilters applied in the schedule. Glad my version number is the same as yours! Again, many thanks.
    Wednesday, April 16, 2014 6:23 PM