none
Windows Error: 0x80070006 - The handle is invalid

    Question

  • Hi community

    I set up a new App-V server App-V 5.0 SP1 including Management, Publishing and Reporting Server. Additionally I installed HF04 (KB2940354) on it.
    I published an App-V package for Domain Computers.

    On the other side I've a RDS App-V Client with App-V 5.0 SP2 incl. HF02 (KB2934349). The RDS Client is configured via GPO and I verified that the settings are now correct.

    If I try to synchronize from RDS Client manually I get following output in Power Shell:
    PS C:\Users\<username>> Sync-AppvPublishingServer

    cmdlet Sync-AppvPublishingServer at command pipeline position 1
    Supply values for the following parameters:
    ServerId: 1

    Sync-AppvPublishingServer : Application Virtualization Service failed to complete requested operation.
    Operation attempted: RefreshPublishingServer.
    Windows Error: 0x80070006 - The handle is invalid
    Error module: Publishing. Internal error detail: 45500D2780070006.
    Please consult AppV Client Event Log for more details.
    At line:1 char:1
    + Sync-AppvPublishingServer
    + ~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (:) [Sync-AppvPublishingServer], ClientException
        + FullyQualifiedErrorId : RefreshPublishingServerError,Microsoft.AppV.AppvClientPowerShell.SyncAppvPublishingServer

    In App-V Eventlog on the RDS Client there are 2 Events resulting my manual action:
    1. Event ID 19203

    HttpRequest sendRequest failed.

    URL: http://<URL>:82 /

    Error code: 0x45500D27 - 0x80070006


    2. Event ID 10102
    Getting server publishing data failed.

    URL: http://<URL>:82 /

    Error code: 0x45500D27 - 0x8007000


    Who can help me out here?
    • Edited by cue0 Wednesday, June 25, 2014 6:46 AM
    Tuesday, June 24, 2014 12:40 PM

Answers

  • Solution found by myself!

    It was the GPO which applies App-V settings amongst others. Something must have been wrong with it. Since I created a new GPO with exactly same settings everything goes fine.

    I hope this kind of error message won't appear a lot in the future. Otherwise this experience could help others.


    Thursday, June 26, 2014 10:38 AM

All replies

  • Could you list your current ports:

    • Management Server web application
    • Publishing Server web application
    • Reporting Server web application (if installed)
    • Default Web site

    Please verify that both, the App-V registry values (HKLM/Software/AppV/Server) and the IIS port bindings show the same values (except for the Default WebSite, as this doesn't have a reg value there)


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, June 24, 2014 2:33 PM
    Moderator
    • Management Server web application -> Port81
    • Publishing Server web application -> Port82
    • Reporting Server web application (if installed) -> Port83
    • Default Web site -> Port80

    Registry values are correct

    Wednesday, June 25, 2014 6:30 AM
  • Hello,

    If you open a web-browser and visit the URL of the publishing web server, what happens then?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Wednesday, June 25, 2014 6:20 PM
  • Also we need the output of Get-AppVPublishingServer and Get-AppVClientConfiguration.

    Also verify the client service is starting and verify the AppPool for the publishing service is running in IIS manager.


    Steve Thomas, Senior Consultant, Microsoft

    App-V/MED-V/SCVMM/Server App-V/MDOP/AppCompat

    http://blogs.technet.com/gladiatormsft/
    The App-V Team blog: http://blogs.technet.com/appv/
    The MED-V Team Blog: http://blogs.technet.com/medv
    The SCVMM Team blog: http://blogs.technet.com/scvmm/

    “This posting is provided "AS IS" with no warranties, and confers no rights. User assumes all risks.”

    Wednesday, June 25, 2014 6:30 PM
  • Hi Nicke

    I get following:

    - <Publishing Protocol="1.0">

    <Packages />

    </Publishing>

    Even though I have one application package published I don't see any package ID. Is that okay?
    I also have exactly the same output in our development environment where everything runs fine and we have more than 10 publishe app-v packages



    • Edited by cue0 Thursday, June 26, 2014 7:12 AM
    Thursday, June 26, 2014 7:11 AM
  • Hi Steve

    Meanwhile I found out that everything runs fine if I implement App-V Client settings manually on the RDS Client instead of populating with GPO. I use the same GPO settings like in our development environment where everything runs good.

    Here the desired output (anonymized):

    PS C:\Users\<user>> Get-AppvPublishingServer
    Id                      : 1
    SetByGroupPolicy        : True
    Name                    : <Name>
    URL                     : http://<FQDN>:82
    GlobalRefreshEnabled    : True
    GlobalRefreshOnLogon    : True
    GlobalRefreshInterval   : 1
    GlobalRefreshIntervalUnit                           : Hour
    UserRefreshEnabled      : False
    UserRefreshOnLogon      : False
    UserRefreshInterval     : 1
    UserRefreshIntervalUnit : Hour

    PS C:\Users\<user>> Get-AppvClientConfiguration
    Name                    Value                       SetByGroupPolicy
    ----                    -----                       ----------------
    PackageInstallationRoot D:\App-V\InstallationRoot   True
    PackageSourceRoot       False
    LocationProvider        False
    AutoLoad                2                           True
    EnablePackageScripts    1                           True
    ReestablishmentInterval 5                           False
    ReestablishmentRetries  3                           False
    CertFilterForClientSsl  LOCAL_MACHINE\MY\1.3.6.1.5.5.7.3.2  False
    VerifyCertificateRevocationList                     1 False
    SharedContentStoreMode  0                           False
    MigrationMode           0                           False
    RoamingFileExclusions   False
    RoamingRegistryExclusions                           SOFTWARE\CLASSES    False
    AllowHighCostLaunch     0                           False
    PackageStoreAccessControl                           0 False
    IntegrationRootUser     %localappdata%\Microsoft\AppV\Client...   True
    IntegrationRootGlobal   D:\App-V\RootGlobal         True
    VirtualizableExtensions exe,com,bat,cmd,vbs,ps1,cpl,jar,wsf,...   False
    IgnoreLocationProvider  0                           False
    ReportingEnabled        0                           False
    ReportingStartTime      False
    ReportingRandomDelay    False
    ReportingInterval       False
    ReportingServerURL      False
    ReportingDataCacheLimit False
    ReportingDataBlockSize  False
    ExperienceImprovementOptIn                          0 True
    EnablePublishingRefreshUI                           0 False
    ProcessesUsingVirtualComponents                     {%SystemRoot%\explorer.exe, %Program...                        False
    EnableDynamicVirtualization                         1 False

    • Edited by cue0 Thursday, June 26, 2014 7:39 AM
    Thursday, June 26, 2014 7:32 AM
  • Solution found by myself!

    It was the GPO which applies App-V settings amongst others. Something must have been wrong with it. Since I created a new GPO with exactly same settings everything goes fine.

    I hope this kind of error message won't appear a lot in the future. Otherwise this experience could help others.


    Thursday, June 26, 2014 10:38 AM