locked
Programs and Features list populates very slow more than 3 - 5 minutes RRS feed

  • Question

  • Hi All,

    I am having an inconsistent issue on PC in my organization. I would say at least 85% of the PC's are having this issue.

    Programs and Features list populates very slow. Sometimes it takes more than 3 - 5 minutes to populate the entire list. Most PC's have 61 - 128 items installed. Any ideas on this one?

    Kind Regards,

    Matthew


    Friday, January 29, 2016 6:38 PM

Answers

  • Hi Matthew,

    Thank you for your question.

    We suggest you could refer to the following steps to check if the issue persist:

    1. Turn off the Size column. If you right click the Size column and turn it off, the list will populate just about instantly. For full speed, show only the Name, Publisher, Installed On and Version columns. Once you verified it opens instantly, add back columns that you want and then you can see which columns are the slow ones.
    2. Do a clean boot : https://support.microsoft.com/en-us/kb/929135 
    3. there are some discussion by the following link: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/windows-7-is-very-slow-to-load-and-to-run-programs/f5dc0ac0-e605-41fc-a43a-cd9f3fbf1dcc 

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Monday, February 1, 2016 7:20 AM

All replies

  • Hi Matthew,

    Thank you for your question.

    We suggest you could refer to the following steps to check if the issue persist:

    1. Turn off the Size column. If you right click the Size column and turn it off, the list will populate just about instantly. For full speed, show only the Name, Publisher, Installed On and Version columns. Once you verified it opens instantly, add back columns that you want and then you can see which columns are the slow ones.
    2. Do a clean boot : https://support.microsoft.com/en-us/kb/929135 
    3. there are some discussion by the following link: http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_programs/windows-7-is-very-slow-to-load-and-to-run-programs/f5dc0ac0-e605-41fc-a43a-cd9f3fbf1dcc 

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Monday, February 1, 2016 7:20 AM
  • I have given that a try on 10 PCs. This worked for most of them. Is there a way do turn off the size column using GPO?
    Monday, February 1, 2016 2:57 PM
  • I do not see any columns appear when I try to "Turn Windows features on or off"...just a blank box with a "processing" circle.  However about 10 minutes after I recently tried to activate the process I tried again and it instantly populated...c'est la guerre, I guess.
    Monday, November 20, 2017 9:59 PM