none
BGinfo via GPO overwriting my GPO wallpaper

    Question

  • I have a group policy called Wallpaper and here are my settings:

    Create 4 files (under User Configuration):

    1. BGInfo.exe to C:\temp\BGInfo.exe

    2. ws_bginfo.bgi to C:\temp\ws_bginfo.bgi

    3. wallpaper.jpg to C:\temp\wallpaper.jpg

    3. BGINFO.bat to local Startup folder

    Under User Configuration - AdminTemplate - Desktop - Desktop

    For Desktop Wallpaper I have the path set to C:\temp\wallpaper.jpg and Style is set to Fill

    I save it. Then I have a user log off. After logging back in all the files get created and the wallpaper changes, but as soon as the .bat file runs the wallpaper immediately reverts back to the previous wallpaper, but the information from my ws_bginfo.bgi is on the screen. I log off again and log back on and again the new wallpaper loads, but as soon as the .bat file runs the wallpaper reverts back to the previous.

    If i right click on the desktop and go to Personalization under Desktops it is showing my new wallpaper selected, but that is not what is showing.

    Any ideas on this or what I may be doing incorrectly?

    I'm running Windows Server 2012 R2 and the client machines are currently Windows 7 Professional (soon to all become Win10).

    Thank you for your help!

    Jesse

    Wednesday, April 26, 2017 1:30 AM

All replies

  • Hi Jesse,
    Please have a try the following article step by step to deploy wallpaper with BGInfo, and see if it helps:
    https://dipanmpatel.wordpress.com/2012/09/24/deploying-wallpaper-with-bginfo/
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.
    Best regards, 
    Wendy

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 26, 2017 6:07 AM
    Moderator
  • Hi Jesse,

    I am checking how the issue is going, if you still have any questions, please feel free to contact us.

    And if the replies as above are helpful, we would appreciate you to mark them as answers, and if you resolve it using your own solution, please share your experience and solution here. It will be greatly helpful to others who have the same question.

    Appreciate for your feedback.
    Best regards,

    Wendy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, May 1, 2017 6:23 AM
    Moderator