Unable to remove the policies applied by Organization for PIN length requirements RRS feed

  • Question

  • Dear All, 

    Let me explain the scenario, 

    I just configured work folders in my company Server and successfully connected my Personal Laptop to the Work Folders which i configured, Only for testing purposes. Once i am done with i just removed the work Folders from my Laptop. Later on i just went through the settings on Windows 10 and i could see under Accounts > Sign In Options > Require Sign in option is grayed out and shows the warning "Your Organization requires a password when this PC wakes from sleep". I was frustrated to see this behavior and wanted to set back to the previous case where i could change it. I did multiple things, tried deleting the group policy database file, tried to reset group policy but nothing worked. Later i restored the OS to a previous state and this particular policy restriction didn't show up anymore.

    Happy for that, But when i came down to change my PIN again i could see under PIN Requirements "Your Organization has set the following PIN Requirements, Must be at least 6 Digits long" !!! there it goes, Some restrictions are still there. For resetting this i just went to gpedit.msc and went to the policy "Windows Hello for Business under Admin templates > Windows Components, But there i could not see PIN Complexity option. (Personal Laptop, Non Domain Joined btw) I am not sure if i was doing it right, As next step, i just went to "regedit" HKLM > Policies > Microsoft > and Again "PassportForWork" key was not preset which i created myself and set it to the default value of value not set, Which didn't help either. 

    I just want to get the control back over my machine so any help on resetting the policy to the original will be appreciated. I could not find any thread discussing about this Work Folder policy Removal and i am stuck up. Any help will be appreciated, and I just don't want to Re-Install or Reset the OS. 

    Thanks in Advance. 

    Shadil NK. 

    Saturday, April 22, 2017 7:39 AM

All replies

  • Dear Shadil,

    According to Policy CSP documentation on windows 10 hardware dev says:


    An integer X where 4 <= X <= 16 for mobile devices and desktop. However, local accounts will always enforce a minimum password length of 6.

    But we can use the Local Group Policy Editor to set up PIN complexity, note on 1703 machine, the path is different, which is located in:

    Computer Configuration\Administrative Templates\System\PIN Complexity

    Open group policy editor to configure it.

    Good luck.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 24, 2017 6:56 AM
  • Hi, I tried that, but unfortunately that didn't help. Even after making the changes what you suggested here, If i go back to Change PIN option, I can see under PIN "Your organization has set the following PIN Requirements., which is what i would like to remove.
    Tuesday, May 2, 2017 11:52 AM
  • If your computer has ever joined company's domain and apply company's GPOs, this sentence will appears. Even though you can change group policy now.

    On my 1703 machine, doesn’t join the domain, after I configure Minimum PIN length, set the value as 4, gpupdate/force, I can set my PIN fine, only 4 digits, of course, I don’t see the sentence you mentioned.

    Therefore, if your machine still in domain, the current situation is normal. The simplest method to clear these sentence is system reset, you could choose keep my files option. Otherwise, you need to leave domain and recover all applied GPOs.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, May 9, 2017 9:02 AM
  • Where you can close number pattern (such as 123456 or 1111111)

    i want to use 123456 or 1111111

    • Edited by Ace_Sheep Sunday, July 23, 2017 1:08 PM
    Sunday, July 23, 2017 1:01 PM
  • I have the same damn problem on my system. I tried adding my work account, just for testing, and since then I have this restriction to change my PIN. No matter what I try, I cannot use a 4 digit PIN again. Help needed.
    Thursday, March 8, 2018 5:54 PM
  • I have the same damn problem on my system. I tried adding my work account, just for testing, and since then I have this restriction to change my PIN. No matter what I try, I cannot use a 4 digit PIN again. Help needed.

    +1 here on 2 machines. 6 digit pin enforced on one machine and CAD on another. I was testing by adding the work account and now for the life of me cannot remove these restrictions.
    Monday, March 12, 2018 3:16 AM
  • +1 Added my work account, now for some reasing there's a pin policy that forces me to use 6+ digits, and periodically change my pin.. 
    Saturday, March 24, 2018 7:06 PM
  • +1 We have the same issue.  Our client forces the pin policy on our personal machines and we are unable to remove the pin policy using the method described above.  Is there another way other than Group Policy such as a hidden Registry modification which will allow us to gain control over our machines without a complete reset?
    Saturday, March 31, 2018 11:31 PM
  • I have the same problem. Connected my private - non-domain joined computer - to my work account.

    Removed the work account connection. Now I am forever forced to use 6 digit PINs according to my work policies. I had to wipe and reinstall another computer where I just couldn't live with this 6 digit PIN rule.

    This is ridiculous! Over a year now since this thread started. Several users have the same problem, and not one working solution from Microsoft!

    I work as a consultant and I will now be forced to tell my customers to NOT connect their personal computers to a work account as you may end up in being forced to reinstall the machine completely!

    Come on Microsoft - fix this. It's clearly a bug!

    Sunday, April 22, 2018 12:53 PM
  • I found a solution to this. 

    First remove the PIN option completely and then re-add it. 

    Go to 
    Settings --> Accounts --> Sign in Options --> and under PIN select "I forgot my PIN". 
    Enter your password and then when it asks to enter a new PIN, select Cancel. 

    Then go about re-adding your PIN. It let me add a 4 digit PIN, and not the 6 digit I was being forced to use before,

    • Proposed as answer by C.Venn Sunday, July 15, 2018 4:27 AM
    Wednesday, June 20, 2018 1:38 AM
  • Worked like a charm... thanks
    Saturday, June 30, 2018 5:07 AM
  • It works. Looks like a bug of PIN.
    Sunday, July 15, 2018 4:28 AM
  • Wonderful solution - thank you

    This is dreadful bug that needs to be fixed Microsoft!

    Thursday, March 21, 2019 8:58 PM
  • I am having this issue that once I signed into a work system this week (new prompt showed up) it imposed its pin requirement on me and I cannot seem to remove it.  I have to keep my school account linked to my Microsoft account to use microsoft's Class Notebook program through my course management system.  This is my personal computer.  Would unregistering the computer from my Microsoft account help?  I am used to being able to use facial recognition and fingerprint sign in because my laptop is a convertible and in tablet form entering the pin is less than ideal.  Also the facial recognition is quick if my hands are dirty in the lab and I want the projection to resume.

    Microsoft please help with regedits instead of group policy manager suggestions!

    Tuesday, November 19, 2019 6:14 PM
  • Amazing! Thanks a lot!
    Saturday, November 30, 2019 4:39 PM
  • As suggested try forgot pin and then change it to 4 digits, In case you are using two accounts like one personal account and Work account for official emails, After changing pin it might direct you to your organization page in case SSO is enabled at that point cancel the process and then everything will start working. 

    After leaving domain even my Biometric was not working however that also got resolved. I still see the error message as "Sorry, this PIN isn't working for your organization resources " in the Sign in options window however it is fine with me as now things are working. 

    Friday, August 7, 2020 5:42 AM