locked
Filter Security RRS feed

  • Question

  • I have a Dashboard with a filter that is used to pass a parameter to several PPS charts and several ProClarity reports. 

     

    We use Kerberos.

     

    When I run the Dashboard preview, it works correctly for me.  When I have a user test it, he gets the following security error that I believe is on the filter:

     

    The PerformancePoint Server could not connect to the specified data source. Verify that either the current user or application pool user has Read permissions to the data source, depending on your security configuration. Also verify that all required connection information is provided and correct. Contact the administrator for more details.

     

    I have the user and the application pool account added to the Read permission for both the Dashboard and the Data Source.

     

    Any ideas what is wrong? 

    Friday, August 8, 2008 7:40 PM

Answers

All replies

  • I tried to log into the cube using the service account from the PerformancePoint server application pool via an Excel connection.  I was unable to connect to the cube.  I could see all of our cubes and select the cube during the Excel connection wizard; however, it gave me an invalid user name or password combination when trying to create the pivot table.  It looks like this account is configured correctly but I don't know how to troubleshoot this in SQL Server 2005.

     

    Thoughts?

     

    Friday, August 8, 2008 9:31 PM
  • When I tried the above test, I was using a specific user account and providing the service account userid and password to Excel.  This did not work.

     

    When I logged in as the service account user, I could get to the cube via Excel.  It does not appear to be a SQL configuration issue.

     

    Monday, August 11, 2008 2:57 PM
  • I created several test cases.  It appears this issue only occurs when using a filter.  I can use the same ProClarity or PerformancePoint reports prior to applying a filter and it works correctly. 

     

    In the test case, I am using a simple Member Selection filter against a PerformancePoint view.  It works for me as the administrator but doesn't seem to work for Reader users. 

     

    Is there any special security that needs to be set up to allow a user to use a filter?
    Monday, August 11, 2008 3:00 PM
  • It turns out that there were two problems.

     

    1.  The IIS metadata base was not set to NTLM,Negotiate. - Kerberos Issue

    There is an EXCELLENT Kerberos troubleshooting tool located here:

    http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1434 

     

    2.  We didn't have the user added correctly in SSAS security.

     

    Problem Resolved.

    Friday, August 22, 2008 1:08 AM